VOGONS


First post, by slivercr

User metadata
Rank Member
Rank
Member

Hey vogons, I need help to see if I can fix a motherboard.

The problem is it has stopped working with AGP cards. That's it. It was working fine, then one day I lost video. The board had been recapped and cleaned like 3 years prior to the failure, and it had run smoothly until then.

Things I've noticed since then:

  • It will not boot with the following AGP cards (I'll get no video and the card's fan will not even spin)
    • Geforce2 GTS
    • Geforce3
    • Radeon 8500
    • Geforce FX 5500
    • Radeon 9700
  • It boots fine with PCI video cards.
  • It boots fine with an AGP Voodoo3, this really surprised me.

I always hear how "Voodoo3 and Voodoo5 are not real AGP cards", this really drove it home. I suspect either some failing power rail or some AGP initialization routine, but I haven't really started digging.

Any ideas as to where to start? Any help will be appreciated.

Outrigger: an ongoing adventure with the OR840
QuForce FX 5800: turn your Quadro into a GeForce

Reply 2 of 11, by slivercr

User metadata
Rank Member
Rank
Member
pentiumspeed wrote on 2022-09-21, 23:16:

Check CMOS battery or change it. Reset the CMOS settings too.

Cheers,

Already changed the battery and reflashed the BIOS. Didnt help.

Outrigger: an ongoing adventure with the OR840
QuForce FX 5800: turn your Quadro into a GeForce

Reply 3 of 11, by Namrok

User metadata
Rank Member
Rank
Member

Once I had that problem. Turned out to be my ram. Why would that cause all agp cards to stop working? I assume it's because agp apatures use ram as extra agp vram. But I could be wrong.

Win95/DOS 7.1 - P233 MMX (@2.5 x 100 FSB), Diamond Viper V330 AGP, SB16 CT2800
Win98 - K6-2+ 500, GF2 MX, SB AWE 64 CT4500, SBLive CT4780
Win98 - Pentium III 1000, GF2 GTS, SBLive CT4760
WinXP - Athlon 64 3200+, GF 7800 GS, Audigy 2 ZS

Reply 4 of 11, by slivercr

User metadata
Rank Member
Rank
Member
Namrok wrote on 2022-09-21, 23:47:

Once I had that problem. Turned out to be my ram. Why would that cause all agp cards to stop working? I assume it's because agp apatures use ram as extra agp vram. But I could be wrong.

Will try a few different sticks of RAM and report back.

Outrigger: an ongoing adventure with the OR840
QuForce FX 5800: turn your Quadro into a GeForce

Reply 6 of 11, by slivercr

User metadata
Rank Member
Rank
Member
slivercr wrote on 2022-09-21, 23:58:
Namrok wrote on 2022-09-21, 23:47:

Once I had that problem. Turned out to be my ram. Why would that cause all agp cards to stop working? I assume it's because agp apatures use ram as extra agp vram. But I could be wrong.

Will try a few different sticks of RAM and report back.

No luck—tried all the RAM I had, in different configs. Same deal.

maestro wrote on 2022-09-22, 00:13:

"Voodoo3 and Voodoo5 are not real AGP cards"

Another clue might be that those are 3.3V only cards while the others (i think) are 1.5V capable. Maybe try another 3.3V only card and see if that works?

I thought about this previously, but I have no other "real" 3.3V card to test.
What I did was I faked a 3.3V card by grabbing an old Geforce2 MX and making a small cut to the A2 pin. This sets the card in AGP 2x, so supposedly 3.3V.
I had no luck with that, I'll try to find a real 3.3V AGP card to test out.

EDIT: I guess this is a flawed test, since the card will run at 2x but still at 1.5V. Will make a point to find another 3.3V card.

Outrigger: an ongoing adventure with the OR840
QuForce FX 5800: turn your Quadro into a GeForce

Reply 7 of 11, by maestro

User metadata
Rank Newbie
Rank
Newbie
slivercr wrote on 2022-09-22, 00:34:
I thought about this previously, but I have no other "real" 3.3V card to test. What I did was I faked a 3.3V card by grabbing an […]
Show full quote

I thought about this previously, but I have no other "real" 3.3V card to test.
What I did was I faked a 3.3V card by grabbing an old Geforce2 MX and making a small cut to the A2 pin. This sets the card in AGP 2x, so supposedly 3.3V.
I had no luck with that, I'll try to find a real 3.3V AGP card to test out.

EDIT: I guess this is a flawed test, since the card will run at 2x but still at 1.5V. Will make a point to find another 3.3V card.

It's just an observation, whether it leads somewhere useful is another matter. I also think you're right about the GF2 MX still at 1.5V.

BTW I love your OR840 thread and I'm a big fan of your work. I have two OR840's, a 606 and a 701 revision. The 701 will run 512MB RIMMs but the 606 wont. I think the 701 needs to be recapped, it used to run fine on 4xRIMMS but it has become unstable. It's better on 2xRIMM/2xCRIMM but not 100% stable. I hope it's just a recap. The 701 is pimped with two SL4BS P3's and it's my favourite Voodoo5 board.

DSCF9775.JPG
Filename
DSCF9775.JPG
File size
81.24 KiB
Views
204 views
File license
Fair use/fair dealing exception

Reply 8 of 11, by slivercr

User metadata
Rank Member
Rank
Member
maestro wrote on 2022-09-22, 01:09:

It's just an observation, whether it leads somewhere useful is another matter. I also think you're right about the GF2 MX still at 1.5V.

Thanks for bringing it up, made me think about it.
I'll try to find a TNT—I must have one somewhere—and try out. If the TNT and the Voodoo3 work then its probably just be the 1.5V generation, so a dead MOSFET or something like that

maestro wrote on 2022-09-22, 01:09:

BTW I love your OR840 thread and I'm a big fan of your work. I have two OR840's, a 606 and a 701 revision. The 701 will run 512MB RIMMs but the 606 wont. I think the 701 needs to be recapped, it used to run fine on 4xRIMMS but it has become unstable. It's better on 2xRIMM/2xCRIMM but not 100% stable. I hope it's just a recap. The 701 is pimped with two SL4BS P3's and it's my favourite Voodoo5 board.

Thank you! Glad to see more OR840 users out there… there's dozens of us, dozens!
Have you tried recapping the 606? User doogie had a revision which wasnt compatible with 512MB RIMMs and the only difference seemed to be 270uF caps instead of 470uF caps used in later revisions. I guess what I'm saying is: if you're thinking about recapping one, do them both 🤣

Outrigger: an ongoing adventure with the OR840
QuForce FX 5800: turn your Quadro into a GeForce

Reply 9 of 11, by maestro

User metadata
Rank Newbie
Rank
Newbie
slivercr wrote on 2022-09-22, 01:25:

Thank you! Glad to see more OR840 users out there… there's dozens of us, dozens!
Have you tried recapping the 606? User doogie had a revision which wasnt compatible with 512MB RIMMs and the only difference seemed to be 270uF caps instead of 470uF caps used in later revisions. I guess what I'm saying is: if you're thinking about recapping one, do them both 🤣

Ha, dozens.

No way! Well I'm definitely recapping both then, thanks for that heads up! I'll probably try doing it myself but I don't have any experience, so I have a few boards that I intend to practice recapping before I try an Avenger. I have my eye on an AM2 with bulging capacitors that previously booted but now it doesn't, I think a recap will resurrect it. Man, I wish I had a solder vacuum, maybe I'll look into a cheap one.

Reply 10 of 11, by dionb

User metadata
Rank l33t++
Rank
l33t++

Which board are we talking about here? An OR840 or something else?

If you can't find a 3.3V AGP card, you could work the other way round: stick in a 1.5V card and check on a measuring point on the card whether "1.5V" is within spec.

Reply 11 of 11, by slivercr

User metadata
Rank Member
Rank
Member
dionb wrote on 2022-09-22, 08:09:

If you can't find a 3.3V AGP card, you could work the other way round: stick in a 1.5V card and check on a measuring point on the card whether "1.5V" is within spec.

Yeah, yesterday after maestro's input and me realizing my mistake with the GF2MX test I figured I might as well remove the board from its case and start measuring properly.

I'll check later today and report back. If the 1.5V signaling is failing, then there are a couple possibilities to look into
- Either the VRM generating 1.5V has failed, or
- the switching circuit from 3.3V to 1.5V is failing.
- Or I guess AGP's VREF could also be failing?

These are my uninformed guesses from looking at AGPs pinout, so input is welcome and appreciated!

Outrigger: an ongoing adventure with the OR840
QuForce FX 5800: turn your Quadro into a GeForce