Disable A: and B: drive letters in MS-DOS

Getting old software/games running on older hardware.

Disable A: and B: drive letters in MS-DOS

Postby Doppler » 2018-2-14 @ 06:59

Is it possible to disable or hide A: and B: drive letters in MS-DOS so that they couldnt be accessed and seen in file managers like norton/volkov commander?
I know it's just a visual preference, but still I dont use any diskette drives in my computer so I would be happy to disable these letters :)
Doppler
Member
 
Posts: 118
Joined: 2016-8-04 @ 06:01

Re: Disable A: and B: drive letters in MS-DOS

Postby Kamerat » 2018-2-14 @ 09:29

You can use Drive Letter Manipulator for that purpose.
User avatar
Kamerat
Oldbie
 
Posts: 799
Joined: 2014-3-14 @ 19:09
Location: Oslo, Norway

Re: Disable A: and B: drive letters in MS-DOS

Postby derSammler » 2018-2-14 @ 09:56

Unless a program is badly coded, you should not see A: and/or B: when setting them to "none" in the BIOS.
derSammler
Oldbie
 
Posts: 1610
Joined: 2017-4-14 @ 11:30
Location: Germany

Re: Disable A: and B: drive letters in MS-DOS

Postby Doppler » 2018-2-14 @ 11:35

Kamerat wrote:You can use Drive Letter Manipulator for that purpose.


Thanks! it works! :D
Doppler
Member
 
Posts: 118
Joined: 2016-8-04 @ 06:01

Re: Disable A: and B: drive letters in MS-DOS

Postby Cyberdyne » 2018-2-14 @ 11:44

Sometimes, even DOS is badly coded, and even BIOS is badly coded, and those A and B drive are hard to die form your list.
I am aroused about any X86 stuff that has full functional ISA stuff. I think i have problem.
User avatar
Cyberdyne
Member
 
Posts: 289
Joined: 2011-9-18 @ 18:45
Location: Estonia, Tallinn

Re: Disable A: and B: drive letters in MS-DOS

Postby Kamerat » 2018-2-14 @ 18:33

Doppler wrote:Thanks! it works! :D

Nice! :D Used it myself to remove ghost floppy drives from Windows 98SE, just ran it from autoexec.bat before Windows booted.
User avatar
Kamerat
Oldbie
 
Posts: 799
Joined: 2014-3-14 @ 19:09
Location: Oslo, Norway

Re: Disable A: and B: drive letters in MS-DOS

Postby Doppler » 2018-2-16 @ 07:41

Reporting back with more tests.

Unfortunately it works only under volkov commander. In Dos Navigator and others similar file managers, the A letter is still visible, no matter what. Look like I'll have to live with it :) But anyway, thanks one more time!
Doppler
Member
 
Posts: 118
Joined: 2016-8-04 @ 06:01


Return to Software

Who is online

Users browsing this forum: No registered users and 2 guests