VOGONS


First post, by alexclaudiu2003

User metadata
Rank Newbie
Rank
Newbie

does anyone know how I can turn off this annoying message?
Program Requires MS-DOS Mode
may not run well unless it is run in MS-DOS mode. Do you want to change its shortcut properties to make it always run in MS-DOS mode?

appears in very few games, an example is Prehistorik 1
The OS is Windows Millennium

Attachments

Reply 1 of 13, by BloodyCactus

User metadata
Rank Oldbie
Rank
Oldbie

run the game from real dos instead of windows. problem solved.

--/\-[ Stu : Bloody Cactus :: http://kråketær.com :: http://mega-tokyo.com ]-/\--

Reply 3 of 13, by alexclaudiu2003

User metadata
Rank Newbie
Rank
Newbie

I searched a lot and found nothing on how to disable that message,
after pressing NO, the message disappears and the game works perfectly.
To run in real dos, it means shutting down all applications and boot to ms-dos from cd,
instead to click, play, play another game, listen music, etc.

Reply 5 of 13, by Tiido

User metadata
Rank l33t
Rank
l33t

Go to program properties and untick the warning message and perhaps tick "prevent ms-dos progams from detecting windows", a PIF file is saved that windows will use next time.

T-04YBSC, a new YMF71x based sound card & Official VOGONS thread about it
Newly made 4MB 60ns 30pin SIMMs ~
mida sa loed ? nagunii aru ei saa 😜

Reply 6 of 13, by Caluser2000

User metadata
Rank l33t
Rank
l33t

Let win9x run it from does or go directly to the Dos prompt and run it.

There's a glitch in the matrix.
A founding member of the 286 appreciation society.
Apparently 32-bit is dead and nobody likes P4s.
Of course, as always, I'm open to correction...😉

Reply 7 of 13, by Grzyb

User metadata
Rank Oldbie
Rank
Oldbie

Isn't it amusing that MS-DOS Mode is suggested by Windows ME, which... lacks MS-DOS Mode? 😁
Yet another example of how screwed up ME is...

Reply 9 of 13, by Grzyb

User metadata
Rank Oldbie
Rank
Oldbie
dr_st wrote on 2020-05-23, 09:03:

WinME doesn't lack MS-DOS mode; it just lacks the ability to boot into pure DOS without running Windows first.

You mean Windows ME in its original form, without any patches or special registry settings?
If so, then how to access that MS-DOS Mode? Does it allow to load DOS device drivers?

Reply 10 of 13, by dr_st

User metadata
Rank l33t
Rank
l33t

Apologies; apparently my memory deceived me. Indeed the "restart in MS-DOS mode" is not available in WinME (without hacking). I rarely used this mode at all (even in 98SE), and somehow I thought it was still around.

https://cloakedthargoid.wordpress.com/ - Random content on hardware, software, games and toys

Reply 11 of 13, by alexclaudiu2003

User metadata
Rank Newbie
Rank
Newbie

I meant if that message in the image above it can be hidden or disabled from an advanced setting of the operating system because after closing the message, the game runs perfectly.

Reply 12 of 13, by Kalle

User metadata
Rank Newbie
Rank
Newbie

Windows 98 did offer options regarding the MS-DOS mode (by default, "Suggest MS-DOS mode" is ticked, which is very likely the option that triggers the message you're getting).
Win ME however got rid of those advanced options (they used to be in the program tab, after you rightclick the exe and select properties), but the information inside the pif file is still there. I don't know if a standalone pif editor exists for 9x, but you could also edit it with a hex editor, basically it's 1 byte you need to alter.
You'll find it in the "WINDOWS 386 3.0" section, offset 0x29 from the beginning of this section (so if it starts at 0x187, you'll find the byte at 0x1B0). Change it from 00 to 04, that should do the trick.