VOGONS


Reply 20 of 32, by mothergoose729

User metadata
Rank Oldbie
Rank
Oldbie
Gona wrote on 2021-05-18, 21:14:
Cloudschatze wrote on 2021-05-18, 20:40:

Something is wrong with DSMI's SB16 detection routine in Aladdin. I can't speculate as to what. Here's a workaround config file though, concerning a SB16 configured with IRQ5 and high-DMA channel 5. (Byte 0x25 is the IRQ, and byte 0x26 is the DMA channel, if your SB16 is configured otherwise.)

Enjoy 16-bit @ 44.1kHz stereo output with your SB16, or something.

Wow! Great job!Aladdin_SB16_(patched_by_Cloudschatze)_-_on_-_SB16_CT2230_rev02.ogg

Is it also a detection problem when selecting SB Pro in Aladdin the SB16 works as mono?

That sounds great! Even a bit better than WSS I'd say... more filtered but without being muddy.

Reply 21 of 32, by Cloudschatze

User metadata
Rank Oldbie
Rank
Oldbie
Gona wrote on 2021-05-18, 21:14:

Is it also a detection problem when selecting SB Pro in Aladdin the SB16 works as mono?

Detection aside, the stereo PCM playback method used by the Sound Blaster Pro isn't supported by, or compatible with, the SB16.

mothergoose729 wrote on 2021-05-18, 21:27:
Gona wrote on 2021-05-18, 21:14:

Wow! Great job!Aladdin_SB16_(patched_by_Cloudschatze)_-_on_-_SB16_CT2230_rev02.ogg

That sounds great! Even a bit better than WSS I'd say... more filtered but without being muddy.

Here are a couple of FLAC recordings from my CT3980 for comparison, using an optimized mixer configuration:

http://www.symphoniae.com/misc/vogons/aladdin … tle_ct3980.flac (8.48MB)
http://www.symphoniae.com/misc/vogons/aladdin … ket_ct3980.flac (25.6MB)

Reply 22 of 32, by Gona

User metadata
Rank Member
Rank
Member
Cloudschatze wrote on 2021-05-18, 22:12:

Detection aside, the stereo PCM playback method used by the Sound Blaster Pro isn't supported by, or compatible with, the SB16.

Thank you.

Cloudschatze wrote on 2021-05-18, 22:12:

Here are a couple of FLAC recordings from my CT3980 for comparison, using an optimized mixer configuration:

http://www.symphoniae.com/misc/vogons/aladdin … tle_ct3980.flac (8.48MB)
http://www.symphoniae.com/misc/vogons/aladdin … ket_ct3980.flac (25.6MB)

Best! For me the CT3980 is the best AWE32 because this is the last one with true Yamaha OPL chip: CT1747 (made by Yamaha in Japan). Later Creative cards has no true OPL chip just a clone one which sounds different in OPL3 FM sound (but with Aladdin this does not matter because Aladdin uses PCM). And also CT3980 using the newer CT1703-A DAC which has less self noise than earlier Creative DAC chips (my early revision CT2230 using the more noisy CT1703-T as early AWE32s too, but later CT2230s are using also the better CT1703-A DAC).

Video card compatibility matrix for DOS games | ATI3DCIF compatibility matrix | CGL API compatibility matrix

Reply 23 of 32, by Joseph_Joestar

User metadata
Rank l33t
Rank
l33t
Cloudschatze wrote on 2021-05-18, 20:40:

Something is wrong with DSMI's SB16 detection routine in Aladdin. I can't speculate as to what. Here's a workaround config file though, concerning a SB16 configured with IRQ5 and high-DMA channel 5.

Excellent work Cloudschatze!

I just tested your modified sound.cfg on my AWE64 and can confirm that it now plays beautiful stereo music. Thanks for looking into this!

PC#1: Pentium MMX 166 / Soyo SY-5BT / S3 Trio64V+ / Voodoo1 / OPTi 82C930 / AWE64 Gold / SC-155
PC#2: AthlonXP 1700+ / Abit KT7A / Voodoo3 / SBLive / Vortex2
PC#3: Athlon64 3000+ / Asus K8V-MX / GeForce4 / Audigy1
PC#4: i5-3550P / MSI Z77A-G43 / GTX 650Ti / X-Fi

Reply 24 of 32, by Cloudschatze

User metadata
Rank Oldbie
Rank
Oldbie

So, here's another, uh... workaround. For whatever reason, the SB16 output rate doesn't reflect what is defined in the SOUND.CFG file (44100), and is instead fixed at 42kHz. For legit 44.1kHz output, modify the two bytes at 0x1A88F in ALADDIN.EXE from 08 52 to 22 56.

Reply 25 of 32, by Cyberdyne

User metadata
Rank Oldbie
Rank
Oldbie

Vogons is a wonderful place, we fix and update things that have been broken or need an update for over 25 years.

I am aroused about any X86 motherboard that has full functional ISA slot. I think i have problem. Not really into that original (Turbo) XT,286,386 and CGA/EGA stuff. So just a DOS nut.

Reply 26 of 32, by keropi

User metadata
Rank l33t++
Rank
l33t++
mothergoose729 wrote on 2021-05-16, 20:53:

On my Orpheus sound card WSS music never plays after the title screen. Sound blaster pro music is clean and stereo. In general, I have noticed that WSS sounds when mixed in 8 bit sounds similar to sound blaster pro 2, at least on my card, but slightly less filtered/cleaner.

I just saw this and gave the game a go on my 386 system... I get full music in title screen, load screen and level 1 with WSS selected and the Orpheus
System had ~610kb free conventional (not hard to achieve since the game requires EMS) and the only thing that needed attention was to enter the WSS port on SETSND at $530 - and not $534 like the ULTRA16 variable.
Also extended music was selected (gives the warning about needed more ram)

Other than that it all seemed fine , you can really tell the music plays at a higher rate than sbpro option.

🎵 🎧 PCMIDI MPU , Orpheus Soundcard , Action Rewind and Megacard website

Reply 27 of 32, by Joseph_Joestar

User metadata
Rank l33t
Rank
l33t
Cloudschatze wrote on 2021-05-20, 02:21:

For whatever reason, the SB16 output rate doesn't reflect what is defined in the SOUND.CFG file (44100), and is instead fixed at 42kHz. For legit 44.1kHz output, modify the two bytes at 0x1A88F in ALADDIN.EXE from 08 52 to 22 56.

Interesting find!

Does this bug also occur when WSS or PAS16 are selected?

PC#1: Pentium MMX 166 / Soyo SY-5BT / S3 Trio64V+ / Voodoo1 / OPTi 82C930 / AWE64 Gold / SC-155
PC#2: AthlonXP 1700+ / Abit KT7A / Voodoo3 / SBLive / Vortex2
PC#3: Athlon64 3000+ / Asus K8V-MX / GeForce4 / Audigy1
PC#4: i5-3550P / MSI Z77A-G43 / GTX 650Ti / X-Fi

Reply 28 of 32, by mothergoose729

User metadata
Rank Oldbie
Rank
Oldbie
keropi wrote on 2021-05-20, 07:09:
I just saw this and gave the game a go on my 386 system... I get full music in title screen, load screen and level 1 with WSS se […]
Show full quote
mothergoose729 wrote on 2021-05-16, 20:53:

On my Orpheus sound card WSS music never plays after the title screen. Sound blaster pro music is clean and stereo. In general, I have noticed that WSS sounds when mixed in 8 bit sounds similar to sound blaster pro 2, at least on my card, but slightly less filtered/cleaner.

I just saw this and gave the game a go on my 386 system... I get full music in title screen, load screen and level 1 with WSS selected and the Orpheus
System had ~610kb free conventional (not hard to achieve since the game requires EMS) and the only thing that needed attention was to enter the WSS port on SETSND at $530 - and not $534 like the ULTRA16 variable.
Also extended music was selected (gives the warning about needed more ram)

Other than that it all seemed fine , you can really tell the music plays at a higher rate than sbpro option.

Thanks keropi! I'll have to give it another shot.

Reply 29 of 32, by DesktopDynamite

User metadata
Rank Newbie
Rank
Newbie

Hi all, stumbled upon this thread as my issue is that I don't have any sound at all.

Specs:
Asus P3B-F slot 1 Intel 440bx
500Mhz Katmai PIII
512MB RAM
OS WIN98SE and also MS-DOS 6.22 with Phil's starter pack.
Voodoo 3 2000 PCI
Sound card = Creative AWE64 CT4520 ISA
I also have the Yamaha YMF-V724 PCI but removed it to rule out any issues.

I have tried both Aladdin demo and original floppy disk version and I have no sound. Correct drivers are installed under MS-DOS too after following Phil's tutorial.

What else should I check?
Awe64 in DOS and Win98SE reports the following: A220, IRQ5, DMA1.

Other games such as lion King does have sound.

Thanks!

Reply 31 of 32, by DesktopDynamite

User metadata
Rank Newbie
Rank
Newbie
dr_st wrote on 2022-05-15, 04:10:

Just to double-check: did you run SETSND from the game's directory to configure sound?

Yes, I am choosing option number 4, 220h, IRQ5 DMA1, also tried a couple of other options.

Attached first photo is the options list available in the demo version of the game [aladdin].

Now googling found a different set of options as shown in the second photo [DISNEYS ALLADIN SOUND SETTINGS]...

Attachments