VOGONS


First post, by Almoststew1990

User metadata
Rank Oldbie
Rank
Oldbie

I'm building a general DOS PC around an MSI 440BX Chipset motherboard. I will be using an AWE32 for most of the sound, but was wondering if I could use my Soundblaster 2 (which has the CMS chips in it) for GameBlaster sound at the same time?

The PSU I will be using won't have a -5v rail. I know this causes issues when using the SB2.0 for soundblaster sound, but does it also cause issues when using CMS sound?

Ryzen 3700X | 16GB 3600MHz RAM | AMD 6800XT | 2Tb NVME SSD | Windows 10
AMD DX2-80 | 16MB RAM | STB LIghtspeed 128 | AWE32 CT3910
I have a vacancy for a main Windows 98 PC

Reply 1 of 8, by gdjacobs

User metadata
Rank l33t++
Rank
l33t++
Almoststew1990 wrote on 2020-04-29, 13:43:

but was wondering if I could use my Soundblaster 2 (which has the CMS chips in it) for GameBlaster sound at the same time?

The PSU I will be using won't have a -5v rail. I know this causes issues when using the SB2.0 for soundblaster sound, but does it also cause issues when using CMS sound?

I'd expect lack of -5V to be a problem for you. A lot of early sound card pre-amps like a double ended supply.

All hail the Great Capacitor Brand Finder

Reply 2 of 8, by dionb

User metadata
Rank l33t
Rank
l33t

Aside from the -5V issue: certainly.

Just be sure to set them on different resources. The SB2.0 with CMS is from a time when more titles required default settings, so I'd do the most compatible ones there and fit the AWE32 around it:

SB2.0:
A220 I7 D1 T3
AEW32:
A240 I5 D3 (or 0) T6 H5 (or 6 or whatever) P330 E620

Reply 3 of 8, by MKT_Gundam

User metadata
Rank Member
Rank
Member

Is true the Sb 2.0 dont likes fast cpu as P1MMX?

Retro rig 1: Asus CUV4X, VIA c3 800, Voodoo Banshee (Diamond fusion) and SB32 ct3670.
Retro rig 2: Intel DX2 66, SB16 Ct1740 and Cirrus Logic VLB.

Reply 4 of 8, by digistorm

User metadata
Rank Member
Rank
Member

I know that some SB Pro routines don’t like fast CPU’s, even on a SB16. Sometimes you need to disable the L1 cache to get it to work. Also some OPL3 software doesn’t like fast CPU’s.

Reply 5 of 8, by fitzpatr

User metadata
Rank Member
Rank
Member

You absolutely need -5V for CMS on an SB 2.0. There are adapter cables that can generate it when going from ATX to AT, but I can't find anything on ATX to ATX. It is a very simple circuit with an LM 7905 Voltage Regulator, so if you really want to do it this way, you could make one yourself.

CPU speed will likely also be an issue with the card.

MT-32 Old, CM-32L, CM-500, SC-55mkII, SC-88Pro, SC-D70, FB-01, MU2000EX
K6-III+/450/GA-5AX/G400 Max/Voodoo2 SLI/CT1750/MPU-401AT/Audigy 2ZS
486 Build

Reply 7 of 8, by Grzyb

User metadata
Rank Oldbie
Rank
Oldbie
dionb wrote on 2020-04-30, 20:24:
Just be sure to set them on different resources. The SB2.0 with CMS is from a time when more titles required default settings, s […]
Show full quote

Just be sure to set them on different resources. The SB2.0 with CMS is from a time when more titles required default settings, so I'd do the most compatible ones there and fit the AWE32 around it:

SB2.0:
A220 I7 D1 T3
AEW32:
A240 I5 D3 (or 0) T6 H5 (or 6 or whatever) P330 E620

What about 388h ?
Which of the cards is going to handle that?

Reply 8 of 8, by TechieDude

User metadata
Rank Member
Rank
Member
Grzyb wrote on 2020-05-02, 14:50:

What about 388h ?
Which of the cards is going to handle that?

Both, actually. When a program writes to 388h (OPL2/OPL3), they will both output FM Music simultaneously regardless of other settings, as long as there aren't any other conflicts. Freaking laptop keyboard.