VOGONS


First post, by aigeek

User metadata
Rank Newbie
Rank
Newbie

ExpertMedia MED1600 is OPTI82C928 + AD1848
also with FCCID K2Y-AUDIO16C just like OPTI MAD16 82C928+ CS4231
Look good with WaveTable head and OPL3 clone IC

MED1600.jpg
Filename
MED1600.jpg
File size
849.59 KiB
Views
326 views
File license
CC-BY-4.0
MAD16_OPTI82C928_CS4231.jpg
Filename
MAD16_OPTI82C928_CS4231.jpg
File size
180.4 KiB
Views
279 views
File license
Public domain

There are none factory driver on net
And it may suit with part of OPTI MAD16 82C928+ CS4231 driver,
it can boot on and setup the card
but in SNDINIT setup program,
8bit and 16bit digital sound test just begin then stop and report error.
The FM music test is OK.

In game such as DOOM2,
setup sound with SB will get no sound,
setup music with SB or adlib is OK.

Maybe the Codec IC AD90609/1848 is NOT been setup correctly?
Anyone can help with this card?

Last edited by aigeek on 2021-11-09, 01:53. Edited 1 time in total.

Reply 2 of 7, by aigeek

User metadata
Rank Newbie
Rank
Newbie
Schule04 wrote on 2021-11-08, 15:55:

Thank you. Yes I have tried it and got the results above. Not sure if it supports both CS4231 and AD1848 codec

Reply 3 of 7, by cyclone3d

User metadata
Rank l33t++
Rank
l33t++

Ok, so according to the soundcard-drivers.com archive, the original driver filename was 925d_w.exe

driver_file.JPG
Filename
driver_file.JPG
File size
49.72 KiB
Views
270 views
File license
Public domain

Trying to track down a copy now... I may already have it somewhere.

Edit: Looks like vogonsdrivers has a file named that:
http://vogonsdrivers.com/getfile.php?fileid=792&menustate=0

Should be the same as the file here I am guessing... file contents look the same as the soundcard-drivers page:
http://files.mpoli.fi/unpacked/hardware/sound … ip/_925d_w.exe/

Seems kinda sketchy since the file name indicates it is for the 925 and not the 928 but no harm in trying.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header

Reply 4 of 7, by mkarcher

User metadata
Rank Oldbie
Rank
Oldbie

Everything you post about the behaviour points to an IRQ problem. If the test sounds starts to play, DMA and codec initialization work fine. The AD1848 chip only has a single interrupt pin, the OPTi pin is responsible for mapping the interrupt to the selected ISA IRQ pin. Try using a different digital sound IRQ. If that helps, check the ISA IRQ contacts for broken traces.

Reply 5 of 7, by Thermalwrong

User metadata
Rank Oldbie
Rank
Oldbie

Check out the Shuttle HOT-223, it's essentially that card, with the big ol' Opti 82C928 chip and an AD1848 codec:
https://archive.shuttle.eu/2004/de/223.htm

I tried out different drivers from mpoli.fi and found the set on this page (3.01) are the same as I'm running on my 386SX system. In that system, the card works perfectly with what I've tested it with so far. Really nice clean audio and doesn't need the -5v line.

Attachments

Reply 6 of 7, by pc-sound-legacy

User metadata
Rank Member
Rank
Member

Beautiful and rare card! Opti aquired the sound department of OTI/OAK and the 928 is the successor of the Mozart card and OptIs first sound-IC. Therefore, I wonder if one of the expansion headers might be for the OPL4 add on that was planed but presumably never released. The other header is a waveblaster header but as far as I remember it is not mpu401 compliant.