VOGONS


First post, by Meatball

User metadata
Rank Oldbie
Rank
Oldbie

Before I send this away for fixing, I thought someone here might be able to tell me something obvious I am overlooking.

This Obsidian2 has only output and no passthrough - it's from an Arcade unit. Windows sees the card and drivers for Voodoo2 or Obsidian install OK. The drivers which work best are Obsidian2 Release 6C or Fast Voodoo 4.6, and that only means I've gotten the furthest functionality with them. Others probably work fine, but I'd have to reformat the system each time to try a different driver, OS, and DirectX combination.

Monitor 1 (LCD) is connected to a Riva 128ZX (which looks plain awful on an LCD, but fine on CRT.. I digress..)
Monitor 2 (CRT) is connected to the Obsidian 2 90-2440.

Anyway, all the control panel items show up for Voodoo2 drivers. When I activate 3D, I can see the card doing "something" from monitor 1. When I run DXdiag, the spinning cube runs, but I can't see anything - monitor 2 never engages. When I tried Turok in Benchmark mode, same thing. Monitor 1 shows "Glide 3D DLL initialized..." but nothing shows up on monitor 2. I can hear the game running, though.

10MB Total memory
2MB Frame Buffer
4MB per TMU (2x)

Does anyone have any ideas what is going on or what I am missing?

Thanks much!

Attachments

***->WINNER, 1ST PLACE<-***
2022 #QUAKE3totheMAX -560.5fps-
Brain Drain Retro LAN https://discord.com/channels/799008837918261328
Windows ME
NForce2 A7N8X-E DLX
Athlon 848/154MHz
DDR@411MHz (2-3-3-3)
GeForce 256 DDR@144/344MHz
ESS Maestr0-1

Reply 1 of 8, by weedeewee

User metadata
Rank Oldbie
Rank
Oldbie

That bodge transistor doesn't look very well. Is it the photo angle or... ?

Right to repair is fundamental. You own it, you're allowed to fix it.
How To Ask Questions The Smart Way
Do not ask Why !

Reply 2 of 8, by sdz

User metadata
Rank Member
Rank
Member

Looks weird indeed, like it's missing 1 leg. Maybe it's a diode and doesn't need the third leg.

@Meatball do you have an oscilloscope? If the card doesn't throw any errors it's probably mostly OK. I had a card with the exact behaviour as yours, it was missing hsync or vsync, don't recall which one.

Reply 3 of 8, by Meatball

User metadata
Rank Oldbie
Rank
Oldbie
weedeewee wrote on 2022-05-29, 18:36:

That bodge transistor doesn't look very well. Is it the photo angle or... ?

I'm not quite sure what a Bodge Transistor is, but if you're talking about the goofy-looking fix near the RAM, it seems it was from the factory to address a bug.

https://thandor.net/object/105

***->WINNER, 1ST PLACE<-***
2022 #QUAKE3totheMAX -560.5fps-
Brain Drain Retro LAN https://discord.com/channels/799008837918261328
Windows ME
NForce2 A7N8X-E DLX
Athlon 848/154MHz
DDR@411MHz (2-3-3-3)
GeForce 256 DDR@144/344MHz
ESS Maestr0-1

Reply 5 of 8, by Meatball

User metadata
Rank Oldbie
Rank
Oldbie
sdz wrote on 2022-05-29, 19:00:

Looks weird indeed, like it's missing 1 leg. Maybe it's a diode and doesn't need the third leg.

@Meatball do you have an oscilloscope? If the card doesn't throw any errors it's probably mostly OK. I had a card with the exact behaviour as yours, it was missing hsync or vsync, don't recall which one.

I don't have one. I see them on Amazon for less than $50. Are these good enough? Is it good to have one around, in general?

***->WINNER, 1ST PLACE<-***
2022 #QUAKE3totheMAX -560.5fps-
Brain Drain Retro LAN https://discord.com/channels/799008837918261328
Windows ME
NForce2 A7N8X-E DLX
Athlon 848/154MHz
DDR@411MHz (2-3-3-3)
GeForce 256 DDR@144/344MHz
ESS Maestr0-1

Reply 6 of 8, by Meatball

User metadata
Rank Oldbie
Rank
Oldbie
pentiumspeed wrote on 2022-05-29, 19:08:

Make sure this bodge fix's transistor's third leg is not broken off.

Cheers,

Thanks for the suggestion - I have checked with a magnifying glass, and I tapped each leg to check for any movement. All 3 legs are secure.

***->WINNER, 1ST PLACE<-***
2022 #QUAKE3totheMAX -560.5fps-
Brain Drain Retro LAN https://discord.com/channels/799008837918261328
Windows ME
NForce2 A7N8X-E DLX
Athlon 848/154MHz
DDR@411MHz (2-3-3-3)
GeForce 256 DDR@144/344MHz
ESS Maestr0-1

Reply 8 of 8, by rasz_pl

User metadata
Rank Oldbie
Rank
Oldbie
Meatball wrote on 2022-05-29, 19:12:

I don't have one. I see them on Amazon for less than $50. Are these good enough?

no

Meatball wrote on 2022-05-29, 19:12:

Is it good to have one around, in general?

no if you have to ask

Find a HAM or hackerspace near you, ask nicely for a favor, offer box of chocolates or a 6pack 😀. What you want is looking at VGA outputs, and RAMDAC inputs/outputs with https://retronn.de/ftp/docs/pc_hardware/DACs/ICS5342.pdf in hand