VOGONS

Common searches


First post, by Rekrul

User metadata
Rank Member
Rank
Member

(System specs below)

I've had Undying for a while and finally decided to play it. I installed the game, which is already patched to the most recent version.

When just walking through an empty room, the game stutters briefly every few seconds. When a creature appears and/or I fire the gun, the entire game comes to a standstill for a couple of seconds. It stutters so badly that the game is basically unplayable.

I started out using version 82.16 of the Nvidia drivers, but the game was crashing every couple of minutes. I downgraded the drivers to 56.64 and this fixed the crashing issue, but the game still stutters. I downgraded because I tried to play Unreal Gold again and it was crashing with the same error as Undying and I knew it used to work perfectly. Unreal and Undying supposedly use the same engine, but Ureal runs perfectly with huge levels and Undying runs like crap with TINY load zones. I've also played Deep Space 9 The Fallen, which uses the Unreal engine and that ran fine.

I've set the resolution to the smallest size available, turned off shadows and anything else that can be disabled, changed the audio options between software and hardware, etc. Nothing helps.

No other game has ever performed this badly on my system.

EA Tech support was no help. After explaining the problem in detail, including the fact that it crashes under the later driver versions, they suggested that I update the graphic drivers. 😠

My system;

Motherboard: Intel D845PESV
CPU: Pentium 1.8Ghz
RAM: 512MB
OS: Windows 98SE
Graphics: GeForce4 MX440 64MB RAM
Sound: Onboard with SoundMax drivers (latest)

Reply 1 of 11, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Wow, what is this 2001?

Tried different renderers? OGL/D3D/Glide?
Disable/Enable Vsync?
Defragged your HD?

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 2 of 11, by ADDiCT

User metadata
Rank Oldbie
Rank
Oldbie

According to MobyGames, the game should run on the system. But there are a lot of variables. First, your graphics cards is abysmal slow. Second, you didn't give your exact CPU type. I guess it's a Celeron, which is not good at all for gaming.

You should try what DosFreak suggests. Besides, you should consider installing XP on the machine - it should be capable of running it OK. The game is based on the "Unreal1"-engine, so there may be alternate renderers available. It's been a while since i last fiddled with Unreal, but i remember downloading alternative (unofficial) rendering DLL's, which were supposed to give better speed. My gut feeling says your system is simply too slow to run the game at full fps, though.

Reply 4 of 11, by ADDiCT

User metadata
Rank Oldbie
Rank
Oldbie
F2bnp wrote:

Um his system is way past the requirements of the game.

How naive... Try playing a few games on a machine meeting the stated minimum system requirements (and that's what they are, no more, no less), and you'll quickly learn that these requirements are very often quite unrealistic. Companies want to sell games, so they'll give the lowest possible system specs, even though a game may run like a slideshow. Besides, PC's are complex - a bad motherboard/chipset, slow hd, badly configured system etc. can make a game run very badly, even though system requirements are met. And don't get me started on bad/non-optimized coding...

Reply 5 of 11, by Rekrul

User metadata
Rank Member
Rank
Member
DosFreak wrote:
Wow, what is this 2001? […]
Show full quote

Wow, what is this 2001?

Tried different renderers? OGL/D3D/Glide?
Disable/Enable Vsync?
Defragged your HD?

I tried the software renderer and the stuttering wasn't quite as bad, but it was still there. Also, there were numerous rendering errors, like the tops of tables and beds being transparent. I'm not sure how to disable/enable Vsync. Defragging the HD shouldn't make a difference because the game doesn't load while you're playing.

ADDiCT wrote:

According to MobyGames, the game should run on the system. But there are a lot of variables. First, your graphics cards is abysmal slow. Second, you didn't give your exact CPU type. I guess it's a Celeron, which is not good at all for gaming.

As far as I know, the CPU isn't a Celeron, it's a full, standard Pentium 4 chip. I know my graphics card isn't the best, but this still doesn't make any sense. Unreal has HUGE levels, while the levels in Undying are, to be blunt, pathetically small. Most of the load zones consist of a hallway and one or two rooms. I love exploring in games, but Undying actually discourages exploration because practically every time you walk through a doorway, you get the Loading screen.

ADDiCT wrote:

The game is based on the "Unreal1"-engine, so there may be alternate renderers available. It's been a while since i last fiddled with Unreal, but i remember downloading alternative (unofficial) rendering DLL's, which were supposed to give better speed.

I've tried the software renderer, which was actually slightly better, but looked ugly. Undying also supports Glide, but I don't have a card that supports Glide. My attempts to run most commercial games using a Glide wrapper have been disappointing to say the least. There's no option to use OpenGL that I can see.

ADDiCT wrote:

My gut feeling says your system is simply too slow to run the game at full fps, though.

I highly doubt that. The load zones in Undying are tiny, and while the game looks nice, it doesn't exactly have photo-realistic graphics. I've played many other games with levels that dwarf those in Undying, have more detailed graphics and larger numbers of enemies onscreen, and they didn't even flinch on this system. For example, I've played Max Payne 2 (full physics engine), Jedi Academy, Halo (had to turn off particle effects), Serious Sam the Second Encounter (HUGE outdoor levels and ridiculous amounts of enemies at once as well as some gigantic creatures) and others.

Compared to them, Undying has tiny levels and low numbers of enemies. If my system were the problem, those games should be giving problems as well, but they don't. Granted, I don't usually max out all the settings and set them to a giant resolution, but Undying doesn't run properly at even the lowest settings.

Reply 6 of 11, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Try here: http://cwdohnal.home.mindspring.com/utglr/

Undying isn't mention but it's the same engine so they may work.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 7 of 11, by Davros

User metadata
Rank l33t
Rank
l33t

my settings in undying/system/system.ini

[D3DDrv.D3DRenderDevice]
Translucency=True
VolumetricLighting=True
ShinySurfaces=True
Coronas=True
HighDetailActors=True
UseMipmapping=True
UseTrilinear=True
UseMultitexture=True
UsePageFlipping=True
UsePalettes=False
UseFullscreen=True
UseGammaCorrection=True
DetailTextures=True
Use3dfx=False
UseTripleBuffering=True
UsePrecache=True
Use32BitTextures=True
DescFlags=1
UseVertexFog=True
dwDeviceId=20040
dwVendorId=4098
UseAGPTextures=False
UseVideoMemoryVB=False
UseVSync=False
Description=RADEON 9800 PRO

Guardian of the Sacred Five Terabyte's of Gaming Goodness

Reply 8 of 11, by Rekrul

User metadata
Rank Member
Rank
Member
DosFreak wrote:

Try here: http://cwdohnal.home.mindspring.com/utglr/

Undying isn't mention but it's the same engine so they may work.

Thanks. I've downloaded the files and bookmarked that page for future reference although at the moment, it doesn't look like I'll need them. I appreciate the information though.

Davros wrote:

my settings in undying/system/system.ini

[Settings removed to save space]

Changing to your settings seems to have fixed the problem. I haven't tested it extensively, but there was no stutter while walking around or during the 2-3 attacks I managed to survive (until something larger took my head off). 😀

My original settings were almost the same as yours, but with a five differences;

UseTrilinear=False
UsePalettes=True
DetailTextures=False
dwDeviceId=385
dwVendorId=4318

I never changed anything in System.ini manually, so those are the settings that the program thought would be best for my system.

I'll have to experiment to see which one of those made the difference.

I'll also be starting over from the beginning, so that I can enjoy the parts I struggled through the first time (not that I got very far).

Thanks again!

Reply 9 of 11, by ADDiCT

User metadata
Rank Oldbie
Rank
Oldbie

Just a small addition: i was referring to an alternate renderer for Unreal, not the software renderer. I think there are various of these out there, here is one i found with a simple Google search.

Reply 10 of 11, by dr.zeissler

User metadata
Rank l33t
Rank
l33t

Though it's an old one, but I am standing right at the same problem. I am using an Scenic-S2 D1381 P4 System i845gv.
Win98se is installed and I am using Dx8.1. My gfx card is a GF6200/256MB AGP-LP.
Only the FSC-Drivers for the soundmax do work with this board. Every other SoundMax-Drivers 3/4 etc. I have tested, do not work.

There are a lot of games that have crackeling, soundstuttering like Rune/Unreal/etc.

What can I do? there is no way of putting an soundcard in that system.

Retro-Gamer 😀PowerMac 6100-66/Houdini 486/66 - G4 Cube 450/Rage128pro OS9.0.1 - Macintosh LC/Apple IIe Card OS6.0.8 - Acorn A4000 Archimedes - Unisys CWD 486/66 + Aztech Washington

Reply 11 of 11, by hail-to-the-ryzen

User metadata
Rank Member
Rank
Member

Is it just the family of unreal engine games? It is possible to test with alternate sound settings, such as for UT99:

[Galaxy.GalaxyAudioSubsystem]
UseDirectSound=False
UseFilter=False
UseSurround=False
UseStereo=True
UseCDMusic=False
UseDigitalMusic=False
UseSpatial=False
UseReverb=False
Use3dHardware=False
LowSoundQuality=False
ReverseStereo=False
Latency=60
OutputRate=11025Hz
EffectsChannels=8
DopplerSpeed=9000.000000
MusicVolume=0
SoundVolume=96
AmbientFactor=0.700000