VOGONS

Common searches


Reply 20 of 40, by seskanda

User metadata
Rank Newbie
Rank
Newbie
Jorpho wrote:

What am I trying to say is that you need to change the drive letter that is currently being used for your real CD-ROM drive, because that is where the game is (probably) trying to look for its CD. At the time the game was written it was very uncommon for PCs to have multiple CD-ROM drives and it is probably not checking every possible drive letter for its disc.

Can I assign the virtual drive to the SAME letter as my real CD-ROM drive, or vice versa? It does not matter what drive letter my real CD-ROM drive is, because Pitfall will always try to look for it. My real drive is on F:\, i tried changing it, and set the virtual drive to F:\, but that does NOT work. I even tried disabling the real drive via Device Manager, but i still get the "Pitfall must be played using the CD-ROM" error. Maybe I need a way for Pitfall to recognize a virtual drive as the real CD-ROM drive?

I very much doubt that Pitfall is using any sort of copy protection that would require Daemon Tools Pro.

Yes, that's why i believe UltraISO can do the job for me here.

That would be the .iso image you mentioned before.

So, an .ISO image is the same as a bin/cue, then? I'd like to have the bin/cue image save ONLY the data from the CD, i.e. the visible 40 MB that Windows Explorer shows.

Reply 21 of 40, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

No, an iso is not the same as a bin/cue but it's what you asked for, an image without the audio tracks. To make this work you probably need a no-cd crack if that is available for the game.

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 22 of 40, by Jorpho

User metadata
Rank l33t++
Rank
l33t++
seskanda wrote:

My real drive is on F:\, i tried changing it, and set the virtual drive to F:\, but that does NOT work. I even tried disabling the real drive via Device Manager, but i still get the "Pitfall must be played using the CD-ROM" error.

Oh. Okay, then. And you said it worked fine when you had the real CD in your real drive F: ?

The best way to be sure about where the game is actually looking is to getProcess Monitor. Set it up to show only file system activity (i.e. clear the last five toolbar buttons, and then click the fourth one from the right), and then filter all processes that do not match the name of Pitfall's executable. Run the game and you should see it checking one or more drive letters before stopping.

Unfortunately, I cannot seem to locate my copy of Pitfall, or I would have a look at this myself. As Dominus suggests, there may be a no-CD crack out there somewhere.

Reply 23 of 40, by seskanda

User metadata
Rank Newbie
Rank
Newbie
Jorpho wrote:

Okay, then. And you said it worked fine when you had the real CD in your real drive F: ?.

Yes. See title of thread please.

The best way to be sure about where the game is actually looking is to getProcess Monitor. Set it up to show only file system activity (i.e. clear the last five toolbar buttons, and then click the fourth one from the right), and then filter all processes that do not match the name of Pitfall's executable. Run the game and you should see it checking one or more drive letters before stopping.

Process Monitor shows F: for Pitfall.exe when the error message displays, what can i do next?

I can NOT find a no CD patch for this game. If anyone has one please let me know, so we can figure out a way to send it to me.

Reply 24 of 40, by Joey_sw

User metadata
Rank Oldbie
Rank
Oldbie

very likely you'll need to hunt for pirated games (###-in-1) CDs,
if one of those CD contain pitfall, its most likely already in no-CD patch, and of course without any CD-musics.
i remember one of my friend play that game (pirated), ages ago.

Pirated games however, is frowned here.
so none will help you in that quests.

-fffuuu

Reply 25 of 40, by vetz

User metadata
Rank l33t
Rank
l33t

I do not think using a NO-CD patch is any problem as long you have the original disc, and especially when you have a problem running it.

Try this executable:
http://www.mediafire.com/?7br1y7h95acq0rl

3D Accelerated Games List (Proprietary APIs - No 3DFX/Direct3D)
3D Acceleration Comparison Episodes

Reply 26 of 40, by seskanda

User metadata
Rank Newbie
Rank
Newbie

I tried CloneCD, ALL modes, it made a 600+ MB img file and ccd file, none of them worked. I created a new .ISO of the CD using MagicISO, but that failed, too. Also, i made a bin/cue image of the CD using MagicISO, that did nothing either. I just used Daemon Tools Pro, and so far Data and Mixed Mode do NOT work.

So, my last option is a NO CD patch, it seems the one posted finally works 😁 Thanks to everyone here. But, one last snafu, now i get NO sound or music whatsoever, even with CD inserted.

Reply 28 of 40, by vetz

User metadata
Rank l33t
Rank
l33t

Forgot to check that the game crashes in Windows 95 compability mode. A quick Google search revealed that the problem is a faulty WAIL32.dll file located in the game directory. I've included a proper file in this message. Just replace this new file with the old.

Remember to enable sound when you start it up in the settings if it isn't already. The 256 color error should still come up unless you change the settings for that in compability mode.

Attachments

  • Filename
    wail32.zip
    File size
    41.46 KiB
    Downloads
    3799 downloads
    File license
    Fair use/fair dealing exception

3D Accelerated Games List (Proprietary APIs - No 3DFX/Direct3D)
3D Acceleration Comparison Episodes

Reply 29 of 40, by HunterZ

User metadata
Rank l33t++
Rank
l33t++

I don't think I've had a problem using ImgBurn and MagicDisc (both 100% free), but I haven't messed much with Windows games that use CD Audio tracks.

Redbook audio in games is the devil, and I'm glad it was a short-lived concept.

Reply 30 of 40, by Joey_sw

User metadata
Rank Oldbie
Rank
Oldbie

short-lived concept

Thanks to MP3 & increases in CPU power.

I've Heroes of Might & Magic 2, i made a cd images using cloneCD, mount that images using Daemon Tools.

I can play the music using Windows Media Player (on winxp),
or using CDPlayer on win9x.

to OP, are you unable to play the music from mounted cd-image using Windows Media Player?

-fffuuu

Reply 31 of 40, by seskanda

User metadata
Rank Newbie
Rank
Newbie

I'm running Windows XP SP3, by the way. And compatibility mode with the wail32.dll posted, gives me sound. That's Great! Still NO music though. Only if i mount the .cue file can i play the music in Windows Media Player. Of course, i'd like the music to play in sync with the game as it's supposed to. Oddly, if i play the game from the CD now, i get NO music or sound anymore. The properties for music and sound are grayed out, as well.

Reply 32 of 40, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

Just now, I took a BIN/CUE image, mounted it using Daemon Tools Lite in Windows 7, and then used the Daemon Tools virtual drive with my XP SP3 virtual machine running in VMware.

It Just Worked – CD audio and everything. (EDIT: No sounds.) I can't explain it.

My MD5 sums are
6ccfa0367a2b4f1c10653b96923c5d58 PITFALL.CUE (1,037 bytes)
252f19a8cbb4723f89f67495909fb0bf PITFALL.BIN (640,127,376 bytes)

You can check these using WinMD5 or any other MD5 generator. (Just drag your files onto the WinMD5 program window and see if it generates the same hashes.)

EDIT 2: Further experimentation (with my "real" XP computer) suggests – as I expected – that it brings up the "must use CD-ROM" message if there is another optical drive with a higher drive letter.

Do you only have the one optical drive ("F:\") on your system, Mr. Seskanda ? What is your drive D and drive E?

Reply 33 of 40, by seskanda

User metadata
Rank Newbie
Rank
Newbie

I only have 1 optical drive, its on F:. Drive E: is the memory card reader from my Lexmark AIO printer, and D: is a partition of my hard disk. I used MagicISO to make the BIN/CUE image this time, the hashes are different than yours:

870d61a2e2a9580ec4ad415c4ee09a72(668132640 bytes) PITFALL.BIN

327fb020c4bf8bbbbbff7637456c9d56(1104 bytes) PITFALL.CUE

Reply 36 of 40, by Jorpho

User metadata
Rank l33t++
Rank
l33t++

By "virtual drive" I meant your Daemon Tools drive.

I don't think Daemon Tools can make a BIN/CUE image. Certainly, I wouldn't expect it to make a different BIN/CUE image than anything else.

Reply 37 of 40, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

No need for hashes of the cue file, it's just a text file and is easily screwwed up by different rippers as some put in the full path to the bin file instead of just the filename. Best compare the text...

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 38 of 40, by tincup

User metadata
Rank Oldbie
Rank
Oldbie

Re-letter your current card reader and DVD to G: and H:. Set DaemonTools or MagicDisk to F: [your original CDR drive letter}, and give that a try. As previously mentioned some old games are very fussy about being the first drive on the one hand, and a low letter drive on the other. If this doesn't work, move the DT/MD to E:.

Also check for ini or cfg files in the game root directory. Often they specify install paths that need to be edited when mounting iso/bin+cue's to other drives.

Reply 39 of 40, by rolloLG

User metadata
Rank Newbie
Rank
Newbie

Sorry if I resurrect this old thread but after many years I wanted to reinstall this good old platform…
I never liked using single EXE Properties settings because they get easily lost when you switch to another/new PC (infact I have a new laptop gaming now), and I don't like to promte EXEs to run with Admin privileges to avoid registry corruption and the like.... so I usually fix my old games through Microsoft Application Compatibility Toolkit and move and re-apply my good old fixes database to every machine…
In short, it didn't work out-of-box this time, as the problem was that even with original CD in drive the game had CD Music/AmbientFx disabled and greyed out, and don't know why, but this is THE ONLY game that requires Admin rights to be able to see the CD-ROM drive I've ever seen:
image.png

(Added this comment also as a reminder for myself 😉)
Windows 10 1809