Heavy metal F.A.K.K 2 A3D1 & A3D2 problems.

Getting old Windows games working.

Heavy metal F.A.K.K 2 A3D1 & A3D2 problems.

Postby Unrealdevon » 2019-8-24 @ 13:58

Hi!

I just installed Heavy metal fakk 2.

The game has a3d support (and a3d 2.0?).

I see in a Snddrivers folder in the game dir that there are a few alternatives eax a3d and a3d2.

A3D 2.0 is not selectable in the games options once in game.

A3D1 can be enabled but sounds terrible during gameplay due to muffled and non hearable sound from example the pistol.

I have 2048 reference drivers installed on a Xitel storm platinum card (vortex 2)

Win98se sp3
Asus p800-e deluxe (latest stable bios)
Geforce 4ti 4600 30.82 driver.
500gb sata (80gb partion used atm)
Asus cdrw5232as (firmware 1.03)

Used the console to s_milesdriver a3d2 and it confirms my command and says it will begin on restart.

I restart the game and it reverts back to software.
I can load a game after using the driver command and it will say a3d2 in the game options but im not sure if it actually works.

A3D1 is an option but the usual a3d commands like
S_distance etc dont work so i cant solve the muffled sound in that mode.
I tried removing the snddrivers folder in the game dir and used the s_nomilesdriver 0 command (cant remeber right now the exact command but you get it)

The game starts but no sound at all.
I was hoping the quake3 engine would look for a a3d.api in windows system folder instead :(

Also tried putting the a3d.api in the fakk2.exe dir with no success.

Are there any updates to the miles sound system for a3d?

Are there any official/unofficial fixes at all out there for this?

Best regards!
Unrealdevon
Newbie
 
Posts: 46
Joined: 2019-7-12 @ 08:25

Re: Heavy metal F.A.K.K 2 A3D1 & A3D2 problems.

Postby akula65 » 2019-8-26 @ 16:06

Did you update the game? I think Version 1.02 is the latest official version.

Also, you might want to check out Thomas McGuires' Tweak Guide at 3dspotlight.net from August 2000:

https://web.archive.org/web/20040904024 ... kk-6.shtml

Make sure to click the "Go to the next page" button at the bottom of the page as there is more audio configuration information on the following page.
User avatar
akula65
Oldbie
 
Posts: 545
Joined: 2004-9-28 @ 01:29
Location: North Carolina

Re: Heavy metal F.A.K.K 2 A3D1 & A3D2 problems.

Postby Unrealdevon » 2019-8-30 @ 12:36

Yeah sorry i forgot to mention that but yes it is updated to the latest version 1.02.

I will have a look at this guide
Unrealdevon
Newbie
 
Posts: 46
Joined: 2019-7-12 @ 08:25

Re: Heavy metal F.A.K.K 2 A3D1 & A3D2 problems.

Postby Unrealdevon » 2019-11-13 @ 12:35

Checked the guide and although it has some intresting info, unfortunatly nothing there helped.
Unrealdevon
Newbie
 
Posts: 46
Joined: 2019-7-12 @ 08:25


Return to Windows

Who is online

Users browsing this forum: No registered users and 3 guests