Common searches

First post, by cl0ud

User metadata
Rank Newbie

I can't get CD audio working in Windows 98 SE, but it does work while in DOS mode.
It's a CT4740.

The symptom:
Music CDs and red book audio games have no music, but the CD drive light is blinking as though it were reading music, just no audio.
WMP will seek through the music as though playing, but again, no audio.

Here's a list of what I've done to troubleshoot:

-Double checked all volume levels in the mixer including the multimedia settings; CD audio is all the way up, made sure nothing was muted.
-Double checked the wire is plugged in the CD drive to the header
-Installed the latest SB16 update, Rev 16
-Ran the SoundBlaster diagnose.exe tool to confirm settings matched in device manager. (A220 I5 D1 H5 P330 T6)
-Tried multiple music CDs in both CD Player and WMP7
-Tried multiple games that require CDs for music (Quake and Blood; they do have music while in DOS, just not in Windows)

Here are my config and autoexecs:




SET BLASTER=A220 I5 D1 H5 P330 T6



Reply 1 of 5, by Jorpho

User metadata
Rank l33t++

I'm guessing that Windows is trying to play back the CD audio digitally through the sound card, whereas in DOS, it is being passed through via the CD-in cable.

I'm not sure how to fix the problem, but you can at least try to deselect the digital CD audio option in Windows. It should be in the CD drive properties in Device Manager. (There's also a volume slider there that you may need to adjust.)

Reply 3 of 5, by Jorpho

User metadata
Rank l33t++

Have you installed any strange old media player software that might include extensions for ripping CDs, or other CD-burning software? Those sometimes install problematic "filter drivers". I'm not sure what the best reference for those is, but a quick Google turns up https://www.dell.com/community/Storage-Drives … yed/td-p/199530 .

Reply 5 of 5, by Jorpho

User metadata
Rank l33t++
cl0ud wrote on 2021-05-24, 23:44:

I did install WMP 7 which includes a CD burner plugin but I just uninstalled it to see if it would make a difference but nope.

Unforunately filter drivers are notoriously persistent. You should check the relevant registry keys to see if they are truly gone.