VOGONS

Common searches


First post, by Muz

User metadata
Rank Member
Rank
Member

How to disable prefetch in Windows?

Reply 1 of 4, by eL_PuSHeR

User metadata
Rank Moderator
Rank
Moderator

Which Windows version?

For pre-w10 Windows you open regedit and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters
And you have two keys: EnablePrefetch and EnableSuperfetch; with the following values:

0 - Disabled
1 - Enabled (boot only)
2- Enabled (applications only)
3- Enabled (boot and applications) [default]

For w10 onwards open either services.msc or an administrative cmd.exe window and disable either Superfetch/SysMain service.
For command-line: sc config Superfetch start=disabled
sc config SysMain start=disabled

and reboot.

Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
8 GB GeForce GTX 1070 G1 Gaming (Gigabyte)

Reply 4 of 4, by erpster-xg4

User metadata
Rank Newbie
Rank
Newbie

sometimes a few apps do not work correctly when prefetch is enabled on certain systems but it happens almost rarely
have it disabled when using modern SSD drives but okay to leave prefetch enabled for HDD drives
there's really no benefit for leaving prefetch on for SSDs

btw, Win10 v1809 (build 17763.x) and higher use SysMain instead of Superfetch; older Win10 versions (like from 1507/RTM to 1803) use Superfetch service entries
in WinXP, see this site on how to disable Prefetcher:
http://www.helpwithwindows.com/WindowsXP/troub-07.html