VOGONS

Common searches


First post, by vorob

User metadata
Rank Oldbie
Rank
Oldbie

So I’ve buildup a retro pc with VooDoo 3 2000. I’m on Windows 98, the 3dfx driver is V1.05.00.

I wanted to play retail vanilla version but it crashes. Any reason for it? I’m on native hardware after all.

D27BFB9B-FB2C-4D29-BD44-47135AC924CA.jpeg
Filename
D27BFB9B-FB2C-4D29-BD44-47135AC924CA.jpeg
File size
181.83 KiB
Views
900 views
File license
Public domain

226 in glide works perfect.

Reply 2 of 17, by dr.zeissler

User metadata
Rank l33t
Rank
l33t

Was this due to the multitexture (glide3), or was it the dx-version issue. I remember this.
You get this error on a voodoo1/2 too if you use a newer driver/dx-version.

On Voodoo1 I always use DX5 and 2.43 and this worked, I don't know if 2.48 got this error.
I am not shure, but I think I wonÄt be able to play 1.0 with voodoo3, even on the oldest drivers.

Retro-Gamer 😀PowerMac 6100-66/Houdini 486/66 - G4 Cube 450/Rage128pro OS9.0.1 - Macintosh LC/Apple IIe Card OS6.0.8 - Acorn A4000 Archimedes - Unisys CWD 486/66 + Aztech Washington

Reply 4 of 17, by vorob

User metadata
Rank Oldbie
Rank
Oldbie

Okay, patch 224 did the trick. But still it’s sad I can’t play unreal on voodoo. From my point of view unreal was a key glide game. 3dfx should make sure it’s working from their side.

Reply 5 of 17, by TrashPanda

User metadata
Rank Oldbie
Rank
Oldbie
vorob wrote on 2022-07-31, 09:06:

Okay, patch 224 did the trick. But still it’s sad I can’t play unreal on voodoo. From my point of view unreal was a key glide game. 3dfx should make sure it’s working from their side.

"Should" implies they still exist, Sadly they dont and you can expect quite a lot of weirdness from 3DFX drivers and different cards, their drivers tended to be either fucking amazing or ..well umm a cesspool of bugs. And if you have Diamond versions of the 3DFX cards well ..even more stupidity ensues and Diamond did some black magic fuckery with their Monster II cards and you need their official Diamond drivers installed first before any other 3rd party drivers or you will get a ton of issues.

Ask me how I know.

There are 3rd party driver sets that can fix a bunch of these issues so you could try some of them too.

That said .. Unreal worked flawlessly with 3DFX cards prior to Avenger so you could say they did make sure it worked, Avenger changed quite a bit up Glide API wise so its unreasonable to expect a game designed with Glide 1x/2x in mind to work perfectly with Glide 3x. I'm sure had they remained solvent they would have fixed a great many other bugs but even during the Voodoo3 era they were in financial trouble and were struggling to retain market share from ATI and nVidia. So sadly many bug fixes and driver issues never got the developer attention they required.

Go easy on the old girls, these cards are amazing to play with and even with the bugs and weirdness you can have a lot of fun if you are willing to tinker a bit.

Oh noes, the cap let the shmooo out 😁

Reply 6 of 17, by leileilol

User metadata
Rank l33t++
Rank
l33t++

Voodoo3s usually come with the first version of Unreal it'd work with (v222) since it was broken before that. The readme notes this. This was likely done to keep the older broken release out of immediate consideration.

GlideDrv didn't support multitexturing in the initial release so it ain't that. Unreal's initial release had other unstable factors coming for it too (CPU bugs, the hardware sound support)

apsosig.png
long live PCem

Reply 7 of 17, by Mouse0707

User metadata
Rank Newbie
Rank
Newbie

Sorry,

I Not have Win98, because it is not need.

I wonder why People buy extreme Rare and expensive Win98 Hardware, when all this Games also work on XP with cheap Hardware.

I allways Use Original CD Driver, and create ISOs from it.

Or Found Original CD Drivers on Archive.Org.

Eiderdaus Was a Mouse

Reply 8 of 17, by vorob

User metadata
Rank Oldbie
Rank
Oldbie
TrashPanda wrote on 2022-07-31, 10:27:

"Should" implies they still exist.

Sure, my mistake. Wasn't expecting them to rise and fix it.

Thx for additional clarification, epecially about 222 that was boundled with voodoo3, it makes everyting clear.

Mouse0707 wrote on 2022-07-31, 14:35:
Sorry, I Not have Win98, because it is not need. I wonder why People buy extreme Rare and expensive Win98 Hardware, when all th […]
Show full quote

Sorry,
I Not have Win98, because it is not need.
I wonder why People buy extreme Rare and expensive Win98 Hardware, when all this Games also work on XP with cheap Hardware.
I allways Use Original CD Driver, and create ISOs from it.
Or Found Original CD Drivers on Archive.Org.

There is a special joy and interest in playing old stuff on it's original hardware. Sure you can play old games on modern pc with patches and mods, but still...

Reply 9 of 17, by TrashPanda

User metadata
Rank Oldbie
Rank
Oldbie
vorob wrote on 2022-07-31, 16:56:
Sure, my mistake. Wasn't expecting them to rise and fix it. […]
Show full quote
TrashPanda wrote on 2022-07-31, 10:27:

"Should" implies they still exist.

Sure, my mistake. Wasn't expecting them to rise and fix it.

Thx for additional clarification, epecially about 222 that was boundled with voodoo3, it makes everyting clear.

Mouse0707 wrote on 2022-07-31, 14:35:
Sorry, I Not have Win98, because it is not need. I wonder why People buy extreme Rare and expensive Win98 Hardware, when all th […]
Show full quote

Sorry,
I Not have Win98, because it is not need.
I wonder why People buy extreme Rare and expensive Win98 Hardware, when all this Games also work on XP with cheap Hardware.
I allways Use Original CD Driver, and create ISOs from it.
Or Found Original CD Drivers on Archive.Org.

There is a special joy and interest in playing old stuff on it's original hardware. Sure you can play old games on modern pc with patches and mods, but still...

I wish they would, we could use another 3DFX, AMD and Novideo could use a kick in the arse.

Oh noes, the cap let the shmooo out 😁

Reply 10 of 17, by leileilol

User metadata
Rank l33t++
Rank
l33t++
Mouse0707 wrote on 2022-07-31, 14:35:

Sorry,

I Not have Win98, because it is not need.

I wonder why People buy extreme Rare and expensive Win98 Hardware, when all this Games also work on XP with cheap Hardware.

WinXP's NT-based, and NT wasn't a support focus for many of those games in the 90s as that was primarily a business professional workstation OS variant of Windows with a more hardened kernel without dos cruft, so a lot will fail in unforeseen ways after XP was brought to the mainstream (thus, these many "xp patches")

Also 3dfx were anything but rare and expensive in the day. A lot of us still have our first-hand 3dfx purchases and never gave into the scalpers.

apsosig.png
long live PCem

Reply 11 of 17, by Asaki

User metadata
Rank Member
Rank
Member
Mouse0707 wrote on 2022-07-31, 14:35:

I wonder why People buy extreme Rare and expensive Win98 Hardware, when all this Games also work on XP with cheap Hardware.

Because Aureal Vortex 2 works in Win98 and not Win XP.

I paid a lot of money for my XP machine, paid for it all with my first real job, but I'm not sure if I spent any money at all on my 98 one...most of that was parts that I saved from the scrap heap.

Reply 12 of 17, by Mouse0707

User metadata
Rank Newbie
Rank
Newbie

eiderdaus was a alien

Now i have also mutch over 40 Shooters from 1997-2008, all Original ISO.

I allways have installed 1 Shooter. The one is Pacific Assault.

When a second come, when it is finish, i delete him, then come the next Shooter.

Bud my 43 Racing Games from 1997-2006 are allways installed.

Last edited by Mouse0707 on 2022-08-08, 14:32. Edited 4 times in total.

Eiderdaus Was a Mouse

Reply 14 of 17, by subhuman@xgtx

User metadata
Rank Oldbie
Rank
Oldbie
leileilol wrote on 2022-07-31, 21:44:
Mouse0707 wrote on 2022-07-31, 14:35:

Sorry,

I Not have Win98, because it is not need.

I wonder why People buy extreme Rare and expensive Win98 Hardware, when all this Games also work on XP with cheap Hardware.

WinXP's NT-based, and NT wasn't a support focus for many of those games in the 90s as that was primarily a business professional workstation OS variant of Windows with a more hardened kernel without dos cruft, so a lot will fail in unforeseen ways after XP was brought to the mainstream (thus, these many "xp patches")

Also 3dfx were anything but rare and expensive in the day. A lot of us still have our first-hand 3dfx purchases and never gave into the scalpers.

By 2001 they were nothing but undesirable, budget cards. I recall feeling a GF2 GTS being much more worth a buy after seeing NFS III (a game from mid 98) struggle achieving 60 stable frames per second with an Athlon XP under 4xFSAA (pretty much the sole point of owning a 5500), and that was with a much newer platform than what was available when the V5 cards came out.

7fbns0.png

tbh9k2-6.png

Reply 15 of 17, by Mouse0707

User metadata
Rank Newbie
Rank
Newbie
Mouse0707 wrote on 2022-08-02, 17:38:
eiderdaus was a alien […]
Show full quote

eiderdaus was a alien

Now i have also mutch over 50 Shooters from 1995-2008, all Original ISO.

I allways have installed 1 Shooter. The one is Pacific Assault.

When a second come, when it is finish, i delete him, then come the next Shooter.

Bud my 43 Racing Games from 1997-2006 are allways installed.

Sorry i only wanted to Edit My Post not a Reply. Have delete the Shooters.

Eiderdaus Was a Mouse