Messing with K6XV3+/66 retro system again... Prince of Persia 2 lockups

Discussion about old PC hardware.

Messing with K6XV3+/66 retro system again... Prince of Persia 2 lockups

Postby dr_st » 2018-7-14 @ 10:03

As it's Prince of Persia month at DOS Games Club, I decided to replay the first two games.

My retro DOS system is a DFI-K6XV3+/66 with a K6-II 500MHz, 256MB PC133 (2x128MB), Voodoo 3000 AGP and an AWE64. Playing Prince of Persia 2 1.0, I was experiencing frequent lockups with SB audio enabled (about 10 seconds into the level). Version 1.1 seems not to have these problems, but that version unfortunately introduced some annoying graphical glitches and enemy behavior bugs. So I was trying to see if I could get 1.0 to work reliably.

There are also a wired and wireless network cards in that system (PCI), and I noticed that CTCM was complaining about an IRQ conflict on IRQ5 with one of them. Thinking that it may cause the issues with PoP2 1.0, I tried to resolve the conflicts by moving the cards around, removing them, or disabling COM/LPT ports in the BIOS. In the process I found the following things:

  • The first (top) PCI slot on the K6XV3+ shares resources with the AGP slot, so I cannot have the network adapter in that slot (No POST). I think this is a known thing.
  • After messing with the cards I suddenly started getting the "I/O Channel Check-Checking for Segment...Offending Segment:0000 Press F1 to Disable NMI, F2 to Reboot" error before boot. I'm not sure if it's a RAM parity error or not, but since I had a spare stick, and there are 3 slots, I played with different combinations, and eventually got it to work again with 256MB and no error. I've been having more frequent lockups with that system (especially in Windows), so hopefully whatever was dying finally died, and maybe now the system will be more stable.
  • Disabling the serial ports in the BIOS freed enough IRQs for there to be no conflict at IRQ5 - the network controllers now use IRQ3 and IRQ9, the AWE64 is still at IRQ5. If that had not worked, I probably would have just removed the wired Ethernet card, since the system is on wireless at the moment, but it's more likely I'll use the wired Ethernet in the future than serial ports.
  • I tried going further and disabling the parallel port as well (to free IRQ7), but then the BIOS forced the AWE64 to IRQ7 instead. Since all my games have already been set up to use it at IRQ5, I didn't like this change, so I just reenabled the parallel port and the AWE64 went back to IRQ5. It's possible I can somehow force the BIOS to prefer IRQ5 even if 7 is available, but I didn't feel like spending too much time on it.
Unfortunately, in the end, the lockups in PoP2 1.0 did not go away (although they became far less frequent). PoP2 lets you specify IRQ and DMA in the setup program, and I tried both IRQ7/DMA3 and IRQ5/DMA1 (since these are the two configurations that the BIOS chooses between), and there was no difference. I have to conclude that the lockups have a different underlying cause. Maybe a compatibility issue with the Creative cards, maybe some other conflict, or maybe a hardware fault on my system. Evidently whatever they fixed in PoP2 1.1 makes it less susceptible to the problem, so I will just be playing this version on this old system for now. I have a DOSBox setup that runs 1.0 flawlessly on all my modern computers.
User avatar
dr_st
Oldbie
 
Posts: 1180
Joined: 2015-4-09 @ 07:18

Re: Messing with K6XV3+/66 retro system again... Prince of Persia 2 lockups

Postby Stiletto » 2018-7-16 @ 16:07

Hm.

Maybe try vladr's old SB patch for DIGI.DRV?
viewtopic.php?f=16&t=629
Read through the whole thread from 2002. We were trying to get it going in Windows XP's NTVDM at the time.

Can't believe I remembered doing that POP2 testing just now!
"I see a little silhouette-o of a man, Scaramouche, Scaramouche, will you
do the Fandango!" - Queen

Stiletto
User avatar
Stiletto
l33t
 
Posts: 3985
Joined: 2002-7-01 @ 21:57


Return to General Old Hardware

Who is online

Users browsing this forum: mjnman, tpowell.ca and 11 guests