Common searches

First post, by tomexplodes

User metadata
Rank Newbie

I installed the game. I did all the Glidos recommended stuff and put both it and Redguard in C:\Program Files\ etc, which is where I ran into my first problem, the MS DOS prompt yelling at me about too many parameters. So I changed the Glidos.bat file to point to C:\Progra~1\ etc., and it gets a little further, but if I run in D3D (psVoodoo) mode, it just crashes back to desktop. If I run in OpenGL mode, the game "loads", which is to say I can hear everything but there's no picture.

Using a Geforce 4 MX 440, so I imagine that could be my problem, but if I'm just messing up the setup somewhere, I'd love to know if it can be fixed. Sure, I could run Redguard in software mode, but it doesn't run that great. Alternatively, I could shell out whatever silly prices people want for a nice Voodoo card (which I would absolutely LOVE to do), but as I'm not made of money, that's not currently an option either. I've had good luck with Glidos and Tomb Raider in the past, I was hoping it could get Redguard going on my 98 PC. If that's not doable, it's not doable, but you know how it goes.

Thank you in advance!

- Tom

EDIT: If I try something it suggested, which is putting psVoodoo's glide2x.dll file in the Redguard folder and just running rgfx.exe, it gives me "Fatal Error: Unable to load DLL"

Reply 1 of 4, by tomexplodes

User metadata
Rank Newbie

Hokay, so I tried a few more things. I removed both Redguard and Glidos, put Glidos in C:\Glidos and Redguard in D:\Redguard. I pointed Glidos at D:\Redguard\RGFX.exe so that's all good. But now, when I try to run it either in Direct3D or OpenGL, it crashes and I get this (to me at least) gobbledegook. Redguard's error log gives me nothing, I don't see an error log for Glidos, so this screenshot is the best I can currently do, unfortunately.

EDIT: And finally, I tried running Redguard and Glidos in 640x480 instead of 800x600, and got this error:
GLIDOS caused an invalid page fault in
module GLIDE2X.DLL at 0187:020fb866.
EAX=02151d4c CS=0187 EIP=020fb866 EFLGS=00010246
EBX=00000001 SS=018f ESP=0073f9c0 EBP=0073fa50
ECX=00000000 DS=018f ESI=02b0000c FS=1a7f
EDX=00000000 ES=018f EDI=020f7c30 GS=0000
Bytes at CS:EIP:
8b 01 8b 50 20 ff e2 cc cc cc 83 ec 10 db 44 24
Stack dump:
020f91a6 00000001 00412d93 00000001 a435d1e1 01196270 01197840 00000001 0073fa44 0073fa44 00474bf8 ffffffff 0040fb49 a435d265 0073fc30 0073fc30


  • redguard.png
    File size
    11.04 KiB
    File license
    Public domain

Reply 2 of 4, by tomexplodes

User metadata
Rank Newbie

aaaaaaaand one more thing. I tried running everything in 640x480 mode in OpenGL mode this time, and I get a Glidos pop-up error, "Screen mode change failed"

Once I click okay on that, I get the Redguard load screen, albeit behind the task bar, and the first FMV plays for about 1 second before the whole thing locks up completely again.

I tried this with my computer's desktop in 800x600x32, 640x480x32 and 640x480x16 but same error every time. I feel like I've made progress, though I have no idea how or why.

I also tried using a Bin/Cue combination, loading the .cue file in the ISO section of Glidos, and it gives me the same screen mode change failed error, but the game loads up. No sound and no movies, though.

Reply 3 of 4, by Glidos

User metadata
Rank l33t

I haven't had a machine running Windows 98 for years, so it's been impossible to test. A few suggestions though:

Within the Adjust dialog, under the DOS tab, selection Windows for the Dos emulation, at least to get started.

If you have a copy, try getting Tomb Raider working first. More people used Glidos for that than any other game, so it's the best tested.

For installing, follow the instructions on the Glidos web site, and no others. If it doesn't work, then uninstalling and trying again, reading each detailed step is more likely to work than using someother universal installer.

Reply 4 of 4, by tomexplodes

User metadata
Rank Newbie

I did select Windows for the DOS emulation, VDos did nothing at all and obviously I don't have DOSBox on Win98. I will definitely try Tomb Raider and see if I can make that work, and also I did follow the directions on your site to the letter. I'll get back to you after I try Tomb Raider (which I've had great success with in the past, so thank you for that!) Thanks for your reply!

EDIT: Oh the other thing worth noting is that my soundcard worked with Redguard's auto-detect no problem, so I did not run the setsound program. I'll add that as a step as well just in case.