VOGONS

Common searches


Reply 361 of 367, by C0deHunter

User metadata
Rank Member
Rank
Member

UPDATE:
I just ran AWE64 DOS based diagnose utility, and it fails at setting IRQ 5 to my card. I even moved the Adaptec to a different PCI slot, and it did not help.

UPDATE2:
I think I have isolated and fixed the issue, went into the BIOS, and under the Resources Controlled By, changed it from Auto to Manual, and under IRQ 5, changed it to Legacy ISA for my AWE64.

Upon a reboot, I no longer get the SoftMPU error message, and when I also run AWE64 DOS diagnose utility, no conflict is reported.

Attachments

  • BIOS 01.jpeg
    Filename
    BIOS 01.jpeg
    File size
    1.77 MiB
    Views
    423 views
    File license
    Fair use/fair dealing exception
  • BIOS 02.jpeg
    Filename
    BIOS 02.jpeg
    File size
    471.4 KiB
    Views
    423 views
    File license
    Fair use/fair dealing exception

PIII-800E | Abit BH-6 | Rage 128 Pro Video Card | 256MB SD-RAM PC100 | AWE64 Gold | Sound Canvas 55 MKII | SoftMPU | 2X SanDisk (2004) 2GB CF as C:\ (Win98SE OS) and D:\ (DOS Games) | Windows 98SE (using PhilComputerLabs', *pure* DOS option)

Reply 364 of 367, by C0deHunter

User metadata
Rank Member
Rank
Member

I use SYSTEM COMMANDER 2000 to boot into multiple OS, DOS 7.1 being of them.

PIII-800E | Abit BH-6 | Rage 128 Pro Video Card | 256MB SD-RAM PC100 | AWE64 Gold | Sound Canvas 55 MKII | SoftMPU | 2X SanDisk (2004) 2GB CF as C:\ (Win98SE OS) and D:\ (DOS Games) | Windows 98SE (using PhilComputerLabs', *pure* DOS option)

Reply 366 of 367, by bjwil1991

User metadata
Rank l33t
Rank
l33t

General question. I got myself a Music Quest MIDIEngine 2Port/SE (Parallel port) yesterday and I'm wondering if it's possible to use SoftMPU with it or not really? If it's not possible, let me know.

Discord: https://discord.gg/U5dJw7x
Systems from C64 to FX-6300.

Reply 367 of 367, by guzzard

User metadata
Rank Newbie
Rank
Newbie

Hello! I'm new here, sorry if I post a question that has already been answered. I searched both Vogons and the internet but cannot find the answer.

I setup SoftMPU on my 486 and Munt on my Linux computer to emulate MT-32 with Munt through a serial cable and that works really great, no issues.

However when I tried to get General MIDI working in DOOM, Duke3D etc I had no luck. I was using JACK2 and FluidSynth on my Linux computer and it worked fine to play midi music using DOSMid, but General MIDI did not work in games.

I could not figure what was wrong, but after some searching i found that SoftMPU cannot work with DOS extenders (this would be great info to have on the SoftMPU website under troubleshooting).

So my questions are:
Will it ever be possible to use SoftMPU together with DOS extenders? Or is there some limitations making this impossible? I found no explanation anywhere as to why it's not working, just that it's not. Perhaps someone with a lot of knowledge about DOS can explain why?

Would my proposed setup without SoftMPU (see attached image) work to get General MIDI working in games with DOS extenders? If this doesn't work, what would be the easiest option with new available hardware to be able to connect to JACK2 and use various soundfonts etc?

Attachments

  • midi_question.png
    Filename
    midi_question.png
    File size
    245.24 KiB
    Views
    3 views
    File license
    Public domain