Sound Blaster Live! DOS Drivers

Discussion about old sound cards, MIDI devices and sound related accessories.

Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-03 @ 21:25

I've built a retrogaming rig to play my old Windows favorites (http://www.vogons.org/viewtopic.php?t=21332&highlight=)and was using DOSBox on my main PC for DOS games. But since it does not (yet?) support 3d acceleration and 16bit sound, I figured I should use the real thing for them.

I downloaded the sb16 DOS emulation drivers for my Live! Value but I can't get it to work.

First, when I try to install the drivers, it says I don't have enough disk space on destination drive and that I need to free some space before continuing or cancel the operation. Of course I've got 400+ MB free on system partition. Manually extracting does not work. Because, the system hangs when booting Win98 right after the dos emulation drivers are loaded, after 2 minutes of hang I get a "not ready reading drive c:" or something similar like that, "abort? retry? fail?". When I press either A, R or F nothing happens. So I had to remove the initialize lines from my autoexec.bat. Windows loads up fine, and the sound works perfectly in windows games but I get no sound in DOS games.

I've had my share of googling for hours and it seems that every solution I found didn't work. I tried millions of different variations of the ctsyn.ini, autoexec.bat and config.sys files but no matter what I do, it just gives me the finger :(.

I'm now even considering getting a SB16 PCI but then I'll lose EAX... this sucks...
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-03 @ 21:32

Also, does anyone know of a virtual drive/image mounting program for Win98 SE? I'm too lazy to walk to my library. I'd go to the WC by car if I was able to (yes, I'm THAT lazy :) )
Elan Vital T10, ASUS CUV4X-C, Intel Pentium III 866, 512MB SDRAM, 3DFx Voodoo 3 3000, Creative SB Live! Value --- Uberetro System 2000 :)
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby gerwin » 2009-10-03 @ 21:56

and was using DOSBox on my main PC for DOS games. But since it does not (yet?) support 3d acceleration and 16bit sound, I figured I should use the real thing for them.
DosBox does support 16-Bit Sound.
I downloaded the sb16 DOS emulation drivers for my Live! Value but I can't get it to work.

Please try the Pure Dos emulation drivers with a manual install, they are attached. You also need this additional file to make it complete: http://www.filewatcher.com/_/?q=2MG4.ECW
I'm now even considering getting a SB16 PCI but then I'll lose EAX... this sucks...

SB16 PCI? There is only an ISA SB16.
Attachments
LiveDos.zip
SB-Live! Pure Dos Emulation Drivers
[Excluding 2MG4.ECW!!]
(291.09 KiB) Downloaded 1570 times
User avatar
gerwin
l33t
 
Posts: 2472
Joined: 2004-5-07 @ 19:21
Location: NL

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-03 @ 22:17

DosBox does support 16-Bit Sound.

I couldn't get it to work
Please try the Pure Dos emulation drivers with a manual install, they are attached. You also need this additional file to make it complete: http://www.filewatcher.com/_/?q=2MG4.ECW

Ok I'll try these. Thanks
SB16 PCI? There is only an ISA SB16.

There is a PCI version: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&Item=200388327300&Category=3701&_trkparms=algo%3DLVI%26its%3DI%26otn%3D2 But I'd much rather prefer the ISA one since I've owned one back in the day, the problem is that the MB does not have an ISA slot unfortunately.
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby swaaye » 2009-10-03 @ 23:15

SB16 PCI is perhaps based on Ensoniq AudioPCI. One of the ES137x chips with a new name.

If you are using Windows 98, you can get the DOS drivers most easily by installing Liveware 3 off of a CD. I will upload a image file of my disk that I actually paid money for back in the day. :)
swaaye
Moderator
 
Posts: 7089
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-03 @ 23:41

Thanks for the reply and the CD ISO in advance, swaaye :)

@gerwin: The files you've send did not work. I did everything according to the readme and it says:

"error: Could not configure PCI port. Sound Blaster 16 emulation driver NOT loading"
Elan Vital T10, ASUS CUV4X-C, Intel Pentium III 866, 512MB SDRAM, 3DFx Voodoo 3 3000, Creative SB Live! Value --- Uberetro System 2000 :)
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-04 @ 00:23

Ok, I've assigned IRQ 10 to PCI slots 1/5 from BIOS. It works now. But this time, CD audio is distorted :(
Elan Vital T10, ASUS CUV4X-C, Intel Pentium III 866, 512MB SDRAM, 3DFx Voodoo 3 3000, Creative SB Live! Value --- Uberetro System 2000 :)
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby swaaye » 2009-10-04 @ 03:21

Image
Creative Live!Ware 3.0 CD ISO+update
http://www.megaupload.com/?d=9FHXIOWI
or
http://rapidshare.com/files/385395126/C ... ate.7z.001
http://rapidshare.com/files/385414240/C ... ate.7z.002

This will only install on the original SBLive! or Live! Value. Doesn't detect 5.1 edition Live! cards. It's for Win9x.
Last edited by swaaye on 2010-6-19 @ 20:08, edited 2 times in total.
swaaye
Moderator
 
Posts: 7089
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: Sound Blaster Live! DOS Drivers

Postby RoyBatty » 2009-10-04 @ 14:29

as for win98 disc emulation software, daemon tools 3.47 should work. Easy to find. And freeware.
User avatar
RoyBatty
Member
 
Posts: 427
Joined: 2009-8-22 @ 11:37

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-04 @ 20:23

RoyBatty wrote:as for win98 disc emulation software, daemon tools 3.47 should work. Easy to find. And freeware.


D/L ing now, thanks!
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby swaaye » 2009-10-04 @ 20:55

The CD has some fun extras btw.

-Lava music player with animated 3D "lava" stuff
-SBLive Experience demo and showcase
-EAX Demo
-Creative PlayCenter player
-Bunch of other Creative apps

All of them are optional to install. You get a cool thunder Windows start sound when you install it too. :)
swaaye
Moderator
 
Posts: 7089
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: Sound Blaster Live! DOS Drivers

Postby Davros » 2009-10-04 @ 23:46

Dont you also get the annoying toolbar :D
Guardian of the Sacred Five Terabyte's of Gaming Goodness
User avatar
Davros
l33t
 
Posts: 2476
Joined: 2004-3-01 @ 03:08

Re: Sound Blaster Live! DOS Drivers

Postby swaaye » 2009-10-05 @ 04:05

You mean the "launcher"? I kinda like the thing! You have to set it off of "always on top" though cuz that's ridiculous.

Maybe I'll make it my sig!
Image
swaaye
Moderator
 
Posts: 7089
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: Sound Blaster Live! DOS Drivers

Postby prophase_j » 2009-10-05 @ 07:33

Seeing that launcher brings back a few good memories.. Like the time I hooked up 4 speakers to my Live! and got to hear true 3D sound for the first time. It literally gave me goosebumps.
"Retro Rocket"
Athlon XP-M 2200+ // Epox 8KTA3
Radeon 9800xt // Voodoo2 SLI
Diamond MX300 // SB AWE64 Gold
User avatar
prophase_j
Member
 
Posts: 439
Joined: 2008-4-04 @ 04:27
Location: Planet Erf

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-05 @ 07:40

Yeah, and remember that demo which showcased EAX? Walking around in some creepy environments and hearing simulated stuff for the first time was way cool. Also the two videos in which Starcraft and Thief: The Dark project were shown and advertised "as EAX capable" (which they weren't and are not) ? :)
Elan Vital T10, ASUS CUV4X-C, Intel Pentium III 866, 512MB SDRAM, 3DFx Voodoo 3 3000, Creative SB Live! Value --- Uberetro System 2000 :)
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby swaaye » 2009-10-05 @ 17:34

There are EAX presets for Thief and StarCraft in these drivers. :)
swaaye
Moderator
 
Posts: 7089
Joined: 2002-7-22 @ 21:24
Location: WI, USA

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-05 @ 21:25

I still haven't installed these drivers. Aside from uninstalling the old ones via program add/remove, what do I need to do more? A registry clean? Maybe delete the directories and autoexec.bat entries I made for the DOS drivers?
Elan Vital T10, ASUS CUV4X-C, Intel Pentium III 866, 512MB SDRAM, 3DFx Voodoo 3 3000, Creative SB Live! Value --- Uberetro System 2000 :)
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Re: Sound Blaster Live! DOS Drivers

Postby WolverineDK » 2009-10-06 @ 15:02

ktorpil: have you checked out this thread out yet ?

viewtopic.php?t=20786&highlight=#152531

when it comes to drivers.
User avatar
WolverineDK
Oldbie
 
Posts: 1093
Joined: 2006-7-16 @ 21:00
Location: Denmark

Re: Sound Blaster Live! DOS Drivers

Postby Jorpho » 2009-10-06 @ 17:29

ktorpil wrote:I still haven't installed these drivers. Aside from uninstalling the old ones via program add/remove, what do I need to do more? A registry clean? Maybe delete the directories and autoexec.bat entries I made for the DOS drivers?
If this is about DOS drivers, why would you need to worry about add/remove or the registry?
User avatar
Jorpho
l33t++
 
Posts: 7043
Joined: 2003-2-14 @ 19:50
Location: Canada

Re: Sound Blaster Live! DOS Drivers

Postby ktorpil » 2009-10-26 @ 16:15

Work was coming down on me like a thousand demons on that "Doom" poster so I didn't have a chance to use the P3 much. Finally this weekend I fired it up.

First thing I noticed was while sfx was working well with DOS games, music didn't came at all. I meddled with some ctsyn.ini settings and such to no avail. Finally I decided to uninstall all sound drivers and give the Liveware 3.0 which swaaye generously provided, a chance

I burned the image and tried to install it. Didn't work. Install hang after selecting the components. So I browsed the CD and run the setup file manually. Installed everything including the DOS drivers, restarted and everything was working perfectly. Sfx and music was OK at DOS games.

I gamed for some hours and shut down the computer. The next morning computer hang while booting Windows 98 so I did a hard reset and pressed escape to see what was wrong, this was:
Image

After staying like this for 6-7 minutes finally this prompt came:

Image
After this I had to hard reset since the PC didn't register any keyboard input.

This is the exact same problem I was having before trying gerwin's solution.

I opened up the computer with F8 and step by step confirmation. I Y'd everything except the line with SBINIT.COM and windows booted fine. Checked immediately to see if sound & music were working with DOS games, they worked. Weird indeed...
I ran msconfig and disabled that line. Restarted again and PC hang up again!
Escaped and the probem was there, the line was not disabled.
Manually deleted the line from autoexec.bat, it somehow inserted itself again!
Manually deleted the line and changed autoexec.bat's paremeters to read only. SBINIT.COM strikes back!

No matter what I do, that line comes over and over again and I am unable to boot into Win98 unless I say N at that line while step by step confirming startup parameters.

And interestingly DOS sound works perfectly despite this.
Elan Vital T10, ASUS CUV4X-C, Intel Pentium III 866, 512MB SDRAM, 3DFx Voodoo 3 3000, Creative SB Live! Value --- Uberetro System 2000 :)
User avatar
ktorpil
Newbie
 
Posts: 22
Joined: 2008-7-05 @ 13:51
Location: Ankara, Turkey

Next

Return to Sound

Who is online

Users browsing this forum: No registered users and 1 guest