VOGONS


Glidos for M1 tank platoon

Topic actions

First post, by Unregistered

User metadata

Hi,

Can you tell me is there or will there be a version of Glidos thats supports M1 Tank Platoon2.

This sim has a Glide option and if there was support for it would we be able to run it in a higher resolution?

Jeff

Last edited by Unregistered on 2003-05-10, 14:14. Edited 1 time in total.

Reply 1 of 24, by Schadenfreude

User metadata
Rank Member
Rank
Member

You meant to say "M1 Tank Platoon 2" in your title.

It's a Windows game... Glidos is for DOS Glide games - but Glidos uses a Windows Glide->OpenGL wrapper to make this work. You need to try something called "OpenGlide", which Glidos uses.

And a moderator needs to move this post to the appropriate forum.

But, yes, it could POTENTIALLY work. Generally, if you can get the Windows game working in Windows 2000/XP without OpenGlide, then you MIGHT be able to get it working WITH OpenGlide.

See: openglide.sf.net

There's no manual for OpenGlide, so use the OpenGlide support forums here on VOGONS for help.

You put the DLL file in the game's folder. Or if you are really daring, and you won't forget about it, and you don't own a Voodoo card, and the game knows to look for it, you can put it in your Windows/System or System32 folder. But I do not like this approach, as some games require different OpenGlid.ini settings.
(people need to make a manual and a frontend for Openglide!)

------------------------

If you cannot get OpenGlide to work, and the authors (who post in the OpenGlide forum) cannot get it to work - well, you can try a Glide->Direct3D wrapper called eVoodoo (evoodoo.emulation64.com) but their support forum is not here.

Reply 3 of 24, by Schadenfreude

User metadata
Rank Member
Rank
Member

What are your system specs?

But GOOD to HEAR that it works!

If you get bored, and you have other Windows Glide games to test, go help us out here:
zetafleet.com/dev/oli/compat.php

(OpenGlide programmers, come hither!)

Reply 5 of 24, by Unregistered

User metadata

Thanks guys,

I now have M1TP2 looking so good it could be a new game 😁

On the downside it's uplayable on my rig through the optics, but ok outside the tank.

I used the latest openglide beta and have some screenshots here:

community.webshots.com/album/72638789pdoSqx

Thanks again

Jeff

Reply 6 of 24, by Snover

User metadata
Rank l33t++
Rank
l33t++

It takes a LOT of processing power for OpenGLide to change all the Glide calls into appropriate OpenGL calls. Even the latest beta, while boasting some nice speed improvements, will still struggle. I notice that you're trying to use 4xFSAA. Try turning that off.

Yes, it’s my fault.

Reply 8 of 24, by Schadenfreude

User metadata
Rank Member
Rank
Member
Unregistered wrote:

Hi Snover,

I would turn it of but it looks so good in fsaa 😀 The sim can only run in 640*480 and I just don't want to go back there 😀

Perhaps OpenGlide should have a setting to set the rendering window size - but boy, I don't want to think what scaling up the rendering could do to textures and stuff... OR performance.

But it seems to work as good as Red Baron 3D! Woohoo!

To amend what I said earlier:
if you can get your game running in Windows 2000/XP AND it has a software, DirectX/Direct3D and/or OpenGL renderer that ALSO works in Windows AND it has a Glide rendering mode that is currently not functional, then there is a good chance that the game could use OpenGlide to work in Windows. (Of course, with a Direct3D or OpenGL renderer, there's not really a REASON to use OpenGlide.)

{EDIT}
Before I forget, if you spot a weird texturing, transparency or other weird rendering error and you're SURE it's not the game, feel free to report the issue, with attached screenshot, and details how to duplicate the problem. (best case - assume the programmers do not own the game, find a place to download a legal demo of the game, and write instructions how to duplicate the error using the demo. (NOT warez/abandonwarez, please!)

Last edited by Schadenfreude on 2003-05-11, 06:08. Edited 1 time in total.

Reply 9 of 24, by Unregistered

User metadata

Hi Schadenfreude,

I do have some texture issuse but not all the time, the grass/ trees go a vivid green colour.

I have got rid of it a few times by changing from outside to inside the tank and back again.

The game does have d3d support but the texture under that (dx5a) are really screwed.

On the the rendering window size, that would be a great . Is it possible to do that?

Thaks for all your help, and big thank you to fabio for openglide.

Jeff

Reply 12 of 24, by Schadenfreude

User metadata
Rank Member
Rank
Member
Unregistered wrote:

Hi
This is for Jeff, regarding his May 10 M1 TP2 posts.
I have M1 TP2 too, and hoping you can help.
Which Glide version are you using, and where did you install it?
If you can help, thanks
BJ

See my first post in this thread. He's probably using the latest version of OpenGlide, but I am not sure.

Keep in mind that most glitches/problems with OpenGlide are usually caused by what graphics card you have, its support (or non-support) for 3D graphics, and which version drivers you are using.

First try putting OpenGlide's glide2x.dll in the folder the game's executable file is in (with the other files it comes with) and if that does not work (and you do not own a Voodoo card), place in your SYSTEM or SYSTEM32 folder (I'm not sure where the game would look.)

Reply 13 of 24, by Unregistered

User metadata

Hi Schad
Well, tried all your suggestions, but no luck.
I understand what you mean about different cards/drivers/etc.,
and I'm not sure I want to hassle myself to try and get one sim to look better, (but Jeff's screenies do make it tempting!)
But I would like to thank you for your reply, and your help.
BJ

Reply 15 of 24, by Unregistered

User metadata

Followup:
Tried the evoodoo emulation link provided.
Downloaded ver 3.2
Installed into M1 main folder/Dir.
Experimented. Winning combo was:
Disabled Opengl3.
In evoodoo control exe, disabled all boxes Except full screen.
Started M1 in glide mode again.

SUCCESS.

No slowdown, and good looking graphics.
Maybe not a whole new game, but definitely better than direct 3d or software mode.

Thank you VERY much for that link.

Reply 17 of 24, by Unregistered

User metadata

Well -
I posted too soon.
The Evoodoo glide works UNTILL artillery, aircraft, and tanks all start shooting at the same time.
Then everything slows to a crawl and the game becomes unplayable.
If I understand correctly: more units produce more "glide calls" which overwhelm my cpu & Ram - (AMD XP 1700+ & 768 Ram).
And it looked so GOOD. Damn.

So....
the 'competition' didn't work, either.

Reply 18 of 24, by Guest

User metadata

It is great to see a glide emulator that runs M1TP2! It looks as good as it did on the original. It is slow in some views, as some have mentioned here. More importantly, though, it crashes to desktop when I exit a battle. Does anyone know why? Or know of a solution, maybe a setting change?

Thanks!