VOGONS

Common searches


Guide - Windows 95 on DOSBox 0.74

Topic actions

  • This topic is locked. You cannot reply or edit posts.

Reply 21 of 123, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

@Svenne, it's explained in the guide and in my second post...

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for OS X (10.4-10.14 ppc/intel 32/64bit) codesigned for gatekeeper
DOSBox SVN with SDL2 snapshot for OS X (10.7-10.14 intel 64bit) codesigned for gatekeeper

Reply 22 of 123, by dada

User metadata
Rank Member
Rank
Member
Shouker wrote:
Show quote

Hi
I run windows 95B under dosbox 0.74
With machine=svga_s3 the display of icons is completely messed up for 256 colors, 16 bits and 32 bits colors.
I tried somes other s3 drivers but I didn't found something working properly
It is working for someone with svga_s3 ?

It should work just fine. I'm using svga_s3 as well. Try changing the output system (up in the sdl section). I've also got RAM set to 32 but I don't think that should matter. But Windows supports other video cards as well so svga_paradise would probably work as well.
edit: didn't realize there was a page 2 already, so I guess you already fixed it!

Reply 23 of 123, by robertmo

User metadata
Rank l33t
Rank
l33t
dada wrote:
Show quote

TODO

  • Get internet working
  • Get CD-ROM drive working (is this possible?)
  • Find out how to easily move win95 dir to disk image on Windows host operating system

internet:
use hal's build

cd:
it is possible www.vogons.org/viewtopic.php?p=176296#176296

easily move win95 dir to disk image:
just do both: mount and imgmount (don't boot) and copy whatever you want wherever you want

Reply 24 of 123, by Gadget2006

User metadata
Rank Newbie
Rank
Newbie

Hello,
I'm trying to install Windows 95B under DOSBox 0.74 (stock version, not the MegaBuild or any other modified revisions) - I got it all working smooth until the finalization stage when the installer sets up the Control Panel etc., there are many errors at that period saying "The program performed an illegal operation and will be closed" (this is usually referring to RegSvr32 or RunDll32). The installation completes and Win95 runs, but it's impossible to open the control panel to change the settings (the Explorer crashes) - is that normal behavior so far or is it just me doing something wrong?

P.S. I'm running with core=normal, cputype=pentium_slow, cycles=max, machine=svga_s3, all other settings at their default values.

Reply 27 of 123, by dada

User metadata
Rank Member
Rank
Member

My install was entirely done on core=normal. Actually, I installed it on core=simple before, which worked too until I reached Windows proper at which point it resulted in massive visual glitches. It should be working. Are you sure your Windows ISO is not damaged somehow?

Reply 28 of 123, by Gadget2006

User metadata
Rank Newbie
Rank
Newbie
dada wrote:

My install was entirely done on core=normal. Actually, I installed it on core=simple before, which worked too until I reached Windows proper at which point it resulted in massive visual glitches. It should be working. Are you sure your Windows ISO is not damaged somehow?

Well, it's the same thing I installed totally successfully over 15 years ago on my real DOS/Win9x rig, and I'm running it off of a backup ISO which I made from the CD several years ago - and I did try it out under VMWare some time ago and it did work fine, which means that the ISO was and is good... *shrug* Should be good as far as I can tell, but I'll check again to make sure of course. Will report back.

Reply 32 of 123, by Svenne

User metadata
Rank Member
Rank
Member

I got it working in DOSBox 0.74, but it doesn't work in the Megabuild. It plays half of the startup sound, and then DOSBox crashes. Any help, please?

Intel C2D 2.8 GHz @ 3.0 GHz | ASUS P5KPL | ASUS GTS250 1 GB | 4GB DDR2-800 | 500 GB SATA | Win 7 Pro/Ubuntu 9.10

Reply 34 of 123, by Jorpho

User metadata
Rank l33t++
Rank
l33t++
h-a-l-9000 wrote:

Only the first Win95 version runs more or less okay.

Is it the 95B/98 shell that causes the problem? (If it's installing but Explorer is crashing, it's a possibility, right?) It is a fairly straightforward matter to replace it with the shell from the first version of Win95 (either by using 98lite or by manually replacing a couple of files).

XP1 wrote:

This looks like a nice time-killer for Windows 95 lovers. However, wouldn't Windows 95 be more useful and functional if you used an actual OS virtualization software?

Indeed. I have the impression that Mr. Gadget2006 is seeking to run it on other platforms, however.

Reply 38 of 123, by ppgrainbow

User metadata
Rank Member
Rank
Member

Thanks. Do you mean the original release of Windows 95 or Windows 95 OEM Service Release 1? I thought that the OSR2 version of Windows 95 would work in DOSBox 0.73MB5, but it turns out that it is not supported.

And it's a good thing that I'm still running Windows 95 OSR2 under VMware Player with a 4 GB hard disk image, 64 MB of memory and 4 MB of video.