VOGONS


First post, by MadEgg

User metadata
Rank Newbie
Rank
Newbie

I retried it with the latest CVS-version and the performance is a whole lot better than I experienced before, it's now really playable.

But I can't seem to get the Sound Effects/Voices to work. Every time I select one of the sound effects devices the game crashes with a message about some error in audio.cpp.

Has anyone tried it/got it to work? If so, how? Or is this just a problem of the so far limited real mode support and should I just wait for new releases?

Eyyyy

Reply 1 of 7, by Nicht Sehr Gut

User metadata
Rank l33t
Rank
l33t

Originally posted by MadEgg Or is this just a problem of the so far limited real mode support

Actually real-mode support is fine, it's protected-mode that still needs a lot of work...and "GK" uses protected mode...

...and should I just wait for new releases?

Wait or try the Windows version (being sure to only save while the map is onscreen).

Reply 2 of 7, by MadEgg

User metadata
Rank Newbie
Rank
Newbie

Yes sorry, I meant protected mode of course.

I don't have any Windows on any of my boxes so I'll have to wait; but does it actually work in Windows' dosbox?

And what about the map? It corrupts when you save it outside the map? So that means you can't save at the part in Germany and further?

I'll just wait some more then :p

Eyyyy

Reply 3 of 7, by Nicht Sehr Gut

User metadata
Rank l33t
Rank
l33t

Originally posted by MadEgg I don't have any Windows on any of my boxes so I'll have to wait; but does it actually work in Windows' dosbox?

In 2000 or XP, it can only load or save when the map is displayed.

It should work if run within Win3.1 or Win9x.

Reply 4 of 7, by MadEgg

User metadata
Rank Newbie
Rank
Newbie

Ow, you meant running the Windows version of GK1? I've tried that a couple of months back on a Windows 98 machine, no luck there.

Game ran fine, but without sound and music. So not an option for me. That was on a Creative Soundblaster 16, which is supposed to be compatible with the game.
It also ran on that exact same machine when I put another harddrive in with only DOS 6.22 on it. But I hate swapping harddrives 😠

Eyyyy

Reply 5 of 7, by Nicht Sehr Gut

User metadata
Rank l33t
Rank
l33t

Originally posted by MadEgg Ow, you meant running the Windows version of GK1?

I was.

I've tried that a couple of months back on a Windows 98 machine, no luck there.

Results vary...

Reply 7 of 7, by Dark Knight ez

User metadata
Rank Newbie
Rank
Newbie

no offense, but this post is better...
it gets GK1 running flawlessly, dos-version using dosbox.

www.vogons.org/showthread.php?s=&threadid=2729