Veil of Darkness: Sound troubles

Getting old DOS games working on modern hardware. (DOSBox topics belong in DOSBox areas below, not here).

Veil of Darkness: Sound troubles

Postby Mystery » 2011-6-02 @ 16:49

Hi,

I'm having a really hard time getting Veil of Darkness to run with proper sound and music on my DOS PC.

Usually I don't have any trouble running anything on it and especially the sound configuration is quite solid.

Relevant system specs:
Pentium1 233MMX
SoundBlaster AWE32 with DB50XG
Gravis Ultrasound PNP
a couple of external Roland MIDI devices (SC55, MT32 etc.)
DOS 6.22

The best result I've gotten so far is soundeffects from the AWE32 and music from the PC speaker (what the..?).
I've disabled the GUS, but it hasn't given me any problems in other games so far, but I just wanted to be on the safe side.

The game won't even start when I select LAPC-I in the setup and I've only gotten sound and pc-speaker music to work with a specific IRQ/DMA setting. The setup isn't very helpful as I can't set everything individually.

I've read somewhere, that the game switches to PC speaker sound in DOSBOX when the cycles are too high, so I figured that the 233MHz might bee to fast. By disabling the L1/L2 caches I can throttle the system down to ~486DX40 specs, but this didn't change anything. Maybe it's still too fast? I might try using moslo or something similar.

The perfect solution would have music through the MT-32 and sound through the AWE32, but I'm willing to settle for SB16 OPL music with soundeffects.

Maybe someone can help me out here, I'd really appreciate any tips :)
::42::
User avatar
Mystery
Member
 
Posts: 190
Joined: 2010-4-11 @ 06:49

Re: Veil of Darkness: Sound troubles

Postby Shagittarius » 2011-6-05 @ 02:10

I'm running this under DOSBOX .74 with the cycles at max with CMS Soundblaster 220/7.

I've never been able to get the game to run with SFX and MT-32. I don't believe it supports multiple sound cards.

As far as the issue you are seeing though I dunno, try it with my setup and see if that helps you out even though your trying to run it in real dos.
User avatar
Shagittarius
Oldbie
 
Posts: 600
Joined: 2007-12-20 @ 06:49
Location: California, USA

Re: Veil of Darkness: Sound troubles

Postby Mystery » 2011-6-05 @ 05:40

But it should at least work with SFX + music through the soundblaster and not pc-speaker music.

I tried the 220/7 settings already, without success. I get SFX through the SB and at best pc speaker music, but no music through the sb's opl chip.

What are your soundcard's other settings? Maybe the game requires something specific it's not telling in the setup.
::42::
User avatar
Mystery
Member
 
Posts: 190
Joined: 2010-4-11 @ 06:49

Re: Veil of Darkness: Sound troubles

Postby ripsaw8080 » 2011-6-05 @ 08:57

Shagittarius wrote:I've never been able to get the game to run with SFX and MT-32. I don't believe it supports multiple sound cards.

The setup program doesn't have an option for it, but SB + MT-32 is possible with manual modification of the config file. Run the setup and choose SB with port/IRQ and save, then run setup again to select LAPC-1 and save, then in GRAPH.INI modify the byte at offset 0x08 from 0x58 to 0x30. Keep in mind that the game developers may have disallowed the combination because of potential problems, but I haven't encountered any.
User avatar
ripsaw8080
DOSBox Author
 
Posts: 4422
Joined: 2006-4-25 @ 23:24

Re: Veil of Darkness: Sound troubles

Postby Mystery » 2011-6-05 @ 10:28

The problem with the MT32 solution is, that the game crashes when I try to run it with the LAPC-I selected.

But I'll give it a shot.
::42::
User avatar
Mystery
Member
 
Posts: 190
Joined: 2010-4-11 @ 06:49

Re: Veil of Darkness: Sound troubles

Postby Shagittarius » 2011-6-07 @ 03:17

Thanks again ripsaw that's awesome! You always come through for fixes!
User avatar
Shagittarius
Oldbie
 
Posts: 600
Joined: 2007-12-20 @ 06:49
Location: California, USA

Re: Veil of Darkness: Sound troubles

Postby Kirben » 2015-7-14 @ 00:05

ripsaw8080 wrote:The setup program doesn't have an option for it, but SB + MT-32 is possible with manual modification of the config file. Run the setup and choose SB with port/IRQ and save, then run setup again to select LAPC-1 and save, then in GRAPH.INI modify the byte at offset 0x08 from 0x58 to 0x30. Keep in mind that the game developers may have disallowed the combination because of potential problems, but I haven't encountered any.

An old topic, but I was wondering if a similar work around is possible for The Summoning? which shared the same game engine as Veil of Darkness.
Kirben
Newbie
 
Posts: 30
Joined: 2010-7-10 @ 06:11
Location: Australia

Re: Veil of Darkness: Sound troubles

Postby ripsaw8080 » 2015-7-14 @ 01:29

The Summoning only has some FM sound effects with an AdLib or SB config, no PCM sound at all. If the lack of an IRQ setting in the setup program doesn't make that clear, the absence of PCM data in the resource file does.
User avatar
ripsaw8080
DOSBox Author
 
Posts: 4422
Joined: 2006-4-25 @ 23:24

Re: Veil of Darkness: Sound troubles

Postby mechcentric » 2019-4-11 @ 18:29

is there something like this for secret of monkey island?
mechcentric

AMD 386sx-40/33/25/20, 4MB SDR, CT2230
Intel 486dx2-66, ATI Mach32/64 VLB 1+1MB, 16MB SDR , CT2290
Pentium MMX 166, ATI Rage II + DVD, Voodoo1, YMF718-s
Pentium III 850, Voodoo3 3500, 2x256MB SDR, Aureal Vortex 2 (MX300), 10/100 LAN
Dell P991
User avatar
mechcentric
Newbie
 
Posts: 27
Joined: 2018-2-14 @ 13:01
Location: Washington, DC


Return to DOS

Who is online

Users browsing this forum: No registered users and 1 guest