First post, by dukeofarcadia

User metadata
Rank Newbie

I've got Skynet working great under dosbox 0.73,
only problem is I can't re-enter the same
building,truck or indoor location twice without
it causing a bizarre crash.

It is an orange screen of jumbled numbers and at the

I'm using a mounted cd as my method of playing this.

I've tried it with both my legitimate cd of the game, as well
as a separate ISO I acquired. (to make sure my cd wasn't
causing it)

Both have the problem sadly. If I could just figure out this
problem it will be running perfect! Has anyone else experienced
this problem?

If anybody could help it would be much appreciated!

Reply 4 of 32, by dukeofarcadia

User metadata
Rank Newbie

Is there a svn build you recommend?
there are many to choose from

Anyone running this without any issues?

More info:
So I looked at the terminal when it crashs,

it said; DYNX86: Can't run code on this page!

after I saw that I changed the core from auto
to normal.. it still crashes but I get a
different error message now.

Illegal write to (and then follows a large grouping
of random numbers)

Reply 6 of 32, by dukeofarcadia

User metadata
Rank Newbie

I tried the latest svn build you recommended
but Unfortunately the crash still persists.

Even though this person was playing "Future Shock"
and I'm playing "Skynet" (related games)

The person from this link seems to have the
exact same kind of crash. But unlike them..
changing the core to normal didn't work
for me. Just gave me a different error
message as I've stated above..

Terminator Future Shock issue

Like I said, game works great in every way. Except it's
really kind of ruined since I can't re-enter any locations
more than once. It's very strange how only this action
triggers it. Do the terminal crash errors I posted above
give anyone any clues to whats going wrong?

Reply 8 of 32, by dukeofarcadia

User metadata
Rank Newbie

Just for everyone's info

I'm running off a Windows XP
(just in case that matters
for this problem)

I would love to see a config file of somebody
who doesn't have this crash problem with
this game.. maybe that could help..

It's frustrating cause I feel like I'm so so
close to getting this game fully working

thanks for the help so far

Reply 10 of 32, by dukeofarcadia

User metadata
Rank Newbie

I have never saved the game. This problem has always occurred.
The problem makes it so you can't get past the first level. Because if you die, you re-enter the same truck and then it crashes.

The actual game play is great with no lag.

if it did save without my knowledge,
where would find these files?

Also I read here four posts down that this
kind of error is a directory cache problem or
something as said by ripsaw8080

terminator future shock crashing

I don't know what a directory cache problem is.. but
thought you might find it helpful in figuring this out..
I really appreciate the help!!

Reply 12 of 32, by dukeofarcadia

User metadata
Rank Newbie

try this.. enter a building.. leave it.. and then re-enter
the same building..

thats what crashes it.. not the first time you enter..
but the second time you enter the exact same location

In order to reproduce the crash. You must enter a
location that has a tiny load before entering.

That building your talking about should work though
if you do what I said

Reply 14 of 32, by dukeofarcadia

User metadata
Rank Newbie

I feel a lot better I'm not the only one.
So is this a universal problem? can it be fixed?

I know for sure this didn't happen back in the
windows 95 days.. so it must be a problem
within dosbox

svn 3630 - was a revision that was made specifically
for fixing a cache bug that was occurring in skynet..
do you think using this version might work?

Reply 16 of 32, by robertmo

User metadata
Rank l33t++

even 0.74 is not crashing with less than about 70000 cycles (it looks there is no strict limit)
So i wonder whether that 3630 patch was for something else or is not needed.
Does it help you too?