VOGONS


First post, by darry

User metadata
Rank Member
Rank
Member

I recently acquired an Ipox 3ETI23 industrial board (Tualatin support with 3 ISA slots, yay!) and installed my CT3670 AWE32/SB32 card with 2x4MB RAM .
Everything I<ve tested (AWE native mode, MPU-401 MIDI out) works perfectly EXCEPT aweutil /EM .

Every time I run it I get

I/O CHANNEL CHECK - CHECKING FOR SEGMENT
OFFENDING SEGMENT:
E000
PRESS F1 TO DISABLE NMI, F2 TO REBOOT

Pressing F2 does the obvious.
Pressing F1 displays :

SYNTHGM.SBK loaded
Set MIDI emulation to General MIDI
Reverb: ###############################################################
Chorus: ###############################################################

TSR installed

Of course, trying to use the GM emulation mode leads to a crash, so it obviously is not working as expected .
This leads me to two questions :

1) Is this what I would expect to see with a board that does not support NMI as far as aweutil is concerned ?
2) Are there any known workarounds (besides changing RAM parity settings in BIOS, if possible) ?

Reply 1 of 4, by jesolo

User metadata
Rank Oldbie
Rank
Oldbie

The error message itself indicates a problem with your memory. Hence, why it is "asking" you to either disable your memory parity error checking or reboot.
Make sure you are using the same type of memory.

You could also try to:

  • restore your BIOS defaults, reboot and see if that doesn't solve the problem.
  • clean the contacts of the memory and reseat them.
  • swop out your memory, as it might be a problem with one of your memory modules.

The only solution that Creative provided was to enable the memory parity error checking in your BIOS in order to also enable non maskable interrupts (NMI's).

Unfortunately, if your motherboard does not have a working NMI, then you cannot use Aweutil with the /EM switch.
Your only other alternative would then be to try and run your game via a Command Prompt from within Windows 9x. The added benefit of this is that you can load custom soundfonts and play back those sounds.

Reply 2 of 4, by darry

User metadata
Rank Member
Rank
Member

Thank you for input, jesolo .

I tried resetting CMOS and using different memory but had the same results, so I am now pretty confident it a motherboard incompatibility
I actually never owned an AWE in its heyday (I was a Gravis fanboy) and wanted to experience it fully, warts and all . Luckily I have some external modules, so I won't miss AWE General Midi compatibility that much and I won't shed any tears if I never, ever need to run Gravis' MegaEm either .

Reply 3 of 4, by darry

User metadata
Rank Member
Rank
Member

Your only other alternative would then be to try and run your game via a Command Prompt from within Windows 9x.

I can confirm that MPU401 redirection under Windows 98 seems to work on my system .

Reply 4 of 4, by jesolo

User metadata
Rank Oldbie
Rank
Oldbie
darry wrote:

Your only other alternative would then be to try and run your game via a Command Prompt from within Windows 9x.

I can confirm that MPU401 redirection under Windows 98 seems to work on my system .

For most protected mode games (like Doom, Duke Nukem 3D, etc.), this option seems to work fine for me as well. Although, I do recommend exiting the Command Prompt and restarting before trying to launch another game.
I've had mixed results with real mode General MIDI DOS games (i.e., those that do not make use of a DOS extender).