Sound Blaster 16 CT2740 Hanging note bug or not?

Discussion about old sound cards, MIDI devices and sound related accessories.

Sound Blaster 16 CT2740 Hanging note bug or not?

Postby bjwil1991 » 2017-11-10 @ 16:23

I found a card online, the Sound Blaster 16 CT2740 which has the DSP version 4.11 and I'm trying to figure out if this card has a hanging note bug.

Hanging Note Bug - Vogons Wiki: This site doesn't have the card listed, so I don't know if it does or not. I did ask the seller to check and see if there's a hanging note bug.

The card has the CT1747 bus interface, so there is no Type 1 hanging note bug, but IDK if it has the Type 2 hanging note bug, or if it doesn't have that (that'll be the day).
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 462, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1947
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Sound Blaster 16 CT2740 Hanging note bug or not?

Postby clueless1 » 2017-11-10 @ 17:46

I think this quote from the Hanging Note Wiki answers your question:
Affected are all Sound Blaster models with DSP revisions 4.11, 4.12 and 4.13.
The more I learn, the more I realize how much I don't know.
Let's benchmark our systems with cache disabled
DOS PCI Graphics Card Benchmarks
User avatar
clueless1
l33t
 
Posts: 3681
Joined: 2015-12-22 @ 17:43
Location: Midwest US

Re: Sound Blaster 16 CT2740 Hanging note bug or not?

Postby bjwil1991 » 2017-11-10 @ 18:14

clueless1 wrote:I think this quote from the Hanging Note Wiki answers your question:
Affected are all Sound Blaster models with DSP revisions 4.11, 4.12 and 4.13.


Also, another quote from the Wiki:
Type 1 doesn't occur on cards with a CT1747 bus interface.


The card has the CT1747 bus interface (OPL3) and the card was manufactured in 1993. However, I don't see the card in the list of affected cards.
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 462, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1947
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Sound Blaster 16 CT2740 Hanging note bug or not?

Postby jesolo » 2017-11-10 @ 18:35

The list on the Wiki page is not exhaustive.
This particular model will therefore only have the Type 2 bug.
However, as also mentioned, this occurs very rarely.
User avatar
jesolo
Oldbie
 
Posts: 1488
Joined: 2014-6-24 @ 19:04
Location: South Africa

Re: Sound Blaster 16 CT2740 Hanging note bug or not?

Postby bjwil1991 » 2017-11-10 @ 19:14

jesolo wrote:The list on the Wiki page is not exhaustive.
This particular model will therefore only have the Type 2 bug.
However, as also mentioned, this occurs very rarely.


Guessing it's because if the song's soundtrack has a hanging note, the "Note off" command is often missed? I found another forum about different types of bugs: Sound Blaster 16 Bugs and Deficiencies Summary
C64, WheelWriter 10 Series II QuietWriter 8, Pack-Mate 28 Plus, K6-2/300, Pavilion N3350, iMac G3 & G4, Socket 462, 2x Inspiron 600m, Athlon 64, Dimension 4550 & E510, ThinkPad R40, Presario C700, ASUS X54C, Raspberry Pi B+, 2B-3B+, Custom FX-6300
User avatar
bjwil1991
Oldbie
 
Posts: 1947
Joined: 2013-8-14 @ 03:10
Location: SE, MI USA

Re: Sound Blaster 16 CT2740 Hanging note bug or not?

Postby derSammler » 2017-11-10 @ 20:33

bjwil1991 wrote:Guessing it's because if the song's soundtrack has a hanging note, the "Note off" command is often missed?

Sort of. It does not really just affect the "Note off" command; every MIDI command can get corrupted randomly. But due to the way MIDI works, you only really notice it if a "Note off" command gets corrupted. Also, it will be more present the higher the polyphony of the MIDI module / wavetable is.
derSammler
Oldbie
 
Posts: 1779
Joined: 2017-4-14 @ 11:30
Location: Germany


Return to Sound

Who is online

Users browsing this forum: No registered users and 2 guests