Moto Racer 2 performance with socket 7

Getting old software/games running on older hardware.

Moto Racer 2 performance with socket 7

Postby boink » 2017-12-07 @ 23:21

I have tried moto racer 2 on my geforce256 on two different boards (Asus P5A and the DFI K6XV3+/66) with a k6-2 450 and the game runs pretty bad at even medium settings and 640x480 resolution, i'd guess that by the date the game was released it seems odd that it runs so badly, did anyone with a similar system ever try the game and could tell me if this is normal? Still didn't test with the geforce2 but just seems odd it runs so badly :(.

Running with 64mb ram atm but tried with 128 too and using the 45.23 nvidia drivers.

The game lists a Pentium 166 under minimum specs which is why i'm finding it weird that it runs so slow, tried disabling cd audio in case that was the issue but no, also using the patch 3.14 and have directx 8.1 installed plus the unofficial service pack 2.1a, the sound also goes to hell once the races start with random stutters so guess the game is bogging the cpu down pretty heavily, the sound card is a pci fm801-au (PCI)

Thank you in advance.
boink
Newbie
 
Posts: 18
Joined: 2017-11-12 @ 17:53

Re: Moto Racer 2 performance with socket 7

Postby clueless1 » 2017-12-08 @ 00:39

I would try an older nvidia driver and directx. Try DX7 and nvidia 6.31 to start. If it runs better, you can incrementally inch forward til you see the performance tank. Some graphics cards may be compatible with newer drivers, but perform much better on drivers closer to their period of relevance. A good rule of thumb I've heard is add a year to the release date of a card and pick the current driver. So the GF256 was supported in late 1999 (nvidia 3.68) and DX7 was current. Add a year...late 2000. Current driver in late 2000 was 6.31. The game is a DX6 game, so I'd start with DX7, even though DX8 was current in late 2000.

edit: also, try different versions of chipset drivers if that doesn't help. Use the same strategy...pick a version closer to 1999-2000.

Have you tried any other games? Is this behavior consistent or limited to Moto Racer 2?
The more I learn, the more I realize how much I don't know.
Let's benchmark our systems with cache disabled
DOS PCI Graphics Card Benchmarks
User avatar
clueless1
l33t
 
Posts: 3633
Joined: 2015-12-22 @ 17:43
Location: Midwest US

Re: Moto Racer 2 performance with socket 7

Postby boink » 2017-12-08 @ 01:57

Thank you, yeah so far the odd one out i noticed was Moto Racer 2, other games i've tried so far have been alright and moto racer 1 runs well (Only didn't run too well on the cyrix 6x86l).

Other games where i noticed slow 3d performance was on stuff like school tycoon which i just wanted to test but that one makes more sense since it was released in 2004 or so.

Will try 6.31 thank you, chipset wise already installed 1.72 thinking it could be something with the newest chipset drivers.

It's pretty odd though since it really feels like everything is at full load, the audio issues and also if i don't have other riders in front of me or turning into something not too detailed it speeds up.

Just finding it odd that a 1998 game is putting such a strain on the pc.
boink
Newbie
 
Posts: 18
Joined: 2017-11-12 @ 17:53

Re: Moto Racer 2 performance with socket 7

Postby boink » 2017-12-10 @ 21:15

Did a fresh install with dx7 and nvidia drivers 6.31 + aliagp 1.7 but still the same :(

Maybe it's just a odd game but i'll check again tomorow when i get some k6-iii+'s maybe that will help.

Thanks!
boink
Newbie
 
Posts: 18
Joined: 2017-11-12 @ 17:53


Return to Software

Who is online

Users browsing this forum: No registered users and 1 guest