Voodoo 5 5500 AGP black screen upon installing drivers? (Drivers solved) V5 repaired

Discussion about old graphics cards, monitors and video related things.

Voodoo 5 5500 AGP black screen upon installing drivers? (Drivers solved) V5 repaired

Postby GhostyGhost » 2018-6-04 @ 21:15

Hi everyone!

I recently completed my first Windows 98SE build from scratch and it was fun until I got driver problems with the Voodoo 5 5500 AGP.
Everything works fine during plug and play but when I install the drivers, which I have a genuine copy in hand, the system gives me a black screen with a cursor and hour glass. I then went into safe mode to remove the drivers and try changing the BIOS settings but no luck. So whenever I start up the PC now. WIndows will automatically reinstall the drivers and it's back to the black screen after the computer restarts. I tried changing also to 256 color mode but that also fails. I rarely get that option now. I also tried trying out the other drivers from driver library and some other websites but no luck still.

The only way for me to open Windows 98SE is to constantly remove the drivers before I restart or during safe mode.
Also searched many forums but now luck. Not even the internet got any posts about this issue.

Anyone know a thing about this by any chance?

Specs
OS: Windows 98SE
GPU: Voodoo 5 5500 AGP (EU version)
Motherboard: ASUS TUV4X rev 1.01
RAM 512Mb

EDIT: I have determined that the Voodoo 5 5500 had hardware problems. The problems have been fixed and all is well now. Those lines were definitely artifacts from the V5.
Last edited by GhostyGhost on 2019-9-06 @ 14:06, edited 5 times in total.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby skitters » 2018-6-06 @ 15:41

I've never owned a Voodoo5 but I read they are AGP 1x/2x
Does the ASUS TUV4X motherboard have an option in the BIOS to run AGP at 2x ?
User avatar
skitters
Member
 
Posts: 421
Joined: 2004-11-17 @ 20:08
Location: US

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby GhostyGhost » 2018-6-06 @ 19:55

skitters wrote:I've never owned a Voodoo5 but I read they are AGP 1x/2x
Does the ASUS TUV4X motherboard have an option in the BIOS to run AGP at 2x ?


It does and I already tried using it on AGP 2X mode and AGP 1X mode too. I got no luck.
I always get a Black screen with a movable mouse cursor and hourglass. But no boot. I'm lost and don't know what to do. My Bios recognizes it but won't use it after installing drivers.
interestingly enough, when this happens, the CD drive won't open and is frozen stuck during the black screen. Also it the PC doesn't Beep until prior the Windows 98SE logo appears while booting.

It's very strange and I don't understand why this happens.

Maybe it's time to flash my BIOS. Or unless there is something more I can do. Either way, my PC won't boot when I switch the speed to my CPU speed to 1000Mhz even though it's natural. Stuck on 666Mhz.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby GhostyGhost » 2018-6-07 @ 05:11

Good news and Bad news. The good news is by updating to BIOS 1006 for my ASUS TUV4X Motherboard, I corrected my CPU speed problem. Bad news is that the video card still displays a black screen. On the bright side, I was very close to stabilizing the system for a moment. But it promptly went back to non working mode and it was back to disabling the drivers from Safe Mode.

So far I've tried all the drivers for Windows 98SE and nothing works almost. I really wish I found a way to get this done. But I think I am coming a long way to solving this mystery of the black screen issue. Just need more ideas and time.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby Justin1091 » 2018-6-07 @ 09:36

Maybe try a DOS glide game to test it in DOS mode? Is palette snooping disabled in the bios? Can you see the card when you turn on your PC? There should be a list of devices after the post.

Can also try Windows 2000 to test it, it's more stable and also has drivers for the card. I've also had weird freezes and it turned out a ram module was faulty so you should try memtest86. Just put it on a diskette and boot your pc with it.
Other than that maybe try a different psu.
Justin1091
Member
 
Posts: 112
Joined: 2017-6-29 @ 18:31
Location: The Netherlands

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby GhostyGhost » 2018-6-07 @ 14:14

Justin1091 wrote:Maybe try a DOS glide game to test it in DOS mode? Is palette snooping disabled in the bios? Can you see the card when you turn on your PC? There should be a list of devices after the post.

Can also try Windows 2000 to test it, it's more stable and also has drivers for the card. I've also had weird freezes and it turned out a ram module was faulty so you should try memtest86. Just put it on a diskette and boot your pc with it.
Other than that maybe try a different psu.


Unfortunately I don't have any DOS Glide games on me but I did ordered Blood, which has yet to arrive. As for your other questions
2. I have disabled Palette Snooping in BIOS
3. I checked the list of devices after POST by disabling the HDD and this is what I get
4. I don't have Windows 2000 on hand so I can't test it out.
5. I haven't tried Memtest86 yet but will try it now.

Also now I have begun getting an RUNDLL error for loading 3dfxCmn.dll saying the system cannot find it. This part just appeared. I think it was from using the Amigagremlin 2.9 drivers.
Attachments
DSC_0033.JPG
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby Justin1091 » 2018-6-07 @ 14:46

Hmm looks fine, bit odd that it has IRQ 5 though. Sometimes the parallel port uses that IRQ or a soundblaster (7 or 5). Maybe check which irq your parralel port uses in the bios. If it's set to irq5, disable it and try again. Can also try 'clear escd' or 'clear extended configuration' in your bios. Should be near the 'PnP OS' option. About pnp, you can also try flipping that option, I personally always use 'No'.

If it doesn't work remove everything from the PC but the Voodoo5. Disable everything like serial ports etc and try again.

As for the memtest you can try testing one dimm and then use that to go further, testing 4 dimms may take a while.
Justin1091
Member
 
Posts: 112
Joined: 2017-6-29 @ 18:31
Location: The Netherlands

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby GhostyGhost » 2018-6-07 @ 15:30

Justin1091 wrote:Hmm looks fine, bit odd that it has IRQ 5 though. Sometimes the parallel port uses that IRQ or a soundblaster (7 or 5). Maybe check which irq your parralel port uses in the bios. If it's set to irq5, disable it and try again. Can also try 'clear escd' or 'clear extended configuration' in your bios. Should be near the 'PnP OS' option. About pnp, you can also try flipping that option, I personally always use 'No'.

If it doesn't work remove everything from the PC but the Voodoo5. Disable everything like serial ports etc and try again.

As for the memtest you can try testing one dimm and then use that to go further, testing 4 dimms may take a while.


I checked the Parallel port and it uses 7 so that's fine. I can't tell if the soundblaster is using 5 but I did get some notice before of a conflicting IRQ. Could be that.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers?

Postby GhostyGhost » 2018-6-07 @ 16:02

I figured out it was a registry issue. I begun using the revert OS registry and the system works fine but there is so much junk from the previous drivers and stuff I installed after installing the OS. The stuff lingering are even 3DFX unistaller can't do it. So I will reinstall Windows 98SE and see if I can fix it from there. I only had it installed for 3 days so it's no big deal.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby GhostyGhost » 2018-6-07 @ 19:20

Great news everyone!
I've discovered the problem and it was definitely registry issues. The Clean install did the trick at first. But then I begun to have troubles. More Safe mode driver uninstallation later and I eventually solved the issue. To fix the issue all you had to do was
1. When Windows 98SE boots. Put the CD for the drivers inside and allow it to scan it, even though this does nothing.
2. IGNORE the restart prompt to get in the desktop.
3. Uninstall the drivers for the Voodoo 5 5500 AGP again.
4.IGNORE the restart prompt.
5. Use the 3DFX uninstall utility to clean registry of remnants of the just uninstalled Voodoo 5 5500 AGP drivers
6. Go to My Computer and right click on the 3DFX CD and "explore" the contents. Click on the folder with your preferred language on it. (in my case I was using the Voodoo 5 1.3 CD drivers)
7. Click on the win9x to begin the installation.
8. Click reinstall drivers and only that.
9. Agree to restart computer this time.
10. Ta da it's done. Now install the 3DFX tools and Restart again.
11. Should be no problem from here now. Now install DirectX 7 and restart.
12.You may now change the display and resolution as you see fit. But I am having some minor issues now and have to ask. How do you fix this?
Attachments
DSC_0034.JPG
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby GhostyGhost » 2018-6-07 @ 19:25

I think I need a new monitor as this EVOV VT7W71 monitor doesn't have the right stuff. But this was some very good work in researching this problem. Also the 3DFX tools are not very responsive right now. I will just ignore this.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby Justin1091 » 2018-6-07 @ 19:59

It shouldn't be so much work installing the drivers, clearly something isn't working properly be it a setting somewhere or something else. I've installed mine countless times and it always worked immediately. Go to falconfly.de and install 3dfx latest reference drivers, if they don't work you should have another closer look.
You can test the card by running a direct3d test (dxdiag.exe) in RUN. Make sure you updated directx to 8 or later for the test.
Justin1091
Member
 
Posts: 112
Joined: 2017-6-29 @ 18:31
Location: The Netherlands

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby GhostyGhost » 2018-6-07 @ 20:27

Justin1091 wrote:It shouldn't be so much work installing the drivers, clearly something isn't working properly be it a setting somewhere or something else. I've installed mine countless times and it always worked immediately. Go to falconfly.de and install 3dfx latest reference drivers, if they don't work you should have another closer look.
You can test the card by running a direct3d test (dxdiag.exe) in RUN. Make sure you updated directx to 8 or later for the test.


I totally agree. It shouldn't but if you were here, you'd be shaking your head in disbelief.

I installed the drivers as said by the manual and it didn't work right. I tried the other drivers from the Vogons library but they had no luck as they came up with issues when I tried previously. I'm tempted to try again but I don't want to risk having to wipe my HDD again and reinstall. After all the Registry errors kept piling up in my PC which lead to the problems to get worse.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby Justin1091 » 2018-6-07 @ 20:58

About those registry errors:

Don't know how fast your disks and your CPU are, but Windows 98 shuts down retardedly fast when your PC is fast (fast as in ~500mhz or more).
Microsoft released a patch to delay the shutdown time back in 2000. Those errors could be caused by the PC shutting down too fast and your HDD not being able to flush it's cache in time.

http://www.tacktech.com/display.cfm?ttid=90

It's the third one on that site (Windows98SE Patch - 273017usa8.exe (225KB). I Always install this one the first moment after installing Windows 98. Keep in mind it's English so it might change your shutdown screen's language to English. And the pieces of shit no longer host any patch on their site and break all links to KB articles. It's very hard to get other language patches. I do have all the official patches in Dutch, so if your installation is Dutch I can send them to you :)

Even if this doesn't fix your problems it's good practice to install it.

What kind of registry errors does Windows show you? How does device manager look? Any exclamation marks near devices?

Oh and those weird colors no idea, never seen them. Try a different monitor or resolution/refresh rate first.
Justin1091
Member
 
Posts: 112
Joined: 2017-6-29 @ 18:31
Location: The Netherlands

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby GhostyGhost » 2018-6-07 @ 21:20

Justin1091 wrote:About those registry errors:

Don't know how fast your disks and your CPU are, but Windows 98 shuts down retardedly fast when your PC is fast (fast as in ~500mhz or more).
Microsoft released a patch to delay the shutdown time back in 2000. Those errors could be caused by the PC shutting down too fast and your HDD not being able to flush it's cache in time.

http://www.tacktech.com/display.cfm?ttid=90

It's the third one on that site (Windows98SE Patch - 273017usa8.exe (225KB). I Always install this one the first moment after installing Windows 98. Keep in mind it's English so it might change your shutdown screen's language to English. And the pieces of shit no longer host any patch on their site and break all links to KB articles. It's very hard to get other language patches. I do have all the official patches in Dutch, so if your installation is Dutch I can send them to you :)

Even if this doesn't fix your problems it's good practice to install it.

What kind of registry errors does Windows show you? How does device manager look? Any exclamation marks near devices?

Oh and those weird colors no idea, never seen them. Try a different monitor or resolution/refresh rate first.


Completely forgot about the CPU and HDD post. But you are definitely right about the speed of my PC shutting down. I have a 1000Mhz (1Ghz) Coppermine CPU with a 120GB Hitachi HDD running at 7200RPM with mode being DMA/ATA 100. And it restarts in 3 seconds flat. I will try out the patches and see what happens. I am currently running on 32bit color mode and tried another monitor as you said but no luck. Probably has to do with the fact I need drivers for the motherboard AGP configuration. Maybe it will do me some good. If it works. Or I need better monitor drivers. But thank you for your help. I really appreciate it.
If life throws a wrench into your plans, then show life that no matter what it does to you, you will always prevail.
User avatar
GhostyGhost
Newbie
 
Posts: 38
Joined: 2018-4-19 @ 23:22
Location: The Underworld

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby Justin1091 » 2018-6-07 @ 22:05

I don't think drivers for your monitor or motherboard chipset will fix those weird spots shown in your photo (but, you should always install them yes), try a different VGA cable. Is it a flat panel? Then press auto adjust on it. It **may** be something wrong with the voodoo5 as the image should be clean.
Don't forget the directX test (or a 3D game, doesn't matter, you can try 3Dmark99 or 3Dmark2000)! Don't forget to test the memory of your PC as well, I've spent hours cursing and swearing because Windows2000 couldn't read my CDROM drive during it's installation and it turned out a RAM module was Bad. All kinds of crazy errors can occur when RAM is bad.
You''re welcome by the way!
Justin1091
Member
 
Posts: 112
Joined: 2017-6-29 @ 18:31
Location: The Netherlands

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (Drivers solved)

Postby candle_86 » 2018-6-12 @ 13:22

Just install the Windows 98 unoffical SP3
Ryzen 5 1600 - Gigabyte B350 Gaming - 16gb DDR4 3200 - 240GB M.2 - Windows 10 Pro
Core i3 3470 - Dell B75 Mobo - 4gb DDR3 1333 - 500gb HDD - Windows XP
Opteron 180 - Epox EP-9NPA+SL - 2gb DDR500 - 320GB HDD - Windows XP
User avatar
candle_86
l33t
 
Posts: 2263
Joined: 2010-8-06 @ 01:04
Location: Fort Worth, Republic of Texas

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby egbertjan » 2019-8-20 @ 10:21

I read here that you have all updates in Dutch for Windows 98 SE. I'm looking for that. Would you send them to me?

Justin1091 wrote:About those registry errors:

Don't know how fast your disks and your CPU are, but Windows 98 shuts down retardedly fast when your PC is fast (fast as in ~500mhz or more).
Microsoft released a patch to delay the shutdown time back in 2000. Those errors could be caused by the PC shutting down too fast and your HDD not being able to flush it's cache in time.

http://www.tacktech.com/display.cfm?ttid=90

It's the third one on that site (Windows98SE Patch - 273017usa8.exe (225KB). I Always install this one the first moment after installing Windows 98. Keep in mind it's English so it might change your shutdown screen's language to English. And the pieces of shit no longer host any patch on their site and break all links to KB articles. It's very hard to get other language patches. I do have all the official patches in Dutch, so if your installation is Dutch I can send them to you :)

Even if this doesn't fix your problems it's good practice to install it.

What kind of registry errors does Windows show you? How does device manager look? Any exclamation marks near devices?

Oh and those weird colors no idea, never seen them. Try a different monitor or resolution/refresh rate first.
egbertjan
Newbie
 
Posts: 22
Joined: 2019-8-20 @ 08:52

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (Drivers solved)

Postby meljor » 2019-8-20 @ 10:37

Did you check that both gpu's are actually functional in windows?
asus tx97-e, 233mmx, voodoo1, s3 virge ,sb16
asus p5a, k6-3+ @ 550mhz, voodoo2 12mb sli, gf2 gts, awe32
asus p3b-f, p3-700, voodoo3 3500TV agp, awe64
asus tusl2-c, p3-S 1,4ghz, voodoo5 5500, live!
asus a7n8x DL, barton cpu, 6800ultra, Voodoo3 pci, audigy1
meljor
Oldbie
 
Posts: 1747
Joined: 2014-4-30 @ 19:43
Location: Netherlands

Re: Voodoo 5 5500 AGP black screen upon installing drivers? (almost solved)

Postby egbertjan » 2019-8-26 @ 15:05

Can you give me your email address via a private message? I have not been on this forum long enough to be allowed to use private messages
I would like to receive the NL Windows 98 Se updates from you?

egbertjan wrote:I have read your private message to me about the Dutch updates of Windows 98se

egbertjan wrote:I read here that you have all updates in Dutch for Windows 98 SE. I'm looking for that. Would you send them to me?

Justin1091 wrote:About those registry errors:

Don't know how fast your disks and your CPU are, but Windows 98 shuts down retardedly fast when your PC is fast (fast as in ~500mhz or more).
Microsoft released a patch to delay the shutdown time back in 2000. Those errors could be caused by the PC shutting down too fast and your HDD not being able to flush it's cache in time.

http://www.tacktech.com/display.cfm?ttid=90

It's the third one on that site (Windows98SE Patch - 273017usa8.exe (225KB). I Always install this one the first moment after installing Windows 98. Keep in mind it's English so it might change your shutdown screen's language to English. And the pieces of shit no longer host any patch on their site and break all links to KB articles. It's very hard to get other language patches. I do have all the official patches in Dutch, so if your installation is Dutch I can send them to you :)

Even if this doesn't fix your problems it's good practice to install it.

What kind of registry errors does Windows show you? How does device manager look? Any exclamation marks near devices?

Oh and those weird colors no idea, never seen them. Try a different monitor or resolution/refresh rate first.
egbertjan
Newbie
 
Posts: 22
Joined: 2019-8-20 @ 08:52

Next

Return to Video

Who is online

Users browsing this forum: No registered users and 2 guests