WfW 3.11 + Matrox Millennium II driver freezes

Discussion about old graphics cards, monitors and video related things.

WfW 3.11 + Matrox Millennium II driver freezes

Postby Dracolich » 2019-5-11 @ 15:56

Hi, folks, I have a K-6/233 with 128MB SDRAM build that multiboots via swapping CF cards in a CF-IDE adapter. My original problem was that in OS/2 Warp and Linux, when switching from a graphic desktop to fullscreen text mode the screen was corrupted. This was while using a Paradise 4MB Virge/GX at 1024x768 16bpp paired with a 4MB Voodoo1. OS/2 used the GRADD/SciTech driver and Linux used its native S3V driver. However, this problem did not happen in WfW 3.11 or Win95c using the S3 Virge drivers. For a photo of the screen corruption see here where I asked about this regarding the S3 in Linux:
https://www.linuxquestions.org/questions/showthread.php?p=5994016

So I followed the suggestion to replace the S3 card with a Matrox, got a good deal on a 4MB Millennium II and installed it yesterday. For WfW 3.11 I used the Millennium II/Mystique 220 cd available on this site. The drivers installed but no matter which resolution+bpp I choose Windows fails to start as if it is an unsupported mode. So I installed the slightly newer Millennium/Mystique series 3.1x driver also on this site. This one does load 1024x768 16bpp and 8bpp. However, the fonts are too large and the system freezes after a few seconds. The custom SVGA driver with VESA support works properly in 1024x768 16bpp. In Linux also the gui freezes when using 16bpp but does work in 8bpp. I have not yet tried Warp or Win95c.

I wonder if removing the Voodoo card or swapping the Voodoo and Matrox slots might help. The mobo is a QDI Titanium IB+ and currently the Voodoo1 is in PCI3 and the Matrox is in PCI4 plus a nic in PCI2. The MGAMON dos utility reports that VGA is enabled, but in Windows (using the SVGA driver) the card info utility shows VGA is disabled. Previously I had the Virge in PCI2, the Voodoo1 in PCI3 and the nic in PCI4. I rearranged the cards only for aesthetics. I do like this Millennium II. It kicks the Virge's butt in my DOS games. :)
Dracolich
Newbie
 
Posts: 69
Joined: 2017-8-07 @ 13:45

Re: WfW 3.11 + Matrox Millennium II driver freezes

Postby Dracolich » 2019-5-12 @ 12:02

Last night I got into the MGA Control Panel utility and set a mode for 1024x768 8bpp with small fonts and it is working now. I just don't understand why 16bpp is not working. Does the Mystique 220/Millennium II not support 16? How about 24 or 32?
Dracolich
Newbie
 
Posts: 69
Joined: 2017-8-07 @ 13:45

Re: WfW 3.11 + Matrox Millennium II driver freezes

Postby Dracolich » 2019-5-13 @ 11:57

It seems that the arrangement of the cards was the cause. A big clue was when I booted OS/2 Warp attempting to install the driver. Any video mode higher than basic VGA 640x480 would cause it to hang during boot when loading the nic driver. If I disabled the nic driver then SVGA modes would work. So I rearranged the cards back so that the Matrox is in the highest slot and now it's working great. All of my OSs now are running 1024x768 16bpp with no problem. I think this is the first card I've ever had that is particular about slot order.
Dracolich
Newbie
 
Posts: 69
Joined: 2017-8-07 @ 13:45


Return to Video

Who is online

Users browsing this forum: No registered users and 1 guest