PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Discussion about old graphics cards, monitors and video related things.

PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby pentiumspeed » 2019-2-05 @ 04:40

I have a Dell version of TNT2 M64 16MB with two PCI buffers ICs near PCI connector but I'm having a problem with this for intended goal:

Since I only have one socket 7 pentium Micronics M55Hi Plus board based on 430HX chipset, 64MB, 200mhz. Even PCI support is version 2.1 but;

Yet I cannot get this TNT2 M64 card to initialize on boot up, no video. But I can use FX 5200 (128bits) PCI and another PCI video card with no problems. Same TNT2 M64 get initializes fine on any motherboards I have.

Problem with this is finding good PCI video cards can be expensive easily.

Intended goal for this Pentium 200 machine is for DOS games that cannot be run right on PII even at 233mhz with AGP video card (too fast even AGP too?). I thought TNT2 as basic VGA could be faster than these these and but finding anything PCI video cards stronger than S3 or Cirrus Logic video card is not easy.

I have a PIII 500 with BX board working very well but I don't know if this can support some fussy DOS games compatiablity-wise and early, middle Win98se sufficiently?
I have plenty of AGP video cards to choose from. I have few overkill AGP boards for P4 and Athlon XP CPUs as well but this will be built later for 98se/2000 and early XP. For anything else that is happy on XP, I have plenty of PCIe boards to choose from as well and I'm not concerned about this.

Cheers, Pentiumspeed
pentiumspeed
Newbie
 
Posts: 84
Joined: 2017-5-17 @ 23:17

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby STX » 2019-5-10 @ 12:17

I'm surprised that your TNT2 M64 wouldn't work. I'd examine the PCI slot under good lighting. Maybe there is a foreign object that's interfering with the connection.

Alternatively, you could try lowering the speed of your PIII with Throttle.
User avatar
STX
Member
 
Posts: 193
Joined: 2013-7-10 @ 22:19
Location: USA

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby AlaricD » 2019-5-10 @ 14:26

STX wrote:I'd examine the PCI slot under good lighting. Maybe there is a foreign object that's interfering with the connection.

If it were me troubleshooting, I'd have tried other PCI slots. Also, that FX5200 and another card work fine, so while it'd be a good idea to check the slot, it's not extremely likely that it's the problem.

I've seen those Dell TNT2 M64 cards listed on eBay before, and one listing in particular said:
...while this card has a universal 3.3/5 volt PCI connector, it will mostly likely not work on older motherboards with 5volt only PCI slots. So if you have a Socket 7 / Super Socket 7 based motherboard this card probably will not work. I'd use this card in systems with the Intel 440BX, i810, i815, Via KTxxx chipset or newer.

At the time it made me hesitate to buy it (but had a nagging feeling they weren't quite correct) but not maybe it seems there's something to what they said. My 430FX-based Shuttle HOT-541 needs a decent graphics card :(
User avatar
AlaricD
Member
 
Posts: 438
Joined: 2017-6-28 @ 19:11
Location: Stillwater, America

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby pentiumspeed » 2019-5-16 @ 00:50

Been awhile to post another data: Update on this video cards:

I received two S3 video cards while ago: DX and GX and they works perfectly on this 430HX chipset board.

Will ask more in new post later, specificially PII using AGP Riva 128 card as alternative choice but I heard that PII is too "fast" in this context?

Cheers, pentiumspeed
pentiumspeed
Newbie
 
Posts: 84
Joined: 2017-5-17 @ 23:17

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby appiah4 » 2019-5-16 @ 08:09

Out of curiosity, is this the card you have?

Image
A500:Rev6|+512K|ACA500+|C1084S
i386:Am386SX25|4M|GD5402|ES688|MuntPi3
i486:U5S33|8M|GD5428|YMF719|DB-S2
i586:P133|32M|T64+/MX2|V1|CT3980/32M
i686:K6-2/400|128M|V2/SLI|CT4520/32M
S370:P3-1200|384M|GF4-4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 4039
Joined: 2017-2-19 @ 07:36

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby pentiumspeed » 2019-5-23 @ 01:27

Yes this is same type of video card board design I have TNT2 M64 16MB, not defective as I tested this same card on PIII and later boards to make sure. What the reason for asking about this?

What I do not understand is bios initialization does not work on socket 7 motherboard with this. Does this exact same video card works in pentium socket 5 and 7 of different motherboards? Any processors that fits socket 5 or 7, any chipset, success with this type of TNT2 M64 16mb card? Mine is Micronics motherboard.

3.3V PCI only exists on PCI-X slots.

Virtually all the consumer level boards with 32 bit PCI slots is 5V only. I checked.

Cheers, pentiumspeed
pentiumspeed
Newbie
 
Posts: 84
Joined: 2017-5-17 @ 23:17

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby appiah4 » 2019-5-23 @ 06:21

I asked because I have one and can test..
A500:Rev6|+512K|ACA500+|C1084S
i386:Am386SX25|4M|GD5402|ES688|MuntPi3
i486:U5S33|8M|GD5428|YMF719|DB-S2
i586:P133|32M|T64+/MX2|V1|CT3980/32M
i686:K6-2/400|128M|V2/SLI|CT4520/32M
S370:P3-1200|384M|GF4-4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 4039
Joined: 2017-2-19 @ 07:36

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby Logistics » 2019-5-23 @ 06:28

No, 430HX is a PCI 2.0 board, the introduction of 3.3V PCI. But you have a PCI 2.2 card. Not sure why the card is unhappy,
User avatar
Logistics
Oldbie
 
Posts: 519
Joined: 2013-2-06 @ 06:37
Location: San Jose, CA

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby appiah4 » 2019-5-23 @ 06:42

Logistics wrote:No, 430HX is a PCI 2.0 board, the introduction of 3.3V PCI. But you have a PCI 2.2 card. Not sure why the card is unhappy,


Probably needs PCI 66MHz which came with PCI 2.1 that the HX board lacks.
Last edited by appiah4 on 2019-5-23 @ 16:18, edited 1 time in total.
A500:Rev6|+512K|ACA500+|C1084S
i386:Am386SX25|4M|GD5402|ES688|MuntPi3
i486:U5S33|8M|GD5428|YMF719|DB-S2
i586:P133|32M|T64+/MX2|V1|CT3980/32M
i686:K6-2/400|128M|V2/SLI|CT4520/32M
S370:P3-1200|384M|GF4-4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 4039
Joined: 2017-2-19 @ 07:36

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby havli » 2019-5-23 @ 15:36

Is there even such a thing as 66MHz-only PCI card? As far as I know PCI always works at 33 MHz and some cards support 66 MHz so they can utilize faster bus communication... but don't require it.
HW museum.cz - my collection of PC hardware
User avatar
havli
Oldbie
 
Posts: 799
Joined: 2014-11-07 @ 16:51
Location: Czech Republic

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby appiah4 » 2019-5-23 @ 16:17

havli wrote:Is there even such a thing as 66MHz-only PCI card? As far as I know PCI always works at 33 MHz and some cards support 66 MHz so they can utilize faster bus communication... but don't require it.


Never came across one myself but the card is a Dell OEM so it may have weird BIOS quirks. No idea..
A500:Rev6|+512K|ACA500+|C1084S
i386:Am386SX25|4M|GD5402|ES688|MuntPi3
i486:U5S33|8M|GD5428|YMF719|DB-S2
i586:P133|32M|T64+/MX2|V1|CT3980/32M
i686:K6-2/400|128M|V2/SLI|CT4520/32M
S370:P3-1200|384M|GF4-4200|MX300
S754:A3700+|2G|X1950PRO|SB0350
User avatar
appiah4
l33t
 
Posts: 4039
Joined: 2017-2-19 @ 07:36

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby pentiumspeed » 2019-5-23 @ 19:26

Need to clarify with any one, if you study the PCI and PCI-X slots, there is a difference. I had been looking at boards on ebay and google images for years.

Majority of PCI is 5V, The majority of PCI-X is 3.3V, Despite what the wiki says for PCI and PCI-X lists all the possible voltage combinations.

430HX is PCI 2.1 like mine is made by Micronics and means the bios is limited and not as compatible as Asus's bios for example would been. I have only one pentium class board at this moment so cannot confirm either video card or bios issue. These days obtaining another different pentium board is expensive and I preferred ATX format for ease of using typical cases and I already have obtained early ATX power supply with -5V for the ISA. This means waiting longer time for good deal and one I wanted to have in ATX with pentium much harder to find.

I did test both classic and mmx pentium with 2.8V VRM module, processors in this micronics both can detect either and I already updated the bios version. Certain PCI video card issue like I posted in first place in addition to POST screen; I set jumpers correctly to 3x for Pentium shows 200MHz and Pentium MMX set to 1.5X should display 233MHz, actual display says 200MHz, MMX. I was testing and have not yet assembled in order to boot dos in order to do some more tests to confirm that mmx processor is correct, running 3.5X mode at 233 with a diagnostic program. Not yet with this.

P55C spec designed into the motherboard's voltage supplies is usually found on many boards that sport a VRM module socket even the board does not say it is P55C bios compatible.
How I know this? I do still have a mobile pentium 90MHz tape package with 2.9V in a PPGA adapter PCB which requires P55C voltage planes motherboards to work correctly.

Cheers, Pentiumspeed
pentiumspeed
Newbie
 
Posts: 84
Joined: 2017-5-17 @ 23:17

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby TheMobRules » 2019-5-23 @ 19:51

I don't know if this is of any help, but I have a Micronics D5CUB (also a 430HX board) and it is VERY finicky about what PCI video cards work on it.

In general, S3 cards work fine, but with several common cards from that era, such as a Matrox Millennium II PCI, which work perfectly on pretty much any other board, it refuses to even boot: no beeps or errors, just a black screen. No idea about the reason for these incompatibilities though.
TheMobRules
Member
 
Posts: 478
Joined: 2016-1-19 @ 23:29

Re: PCI Dell TNT2 card not working on 430HX board but works in any other boards.

Postby Windows9566 » 2019-5-26 @ 04:32

do Cirrus logic cards work on the D5-CUB?
1995-Advanced/ML,P100,32MB-RAM,CL-GD5446,CT1740,WFWG-3.11/DOS-6.22
1996-VX97,P133,32MB-RAM,TRIO-64V+,CT1740,Win95-OSR2.1
2009-M2N68-AM-Plus,Athlon-64-X2-5600+,2GB-RAM,GTS-450,WinXP-Pro
2017-ROG-B450F,R5-1600,16GB-RAM,GTX-1060,Win10-Home
User avatar
Windows9566
Member
 
Posts: 252
Joined: 2015-4-30 @ 14:55


Return to Video

Who is online

Users browsing this forum: Big Pink and 3 guests