I got a Dell 486 - my ultimate 486 build log!

Showcase your Retro PC / Build logs.

I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-8-30 @ 23:42

I'm actually very excited about this machine. Now I finally get to live up to my username.

I was poking around at the recycle center looking for parts for my various Thinkpads and my foray into actually building a modern desktop (more on that later) -- when I came across this Dell 466/M. The characteristic Made in USA sticker caught my eye, and then I noticed the triple-stacked drives, and I knew I needed it.

That was even before I realized that it had an original Sound Blaster 16 1740 in it, a "holy grail" item for me as I have never found one before in the wild like this.

It doesn't have a HDD as the recycle center requires that all drives be removed and the data on them destroyed - and they didn't have the capability to wipe IDE drives any more. Doh! Kind of sad as it was a nice 340 meg drive, but that's OK.

There is VGA video out on the motherboard. I assume it is some kind of SVGA chip but we will see. There is also the SB16, and an Ethernet card which I may or may not replace with something else. I suspect the CPU is a DX2/66. But if it isn't, that can be remedied :evil:

Hot diggity dog! Now it's time to get working!

Here's a quick photo of it before I set to work:

IMG_7779 small.JPG


Benchmarks from PC Mag :wink: https://books.google.com/books?id=5KSmA ... &q&f=false

Original advertisement: https://books.google.com/books?id=23Xxb ... ag&f=false
They seem to be very proud of the video chip on the motherboard. I don't even know what it is yet; stay tuned to find out!
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby xjas » 2019-8-30 @ 23:45

Nice find, love that caddy-load CD-ROM drive with the MPC logo. You're lucky you got a caddy along with it as those are pretty hard to find. I think that drive was offered along with the SB16 as a Creative "Multimedia kit."
User avatar
xjas
l33t
 
Posts: 2138
Joined: 2015-9-07 @ 02:29

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Intel486dx33 » 2019-8-31 @ 00:53

That Sound Blaster 16 1740 has a propriety Panasonic interface. So that CDROM is most likely Matshusta. I have one in my IBM PS/1
You have to use the CDMKE.SYS driver with this sound card.
You need the Sound Blaster 16 drivers too.

Autoexec.bat
MSCDEX.EXE /S /D:MSCD01 /V /M:15

Config.sys
DEVICE=CDMKE.SYS /D:MSCD01 /SBP:220

See my post:
viewtopic.php?f=46&t=68567&hilit=1740
Last edited by Intel486dx33 on 2019-8-31 @ 17:53, edited 1 time in total.
Intel486dx33
l33t
 
Posts: 2052
Joined: 2018-5-17 @ 01:17
Location: U.S.A.

Re: I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-8-31 @ 17:40

xjas wrote:Nice find, love that caddy-load CD-ROM drive with the MPC logo. You're lucky you got a caddy along with it as those are pretty hard to find. I think that drive was offered along with the SB16 as a Creative "Multimedia kit."

Yeah, that's what I figured! I was pretty happy about that.
Intel486dx33 wrote:You have to use the CDMKE.SYS driver with this sound card.

Thank you! I didn't know that! Yeah, I tried VIDE-CDD.SYS and it didn't work.

Last night I opened it up, cleaned everything, reseated cables, etc. and then put a hard drive in it in order to try it out.

On first boot the 3.5 inch floppy drive made some horrible noises and the machine refused to boot from it. However, setting the hard drive settings to type 41 let it boot from that (it has EZ-DRIVE on it so I can access all 16 gigs of the DOS partition on it). I had some fun playing around with it to see what it can do. This drive already had a bunch of generic DOS stuff on it from a previous project, and only required some tweaking of CONFIG.SYS and AUTOEXEC.BAT to make it work fine with the Dell!

One annoyance is that the CPU has a heatsink stuck to it. I am really not sure how to get it off. I want to know what this socket is; there is an extra set of pins around the CPU and advertisements claimed this machine could be "upgraded with Pentium technology."

The machine opened up before cleaning
2.JPG


The cards that were in the unit
3.JPG

4.JPG


What is this? It goes in a slot behind the CPU. Cache?
5.JPG


Holy crap, it's old enough to still have a "PC's Limited" sticker on it! Cool!
6.JPG
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-8-31 @ 17:45

Looking snazzy on the newly christened Retro Corner of my desk.
7.JPG


This was in the CD caddy when I opened it for the first time!
8.JPG


Doing some retro DOS web browsing with Links
10.JPG

11.JPG
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-8-31 @ 17:54

A valiant attempt
12.JPG


Keen didn't make it =(
(these screenshots were brought to you by the B, A, and T keys on my keyboard)
13.JPG


Some MSD stats!
14.JPG

15.JPG



As I suspected, the machine is indeed a 486 DX2/66.

Specs currently:
  • Intel 486DX2/66 (cache? Not sure)
  • 16 MB of RAM (may replace. I was getting some weird issues with Keen dropping sprites that I've never seen before, and random corrupted lines here and there in Wolfenstein 3D)
  • 250 GB HDD (might need more space, dunno if that's enough for a 486! Maybe I should put a 1 TB drive in there) -- really though there is just a 16 GB partition on it that I am running DOS from.
  • Some S3 onboard video card -- seems to be compatible with everything I've tried
  • Sound Blaster 16 CT1740 -- works great! A little noisy in games but running MPXPLAY it sounds amazing.
  • 3Com 3C509 ethernet card

All in all this is a great system to play around with! Stay tuned here for more projects and upgrades I may do with it!
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Intel486dx33 » 2019-8-31 @ 18:01

If that CDROM is NOT reading correctly you can always open up the CDROM drive and clean the lens with some CDROM lens cleaner and a soft cloth.
That's what I do with all my old CDROM drives. It's easy once you get the hang of it.

Here is how I got the 3com 3c509 NIC working in DOS with packet driver and mTCP package.
viewtopic.php?f=46&t=67721&hilit=3c509+3com+3com+3c509&start=20#p767055
Intel486dx33
l33t
 
Posts: 2052
Joined: 2018-5-17 @ 01:17
Location: U.S.A.

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Anonymous Coward » 2019-9-01 @ 13:08

Although at the time I really didn't like the 1X and 2X drives (they were slow even when new), these days I really appreciate the bezel design on this one.

I really like these old Dells too. In my opinion, Dell wasn't as cool after they ditched the grey face plates. Too bad the CD-ROM drive doesn't match.
Will the highways on the internets become more few?
V'Ger XT|Upgraded AT|Ultimate 386|Super VL/EISA 486|SMP VL/EISA Pentium
User avatar
Anonymous Coward
l33t
 
Posts: 3293
Joined: 2008-3-20 @ 05:37
Location: Shandong, China

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Caluser2000 » 2019-9-02 @ 07:42

If you've only got the caddy that came with the CD drive it is a pain. Best to have three of four laying about. Nice system all the same.
User avatar
Caluser2000
Oldbie
 
Posts: 1242
Joined: 2014-10-21 @ 05:34

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Zack_H » 2019-9-02 @ 12:25

Excellent find! I'd love to get a 486 dell someday. The oldest I currently have is a Dimension XPS P90 (Penitum 90MHz) desktop, which uses a similar case to this 486.
Starting Windows 95. . .
User avatar
Zack_H
Newbie
 
Posts: 40
Joined: 2019-2-22 @ 14:40
Location: USA

Re: I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-9-03 @ 06:19

I am attempting to get the CD drive working. So far after having loaded the drivers successfully, it will not spin up the disk. I will be checking cables tomorrow.
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Zack_H » 2019-9-03 @ 09:35

A lot of those early CD drives have SMD electrolytic capacitors in them that start leaking with age. That could very well be your problem here.
Starting Windows 95. . .
User avatar
Zack_H
Newbie
 
Posts: 40
Joined: 2019-2-22 @ 14:40
Location: USA

Re: I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-9-03 @ 18:21

Zack_H wrote:A lot of those early CD drives have SMD electrolytic capacitors in them that start leaking with age. That could very well be your problem here.

I'll look into that!

The video card is a VLB S3 86C805, built into the motherboard. I suspect it has hardly any RAM, though. It will do a max of 1024x768 with 256 colors in Windows 3.1, and no matter what I do I can't get it to go beyond 256 colors.
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Intel486dx33 » 2019-9-04 @ 01:45

keenmaster486 wrote:I am attempting to get the CD drive working. So far after having loaded the drivers successfully, it will not spin up the disk. I will be checking cables tomorrow.


I ran into this problem too.
Make sure you have the cable hooked up correctly.
I think the red stripe on the ribbon cable goes on the right side of the IDE connector.
Attachments
soundblaster_16_asp_ct1740 (1).jpg
07fig05_alt.jpg
Intel486dx33
l33t
 
Posts: 2052
Joined: 2018-5-17 @ 01:17
Location: U.S.A.

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Anonymous Coward » 2019-9-04 @ 23:51

Another problem with old CD-ROM drives is that the grease in between the gears gets all dry and turns to powder, though it's usually specific to the eject mechanism.
Will the highways on the internets become more few?
V'Ger XT|Upgraded AT|Ultimate 386|Super VL/EISA 486|SMP VL/EISA Pentium
User avatar
Anonymous Coward
l33t
 
Posts: 3293
Joined: 2008-3-20 @ 05:37
Location: Shandong, China

Re: I got a Dell 486 - my ultimate 486 build log!

Postby oeuvre » 2019-9-07 @ 13:17

maybe it has ejectile dysfunction
HP Z420 Workstation Intel Xeon E5-1620, 32GB, AMD FirePro V7900 2GB, SSD + HD, XP/7
Main Desktop Intel 6700, 32GB, AMD RX580 8GB, NVMe SSD + HD, 10
Image
User avatar
oeuvre
l33t
 
Posts: 3064
Joined: 2015-3-31 @ 13:31
Location: USA

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Windows9566 » 2019-9-07 @ 19:51

oeuvre wrote:maybe it has ejectile dysfunction


my Windows XP PC's DVD drive has ejectile dysfunction but it still reads and even burns discs. just have to have a paperclip at hand when i want to swap discs.
1995-Advanced/ML,P100,32MB-RAM,CL-GD5446,CT1740,WFWG-3.11/DOS-6.22
1996-VX97,P133,32MB-RAM,TRIO-64V+,CT1740,Win95-OSR2.1
2009-M2N68-AM-Plus,Athlon-64-X2-5600+,2GB-RAM,GTS-450,WinXP-Pro
2017-ROG-B450F,R5-1600,16GB-RAM,GTX-1060,Win10-Home
User avatar
Windows9566
Member
 
Posts: 253
Joined: 2015-4-30 @ 14:55

Re: I got a Dell 486 - my ultimate 486 build log!

Postby JonathonWyble » 2019-9-07 @ 23:35

Windows9566 wrote:
oeuvre wrote:maybe it has ejectile dysfunction


my Windows XP PC's DVD drive has ejectile dysfunction but it still reads and even burns discs. just have to have a paperclip at hand when i want to swap discs.

A paperclip? How would something like that help with burning a disc? I didn't know that was something people can do...
JonathonWyble
Member
 
Posts: 181
Joined: 2019-1-13 @ 02:10
Location: Buffalo, New York

Re: I got a Dell 486 - my ultimate 486 build log!

Postby keenmaster486 » 2019-9-07 @ 23:52

JonathonWyble wrote:A paperclip? How would something like that help with burning a disc? I didn't know that was something people can do...

Clearly you've never gotten a CD stuck in a drive before.

I reseated the cable on the CD drive and now it spins up the disk and attempts to read it, but it cannot read; just sits there making those characteristic squeaky CD drive noises forever and ever.
I flermmed the plootash just like you asked.

http://classictechnology.herokuapp.com
http://keenmaster486.github.io
IBM Thinkpad 600E, 560X, 365CD
User avatar
keenmaster486
Oldbie
 
Posts: 1809
Joined: 2016-2-16 @ 02:04
Location: Atroxus

Re: I got a Dell 486 - my ultimate 486 build log!

Postby Windows9566 » 2019-9-08 @ 01:51

keenmaster486 wrote:
JonathonWyble wrote:A paperclip? How would something like that help with burning a disc? I didn't know that was something people can do...

Clearly you've never gotten a CD stuck in a drive before.

I reseated the cable on the CD drive and now it spins up the disk and attempts to read it, but it cannot read; just sits there making those characteristic squeaky CD drive noises forever and ever.


you need to put in a disc before you burn it. and you also need to open the drive to put the disc in, unless it's one of those slot loading drives. you know those eject holes in every tray loader CD drive if the tray is being stubborn, just get a paperclip and push it in there.
1995-Advanced/ML,P100,32MB-RAM,CL-GD5446,CT1740,WFWG-3.11/DOS-6.22
1996-VX97,P133,32MB-RAM,TRIO-64V+,CT1740,Win95-OSR2.1
2009-M2N68-AM-Plus,Athlon-64-X2-5600+,2GB-RAM,GTS-450,WinXP-Pro
2017-ROG-B450F,R5-1600,16GB-RAM,GTX-1060,Win10-Home
User avatar
Windows9566
Member
 
Posts: 253
Joined: 2015-4-30 @ 14:55

Next

Return to System Specs

Who is online

Users browsing this forum: No registered users and 1 guest