First post, by lemonlime

User metadata
Rank Newbie

Hi All,

I picked up a cheap ‘untested, as-is' CT6670 8MB Voodoo 2 on eBay from a local seller recently. I could see a few issues in the eBay listing, but the damage was more extensive when I received it and did a more thorough inspection.

Top/bottom images before replacing components:

Missing surface mount components:
C9 broken off (rear, near SLI connector, 3.3-4.7uF, minimum 6.3V, 1206 cap)
C48 broken off (front, bottom right corner, 1nF 25V 0603 cap)
C128 broken off (rear, near 500-0010-01 chip, 100nf 25V)
C81 broken off (rear, near 500-0010-01 chip, 1nF 25V 0603 cap)
C108 broken off (rear, near 500-0010-01 chip, 1nF 25V 0603 cap)

Other damage:
Some bent pins on the 3dfx component chips.
Bent PCI bracket near VGA output and trace damage.

I tested it initially after straightening out all of the bent component chip legs (took a long time with a magnifying glass and razor) and making sure nothing was shorting out. I got no video signal at all (passthrough or otherwise), but the card was detected successfully in Windows 98SE and the drivers installed without an issue. Trying to go to the Voodoo2 control panel would cause the system to hang immediately.

After testing with a multimeter, I found two of the traces didn’t have continuity near the VGA output. I soldered a couple temporary jumper wires to test, and that fixed the VGA output issue. I got passthrough video working successfully, but the system would hang whenever going to the Voodoo 2 control panel or launching a glide game.

With the help of sdz in Voodoo 2 component map , I identified all the missing surface mount components and soldered them back on. Some of the capacitors were tiny, but I was very careful to ensure there was good pad contact. I also spent a lot of time very carefully inspecting all the component chip legs with a magnifying glass and razor blade. I was really hoping this would have done the trick, but I’m still seeing the same behavior.

I tried to launch MOJO.EXE in a real DOS 6.22 environment, but it would constantly hang the system shortly after launching. I redirected the debugging output to console and see the following:


Here are numerous high-resolution photos of the component repairs, trace damage etc.

Trace damage before/after repair:

Component repairs:

Any ideas why the card keeps hanging during initialization? Think there is any hope of reviving this card?


Reply 1 of 4, by lemonlime

User metadata
Rank Newbie

I checked and rechecked all of the legs on the component chips without any luck. I found a few other spots on the front of the card with minor trace damage where copper was exposed, but continuity checks out okay with a multimeter. I think whatever is wrong with this card isn't visible on the outside, unfortunately. I've put it away for now as its been driving me nuts 😀

If anyone has any ideas or suggestions, would love to hear them.

Reply 2 of 4, by Vaudane

User metadata
Rank Member

Couple of things strike me from the damage you've detailed. The smd caps having pulled off is a strange one. Says to be either something has hit the board, or the board has been bent at some point.

The fix isn't easy, nor guaranteed to be long lasting. First of all, you may have to recap all the small ceramics around that area as some may be invisibly damaged.

Secondly, the board may have started to delaminate in points. A controlled reflow may reconnect the vias allowing the signal back through. I know that'd be a right pig to test but you'd want to check that before you try a reflow.

I don't know how it works but does accessing the 3dfx options use different pins on the voodoo chips than detection alone? If you can isolate what pins are used for that, you could follow the traces to make sure everything is connected from power to display. Hope you have an oscilloscope 😀

Reply 3 of 4, by Justin1091

User metadata
Rank Member

I have a Creative V2 12 mb. If you want me to test something or a photograph of the card let me know! What happens when you launch a game or for example dxdiag -> Direct3D test? What drivers do you use? I know my V2 locks up when used with a P3 800 and old drivers.

Maybe post another round of photographs? Someone might see something you don't. Probably not, but doesn't hurt to try! PCI connection also looks bad, maybe investigate further there? And what about taking the stickers off, might be something broken underneath it (looks like most damage is in that area, the area of the VGA port).

Reply 4 of 4, by lemonlime

User metadata
Rank Newbie

Thanks Vaudane and Justin1091!

Yeah, no oscilloscope here unfortunately. If I had to guess, I'd say it was probably sitting unprotected in a box with a bunch of other stuff and got knocked about repeatedly. Reflowing might be interesting to try, but I'd have to find some way to do that (I doubt a toaster oven could dial in precise enough heat?) My soldering skills are pretty rudamentary so I'm starting to think whatever this card needs is probably beyond my equipment and ability.

I actually did take the stickers off the back of the card, but there doesn't appear to be any damaged traces or components underneath. I tried both the Creative CD drivers as well as the latest V2 reference drivers - same result for both. If I try to launch anything 3D, I get a blank screen and the system just hangs. Even MOJO.EXE in a DOS environment hangs up the system. Trying to go to the Voodoo 2 control panel under display settings also results in a system hang. I also wonder if the previous owner tried to test the card with all of the shorted component legs and fried something internally.

I put the card away for now as it was driving me crazy 😀