First post, by DNSDies

User metadata
Rank Member

Hey all,

I got a 12MB Voodoo 2 card a little while ago, and recently tried to use it, and it's not working. Like, at all. Causes the computer to totally lock up when a 3D application is launched.
So, I did a little research and found out about the debug logging environment variables, and ran Mojo to see if it would generate a debug file.
It doesn't. It generates the text file, but it's empty. The only debugging information I get appears on the screen for a second before the screen goes black, here:


Video passthrough works, and the card APPEARS to be in good shape (a bulk capacitor was dented, but I removed and tested it and it still reads fine and isn't leaky)
My only thoughts are that the DRAM in Bank 0 appears to be corrupt or damaged, so anything attempting to access it causes a crash, or the main chips are damaged in some way that isn't visually apparent.

I have some pictures of the board, it's an STB manufactured 3DFX 12mb Voodoo 2

Which of the memory banks is bank 0, and should I even attempt to replace the DRAM, or is this card totally borked?

Reply 1 of 2, by bloodem

User metadata
Rank Member

What you want is to use the SSTV2* variables: http://www.mdgx.com/3dfx.htm (second table).
Now, the first thing I would look for on the card is to see if there are any shorts on the T-Rex (TMU) / FBI chip pins (can't really tell from the photos you uploaded since the quality is not that great).
Also check for missing/damaged components or bad traces/scratches.
The issue can also be linked to bad VRAM on the primary TMU chip, however debugging this will be much harder, since - to my knowledge - there's no way to force the card to only use the secondary TMU.
And, of course, if you are really unlucky, one or both of the T-Rex chips might be damaged.

2 x Socket 3 / 3 x Socket 7 / 4 x SuperSocket 7 / 4 x Slot 1 / 2 x Slot A / 5 x Socket 370
3 x Socket A / 1 x Socket 478 / 2 x Socket 754 / 3 x Socket 939 / 2 x LGA775 / 1 x LGA1155
Current rig: AM4 - Ryzen 5 3600X
Backup rig: LGA1151 - Core i7 7700k

Reply 2 of 2, by DNSDies

User metadata
Rank Member

I was actually able to run mojo.exe without the computer crashing in a different motherboard:

I updated the environment variables too.
There don't appear to be any legs touching on the FBI/TMU chips, either.

Still no debug file output, but I think it's safe to say the FBI chip is probably dead? Anyone have any advice? Any sources of these chips, or are they only on Voodoo 2?
If I can't fix it, I can still harvest the DRAM chips at least. Those 1MB chips are impossible to find and I can use them to upgrade an 8MB V2.