VOGONS

Common searches


First post, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie

I rediscovered "Lemmings" and would like to play it pixel perfect with DosBox. The original resolution of Lemmings is 320 x 200. With aspect correction to 640 x 480 it means that 20% is added to the height.

What I'd like to get, is pixels of 4 x 5. So a full-screen resolution of (320 x 4) 1280 by (200 x 5) 1000 pixels (with 14 pixel black bands on top and bottom and 320 pixel black bands left and right, since my screen is 1920 x 1280). This way I would almost have the correct 4:3, but in theorie, the pixels all should "translate" into "4 x 5 pixel" on my screen, right? I don't seem to be able to do this, though. I have been playing around with all the settings in the config file, using DosBox ECE r4301 (last one supporting pixel perfect scaling, as far as I know). When specifying a 1280 x 1000 resolution, I end up with a 1280 x 1000 screen with a 20 pixel black band on top and bottom, leaving the "classic" 1280 x 960 resolution.

Somebody can help me out here? What am I missing? Suggested config file settings are very welcome...

Reply 1 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie
TomVDJ wrote on 2021-01-13, 14:32:

I rediscovered "Lemmings" and would like to play it pixel perfect with DosBox. The original resolution of Lemmings is 320 x 200. With aspect correction to 640 x 480 it means that 20% is added to the height.

What I'd like to get, is pixels of 4 x 5.

Ideal aspect correction would be not 4x5 but 5x6 (if your display permits it).

So a full-screen resolution of (320 x 4) 1280 by (200 x 5) 1000 pixels (with 14 pixel black bands on top and bottom and 320 pixel black bands left and right, since my screen is 1920 x 1280). This way I would almost have the correct 4:3, but in theorie, the pixels all should "translate" into "4 x 5 pixel" on my screen, right?

Right.

I don't seem to be able to do this, though.

In the original plain-vanilla DOSBox, try in windowed mode:

windowresolution = 1280x1000
fullscreen = false
output = openglnb
scaler = none
aspect = false

I have been playing around with all the settings in the config file, using DosBox ECE r4301 (last one supporting pixel perfect scaling, as far as I know). When specifying a 1280 x 1000 resolution, I end up with a 1280 x 1000 screen with a 20 pixel black band on top and bottom, leaving the "classic" 1280 x 960 resolution.

You never have to specify a resolution for pixel-perfect mode. Try in ECE:

fullresolution = desktop
fullscreen = true
output = openglpp
aspect = true

If you still fail to make it work, show me your config and provide a link to your version of ECE, so I can test it on my side. As a last resort, I can set up Lemmings in my own version of ECE and the whole setup back to you, and Bob's your uncle (if Windows is your OS).

Reply 4 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie

Oh man, I don't seem to manage. I think I missed some parameter in my config. I now got a small screen with artefacts around it. In attachment my lemmings.conf file (I start it with a bat file that calls dosbox ece with this config file). I've put machine=vgaonly (instead of svga_s3) since this renders the colors as the original.

I use Dosbox ECE r4301 (downloaded from the archive folder on the ECE website). Also use the CD-rom version of lemmings + oh no more lemmings, but that will not make a difference versus the normal floppy disk version, I guess. The CD only adds CD-audio...

Attachments

  • Filename
    Lemmings.conf
    File size
    11.46 KiB
    Downloads
    8 downloads
    File comment
    Config File
    File license
    Public domain

Reply 5 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie
jmarsh wrote on 2021-01-13, 23:23:

Lemmings uses a resolution of 640x350, not 320x200.

Yep, you're right. At least the menu screen and screen with the level explanation are. The actual resolution while playing is 640x400 (so 2 times 320 x 200, I was testing things out with SpaceQuest which actually is 320 x200, hence the confusion).

I guess that could be a problem for the pixel perfect patch, since it can't multiply with a natural number to generate rectangular pixels... Hight can only be multiplied by 2 on my screen (when it would actually have been 320 x 200, it could have been multiplied by 5).

Still curious how to make this work with SpaceQuest (an actual 320 x 200 game) if it would not be possible with Lemmings.

Reply 6 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie
TomVDJ wrote on 2021-01-14, 07:48:

Oh man, I don't seem to manage. I think I missed some parameter in my config. I now got a small screen with artefacts around it. In attachment my lemmings.conf file (I start it with a bat file that calls dosbox ece with this config file). I've put machine=vgaonly (instead of svga_s3) since this renders the colors as the original.

Your config has:

output=surfacenp

instead of

output=openglpp

Why did not you configure it as I recommended?

Reply 7 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie

Ah, damn, yeah, I tried with different output values there, none of them seemed to work. Also not openglpp. Could you just let me know what settings SHOULD work for the [sdl] and [render] section of the config file? If you just cut and paste those two complete sections with the correct settings, it should work over here too, right?

I have looked for a "template" config file for Dosbox ECE with the pixel perfect patch enabled, but didn't find one, so I tried to "interprete" the readme of your patch, but not too well, apparently...

Reply 8 of 28, by BardBun

User metadata
Rank Newbie
Rank
Newbie

output=openglnb
aspect=false

Pixel perfect resolutions are:

Native game resolution: 320x200
Then: 640x400 \ 1280x800 \ 1600x1000 \ 1920x1200 \ 2240x1400 \ 2560x1600 \ 3200x2000 \ 3840x2400

Native game resolution: 320x240 or 640x480
Then: 1280x960 \ 1920x1440 \ 2560x1920 \ 3200x2400 \ 3840x2880

To get it centered in fullscreen mode you gotta adjust the horizontal value.

For example, you have a 1920x1080 FullHD Monitor, your choice would be the 1600x1000 resolution.
In DOSBox you have to enter
fullresolution=1920x1000

Then it will be 1600x1000 in the middle with black bars around.

This works for every resolution, for example 2560x1400 for monitors with 2560x1440.

For 640x480 games on a 2560x1440 monitor you can just leave it at 2560x1440, it'll be centered already, no need to adjust here.

---

Some games also change between resolutions when it comes to the menu and actual ingame resolution.

Reply 9 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie
TomVDJ wrote on 2021-01-14, 10:29:

Ah, damn, yeah, I tried with different output values there, none of them seemed to work. Also not openglpp. Could you just let me know what settings SHOULD work for the [sdl] and [render] section of the config file?

Not until tomorrow evening. In the mean time, post screnshots of DOSBox ECE and its log window with the following settings:

fullresolution = desktop
fullscreen = true
output = openglpp
aspect = true

I have looked for a "template" config file for Dosbox ECE with the pixel perfect patch enabled, but didn't find one.

You can delete the existing config file, and DOSBox will generate a new default one at startup, if launched without any command-line arguments.

Reply 10 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie

BardBun, the problem is not the centering of the image, but the scaling algorithm. I don't think you can always achieve correct integer scaling in full-screen by changing fullresolution. LCD displays must always work at their native resolution for a sharp image.

Reply 11 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie

OK, generated a "blank" config file by DosBox itself and just changed the above settings, and I got the result in attachment.

In the meanwhile I also tried the dosbox version from here: https://github.com/bladeSk/DOSBox-pixel-perfect and I was able to get what I wanted (see other attachment "Pixel Perfect Patch") but only this does not work with "vgaonly". Only works with svga_s3, which results in some colors being off, especially in the screens where the levels are explained (see attachment "colors").

Attachments

  • colors.gif
    Filename
    colors.gif
    File size
    129.33 KiB
    Views
    354 views
    File comment
    Colors
    File license
    Public domain
  • DosBoxECE.gif
    Filename
    DosBoxECE.gif
    File size
    41.77 KiB
    Views
    354 views
    File comment
    Dosbox ECE
    File license
    Public domain
  • DosBoxAndPatch.gif
    Filename
    DosBoxAndPatch.gif
    File size
    101.38 KiB
    Views
    354 views
    File comment
    Pixel Perfect Patch
    File license
    Public domain

Reply 12 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie

Thanks for the screenshots. Your DOSBox ECE does not seem to work correctly in pixel-perfect mode. I will test it on my side. I also asked you to post a screenshot of its log output window. Can you do that?

Reply 13 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie
BardBun wrote on 2021-01-14, 10:53:

Native game resolution: 320x200
Then: 640x400 \ 1280x800 \ 1600x1000 \ 1920x1200 \ 2240x1400 \ 2560x1600 \ 3200x2000 \ 3840x2400

Yeah, but then you will have pixels that are 2x2 or 4x4,... I want to have pixels that are 4 width and 5 heigh, so the aspect ratio is (more or less) correct. See the one attachment in my previous post: all pixels there are 4x5, but I have no clue how to achieve this in DoxBox ECE r4301.

Reply 14 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie
Ant_222 wrote on 2021-01-14, 11:33:

Thanks for the screenshots. Your DOSBox ECE does not seem to work correctly in pixel-perfect mode. I will test it on my side. I also asked you to post a screenshot of its log output window. Can you do that?

I got this in the DosBox window (I guess that's the output window). Seems openglpp is not supported. (stderr.txt and stdout.txt stayed blank)

DOSBox version SVN
Copyright 2002-2019 DOSBox Team, published under GNU GPL.
---
CONFIG: Loading primary settings from config file lemmings.conf
"openglpp" is not a valid value for variable: output.
It might now be reset to the default value: surface
MIDI: Opened device:win32

To be clear: I used the Dosbox ECE version r4301 I found here: https://dosboxece.yesterplay.net/ in the archive folder, since I read here on Vogons it was the last version supporting Pixel Perfect. Maybe that statement was not correct? (Found it here: Re: DOSBox ECE (for Windows & Linux))

Reply 15 of 28, by imi

User metadata
Rank l33t
Rank
l33t
jmarsh wrote on 2021-01-13, 23:23:

Lemmings uses a resolution of 640x350, not 320x200.

only the menus... which has giving me headaches trying to capture it, because my capture card doesn't like switching between these resolutions sometimes ^^

1600x1200 would be the correct pixel perfect scaling resolution, as someone else said, 1280x1000 is 4x5 pixels and not quite 4:3 while 1600x1200 is 5x6 pixels and 4:3

Last edited by imi on 2021-01-14, 13:25. Edited 1 time in total.

Reply 16 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie
imi wrote on 2021-01-14, 12:23:

1600x1200 would be the correct pixel perfect scaling resolution, as someone else said, 1280x1000 is 4x5 pixels and not quite 4:3 while 1600x1200 is 6x5 pixels and 4:3

Yes, indeed, but my monitor is only 1920 x 1080, so I'd be more than happy with 1280 x 1000 (so 4x5 pixels instead of 5x6), and an aspect ratio that's just a tiny bit off. So that I got this result (but then with, if possible, a recent version of DosBox / DosBox ECE and also if possible with vgaonly instead of svga_s3):

Attachments

  • DosBoxAndPatch.gif
    Filename
    DosBoxAndPatch.gif
    File size
    101.38 KiB
    Views
    339 views
    File comment
    goal
    File license
    Public domain

Reply 17 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie
TomVDJ wrote on 2021-01-14, 11:59:

To be clear: I used the Dosbox ECE version r4301 I found here: https://dosboxece.yesterplay.net/ in the archive folder, since I read here on Vogons it was the last version supporting Pixel Perfect. Maybe that statement was not correct? (Found it here: Re: DOSBox ECE (for Windows & Linux))

Very likely so. I recommend that you try ealier versions, where openglpp is available.

Edit: Your question about DOSBox ECE is best asked in that thread rather than here.

Reply 18 of 28, by TomVDJ

User metadata
Rank Newbie
Rank
Newbie

Yep, the version before that works fine (R4296). For space quest it does exactly what I want. For Lemmings however it gives me this result: A screen of 960 x 800 with 4x3 pixels. While the aspect ratio is perfect, I'd prefer to have a 5x4 pixels with an aspect ratio that's slighlty off, but covering a much bigger part of my screen. Is this possible with your patch Ant_222? Is it able to scale with "halfs"?

So width would scale 2 and height 2,5, resulting in the original 640 x 400 becoming 1280 x 1000. The patch mentioned (https://github.com/bladeSk/DOSBox-pixel-perfect) seems to be able to do this, but fails on supporting the vgaonly option... 🙁.

Attachments

  • Image2.gif
    Filename
    Image2.gif
    File size
    75.18 KiB
    Views
    322 views
    File comment
    Screenshot
    File license
    Public domain

Reply 19 of 28, by Ant_222

User metadata
Rank Oldbie
Rank
Oldbie
TomVDJ wrote on 2021-01-14, 13:59:

Yep, the version before that works fine (R4296). For space quest it does exactly what I want. For Lemmings however it gives me this result: A screen of 960 x 800 with 4x3 pixels. While the aspect ratio is perfect,

The ratio is 3:4 (width:height), and it is far from perfect, because it yields an emulated display of 960x800 with an aspect ratio of 6:5 instead of the standard 4:3. In fact, 4:5 pixels are much closer to the ideal for a 320x200 game than 3:4 ones.

I'd prefer to have a 5x4 pixels with an aspect ratio that's slighlty off, but covering a much bigger part of my screen. Is this possible with your patch Ant_222?

Are you running Lemmings and Space Quest with the same config? Screenshots here show that Lemmings use a 320x200 graphical mode. I remember the was a problem with vgaonly which imitated doublescan, causing the input resolution to be perceived as 320x400. Naturally, you cannot upscale 320x400 into 12800x1000 using integer scaling factors. I vaguely remember that I had to use svga_s3 to bypass exactly that problem, you say it spoils the colors. See if you can disable doublescan in DOSBox in any other way.

To answer your question precisely, I need to see the debug output either as stderr.txt or as a separate console window usually created together with the DOSBox main window. Maybe they can help you activate it at the ECE thread.