VOGONS


First post, by antrad

User metadata
Rank Member
Rank
Member

I am trying to play this game with integer/nearest scaling set to 2x, but I get blurry scaling. Screen is set to centered, I also tried using Max ISF, I tried changing the texture filtering, but it didn't help.

Reply 1 of 9, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

Works fine here, though you should set scaling mode to "Centered, keep aspect ratio", just "Centered" leaves it up to your display, which might not always handle the sometimes weird resolutions integer scaling gives.

antrad wrote on 2021-04-07, 16:03:

Max ISF

"Max ISF" isn't a setting for integer scaling, that only value named that is for resolution forcing, to get actual integer scaling you need to right click tabs > show all sections... > GeneralExt.

Other potential problems is the config file not being read properly.

However, as I reported previously, dgVoodoo has some color glitches during palette animations when FMVs end, so it's not an ideal solution. Dege: did you ever look into that?

It should be possible to get integer scaling without problems using either DxWnd or Peixoto's patches. I'm going to say good luck with that (you need an old version of either program, and neither program is user friendly).

Edit: or just use the hode engine rewrite, though it is at a worrying "0.2.9". Or emulate the PSX version.

Reply 2 of 9, by FulValBot

User metadata
Rank Member
Rank
Member

Which resolution uses this game and which is your display?

Try to force the same resolution of that game in dgVoodoo2 too; don't use Max ISF, go to Integer scale factor setting and try to use X:n, Y:n (n = 1 or 2 or 3 or 4 or 5 etc etc; for example in a 1080p display if that resolution it's 640x480 try to set X:2, Y:2 to scale it at 1280x960); "MAX available" is not recommended

I suggest also to disable scaling in your video driver (GPU scaling is required for this)

Reply 3 of 9, by antrad

User metadata
Rank Member
Rank
Member
ZellSF wrote on 2021-04-07, 17:23:

...to get actual integer scaling you need to right click tabs > show all sections... > GeneralExt.

I was using the resolution setting under DirectX. Now it works. Thanks.

Reply 4 of 9, by willow

User metadata
Rank Member
Rank
Member
FulValBot wrote on 2021-04-07, 17:46:

Which resolution uses this game ?

320x200 with 256 colors on PC version. 320x200 with 16,7 millions colors on PS1.
a 640x480 version was planned (called pentium version) but has been cancelled.

Reply 6 of 9, by ZellSF

User metadata
Rank Oldbie
Rank
Oldbie

It actually runs at 640x480, though probably internally pixel doubled from whatever the PSX version was running it. Hence the black bars. I wouldn't say anything certain about the aspect ratio of this (or other multiplatform games).

Reply 7 of 9, by antrad

User metadata
Rank Member
Rank
Member

Man, this game is gruesome. I wish I played it 20 years ago. When I played Limbo back in 2011 I was shocked by all the horrible deaths, but HOD did it more than a decade earlier. This is like Another World on steroids. Animated cutscenes are too childish and really stick out compared to the death filled gameplay.

Reply 8 of 9, by robertmo

User metadata
Rank l33t++
Rank
l33t++
ZellSF wrote on 2021-04-07, 20:11:

It actually runs at 640x480, though probably internally pixel doubled from whatever the PSX version was running it. Hence the black bars. I wouldn't say anything certain about the aspect ratio of this (or other multiplatform games).

4:3
Heart Of Darkness PC vs PS