VOGONS

Common searches


First post, by _wodek_

User metadata
Rank Newbie
Rank
Newbie

Hi All.
I decide to write here, because i didn't find help for my problem nowhere. Only i already read was blood is quite difficoult to run (with VDMSound and 3dfx).

First - i wolud like to tell, that i tried few versions of Blood - 1.00, 1.20, version downloaded from Glidos.net (BloodForGlidos.exe). In all cases i was able to run game with sound and WITHOUT 3d acceleration (Glidos or dgVoodoo). In all cases sound quality was very good - it works great under VDMSound and so under DosBox. I also tried Vesa modes (800x600 - without 3d acceleration from Glidos etc), and also here game worked great.

Problems begun when i tried to run Blood with Glidos - any options i tried, a game worked very very slowly. After i set sound quality to worst possible (8 bits, 8 kHz, 1 channel) and NOFOG=1, NOPALETE=1 options, game was still unplayable even on smaller spaces.. Turning sound emulation OFF didtn't bring solution, so i gass the problem is with Glidos. I have AMD Sempron 2400+, 512 MB Ram, Radeon 9550 128 MB. I don't understand poor Glidos performance with Blood, but runing Tomb Raider 1 under Glidos was great with high quality sound...

After trying Glidos, i tried dgVoodoo (with TR1 dgVoodoo worked quite good). But here i had another problem - look at the attachments - this is view of my screen. What is going on? dgVoodoo worked great with TR1 but here i was not able to set correct configuration (i think i already tried all possible options from dgVoodoo window). Option set BUILD_FPS=1 showed, i have about 30 fps on open spaces (comparing to Glidos it is very very good), but play on the screen like this is impossible!

Does anyone know how to speed-up Blood under Glidos or at least run Blood under dgVoodoo? Thanks for any answer.

Attachments

  • blood_screen.JPG
    Filename
    blood_screen.JPG
    File size
    80.03 KiB
    Views
    3108 views
    File comment
    Blood problem under dgVoodoo.
    File license
    Fair use/fair dealing exception
  • blood_screen2.JPG
    Filename
    blood_screen2.JPG
    File size
    48.54 KiB
    Views
    3108 views
    File comment
    Blood problem under dgVoodoo (2)
    File license
    Fair use/fair dealing exception

Reply 1 of 3, by Glidos

User metadata
Rank l33t
Rank
l33t

Glidos:
There are two things that make Glidos slow with Blood. One is having OpenGL selected in the Glidos "Adjustment" dialog, while you are using the Microsoft supplied drivers for your graphics card. That will make any game run slow (1fps or worse). Downloading drivers from the chip manufacturers or selecting Direct3D will fix that.

The other is not using the "Texture cache for palette tricks" option. This is present only in the latest versions of Glidos. It takes the game from very jerky to silky smooth.

I'd also recommend getting Blood from here. Its preconfigured for running with Glidos.

dgVoodoo
I think I know whtat that problem is too. Blood is ported to 3dfx in an unusual way. The whole screen is rendered using thin, one-pixel thick triangles. Because of this (when running under dgVoodoo) the wrapper's rendering resolution must exactly match that of the game. So if Blood is set to 800x600, so must dgVoodoo. Even then, you will see that textures are smoothed only in one dimension (some vertically, some horizontally). You will see that too on a real 3dfx card.

With Glidos that restriction is lifted. Glidos stitches the little triangles together, so you get smoothing in both directions (bilinear interpolation), and so you can select any display resolution.

Reply 2 of 3, by _wodek_

User metadata
Rank Newbie
Rank
Newbie

First thank you for your answer. Here is what I managed to do:

Newest version of Glidos is in fact very much faster, as you said. Now game is playable with nice sound, but unfortunately it is much slower than raw Blood game without 3dfx, eg. turn around on open space was about 2 fps (for comparation, i run the game from the same directory with blood.exe file instead of 3dfx.exe. I choose Vesa 800x600 mode and game speed was excellent).

I tried both grivers Direct3D and OpenGlide. Direct3D without "Texture cache for palette tricks" option works the worst - less than 1 fps. Direct3D with "Texture cache..." option set works very simillar to OpenGlide driver, but in best case game was quite playable only in small spaces (and monsters go very slowly). So is this maximum, what my computer is able to reach? Maybe change of Video Drivers can help - at the moment I use Catalyst 6.4...

Edit: I already tried Blood from localization You wrote, but there was no difference in performance.

Reply 3 of 3, by Glidos

User metadata
Rank l33t
Rank
l33t

Some progress I guess, but that's very odd. I've had Blood run smoothly on some very old machines.

You could maybe try with Blood configured to use no Audio, just to see if that's what's slowing it down.