VOGONS

Common searches


First post, by TobyFox2002

User metadata
Rank Newbie
Rank
Newbie

Hello I am having difficulty getting dosbox to function because I cant enter anything that requires a shift key. For example If I went to type: mount c c:\dosapps\ I would get mount c c;]dosapps] . I'm not quite sure what to make of this, whether it has something to do with VISTA or if its some other strange effect of trying to get my computer to work with older software...

If anyone could help I'd really appreciate it.

Reply 1 of 14, by ADDiCT

User metadata
Rank Oldbie
Rank
Oldbie

Another post missing vital information. Sigh.

- Which OS are you on? (could be Vista)
- Which locale are you on?
- Which DOSBox version?

We do not have a damn crystall ball. If you want your car repaired, do you just park it at the mechanic's place and tell him "it's not working"?

Reply 2 of 14, by Plan9FOS

User metadata
Rank Newbie
Rank
Newbie

Are you sure it's a Shift Key problem? Or is it just the \ and : keys?

If it's the \ and : keys, please read the DOSBox README.txt file, which is basically the User Guide.

New users please remember: DOSBox README.txt = DOSBox User Guide

Each chapter is short, it doesn't take long to read.
At the very least, read chapters 1 - 6 and 9 - 11.

1. Quickstart
2. FAQ
3. Usage (with Command Line options)
4. Internal Programs
5. Special Keys
6. Mapper
7. Keyboard Layout
8. Serial Multiplayer feature
9. How to run resource-demanding games
10. Troubleshooting
11. The config file
12. The language file
13. Building your own version of DOSBox
14. Special thanks
15. Contact

Reading Chapter 2. FAQ would reveal the following:

"Q: I can't type \ or : in DOSBox.
A: This is a known problem. It only occurs if your keyboard layout isn't US.
Some possible fixes:
1. Switch the keyboard layout of your operating system.
2. Use / instead.
3. Open dosbox.conf and change usescancodes=false to usescancodes=true.
4. Add the commands you want to execute to the "configfile".
5. Change the DOS keyboard layout (see Section 7 Keyboard Layout).
6. Use ALT-58 for : and ALT-92 for \.
7. for \ try the keys around "enter". For ":" try shift and the keys
between "enter" and "l" (US keyboard layout).
8. Try keyb.com from FreeDOS (http://projects.freedos.net/keyb/).
Look for keyb2.0 pre4 as older and newer versions are known to
have a bug in the loader routines."

Hope that helps.

Reply 3 of 14, by Steve_bhs

User metadata
Rank Newbie
Rank
Newbie

I`ve been interested in this subject and similar, try finding the posts `Permanent fullscreen mode` in DOSBox General forum and `keyboard problem in frontier ellite II` in DOSBox games/apps forum. I think you might find some or all of your answers.

Reply 4 of 14, by jal

User metadata
Rank Oldbie
Rank
Oldbie
ADDiCT wrote:
Another post missing vital information. Sigh. […]
Show full quote

Another post missing vital information. Sigh.

- Which OS are you on? (could be Vista)
- Which locale are you on?
- Which DOSBox version?

We do not have a damn crystall ball. If you want your car repaired, do you just park it at the mechanic's place and tell him "it's not working"?

He is on Vista, he just said so. Well, unless he's blaming Vista without running it. Blame Vista for everything!

JAL

Reply 5 of 14, by onofrivs

User metadata
Rank Newbie
Rank
Newbie

All right, I know it's on FAQ and there are couple of workaround solutions, but not one that is working in my case. What I am talking about here is Frontier: Elite 2 on Mac OS X. It's a known issue that in this game you use right shift for decelerating and there is no way to remap it.

I've tried the implemented mapper, however after trying to bind RS, only left shift was recognized after pressing. So I opened the mapper.txt file to change the mappings manually. The defaults were something like "303" for right and "304" for left shift, so I swapped them, started the game and... not working. Even tried to bind a completely different key, but it seems like the Mac Os itself does not distinguish between the two modifiers, OR DOSBox does not recognize the right one, or both..

Is there no way for the box to recognize right shift on mac? Another one of the greatest games that is running, but it's unplayable... 😀

Reply 7 of 14, by jal

User metadata
Rank Oldbie
Rank
Oldbie
onofrivs wrote:

but it seems like the Mac Os itself does not distinguish between the two modifiers

Maybe OS X does, but the SDL implementation doesn't - although admittedly, Googling for this doesn't show anything relevant.

Qbix wrote:

HP Keyboard ?

On a Mac?

JAL

Reply 8 of 14, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Yes os x doesn't differ between right/left neither for shift, ctrl or alt(option) (I think both sides are shown as left keys).
But no idea whether this is an osx or sdl on osx issue!

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for OS X (10.4-10.14 ppc/intel 32/64bit) codesigned for gatekeeper
DOSBox SVN with SDL2 snapshot for OS X (10.7-10.14 intel 64bit) codesigned for gatekeeper

Reply 10 of 14, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Yes, you are right. Onofrivs, you will just have to accept that you can't use the shift keys for a different function, you will have to map the right shift key to some other key to get the game correctly working.

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for OS X (10.4-10.14 ppc/intel 32/64bit) codesigned for gatekeeper
DOSBox SVN with SDL2 snapshot for OS X (10.7-10.14 intel 64bit) codesigned for gatekeeper

Reply 11 of 14, by onofrivs

User metadata
Rank Newbie
Rank
Newbie

No HP keyboard, I am using iBook G4, DosBox 0.74 and actually that is the problem - no matter what key I bind to right shift, it doesn't work...
But I tell you something, after 3 days I've tried this one thing, to bind 304 (left shift from mapper.txt) to another key and voila! It works! I really don't understand but it seems like the left shift in mapper.txt is actually right shift, probably this applies to mac only... This is really strange as it looks like left shift is not working when bound to left shift.
Though as looking at the file now, it seems logical as the sequence goes: semicolon, quote, backslash, LSHIFT, lessthan, z, x... where actually you have right shift next to backslash... right shift goes after slash and befote left ctrl so this seems to be problem!

Just FYI: I also tried the Amiga version thru an emulator when desperate and it was exactly the same (but it's got no option to remap the keyboard), so it's clearly a mac-related issue. But unlike DOSBox, you cannot map keys in UAE and I couldn't find anything about remapping keyboards directly in mac os.

Reply 12 of 14, by onofrivs

User metadata
Rank Newbie
Rank
Newbie

actually what i am saying here is not exactly right (the sequence of the keys), sorry it must be these pints'o'weissbier... 😜
but the fact remains that although you decelerate with right shift in elite2, i've had to bind the left shift key to another key than left shift to get the decelerator working. hope that helps..

Reply 13 of 14, by jal

User metadata
Rank Oldbie
Rank
Oldbie
onofrivs wrote:

i've had to bind the left shift key to another key than left shift to get the decelerator working. hope that helps..

That makes sense: if SDL on Mac doesn't differentiate between right and left shift, you had the "single" shift key mapped twice. So you had the DOSBox left shift mapped to the Mac left/right shift, and tried to map the DOSBox right shift to the same Mac left/right shift. So now that you've mapped the DOSBox left shift to something else, it works. If my theory is right though, you should be able to decelerate with the Mac left shift as well (as for SDL left and right shift seems to be one and the same key).

JAL

Reply 14 of 14, by onofrivs

User metadata
Rank Newbie
Rank
Newbie

actually i am now able to decelerate with RIGHT SHIFT, after i've bound the whatever-key-other-than-it-was to it. 😀 so it seems it is as you say. unfortunately the game keeps crashing occasionaly, but i am able to take a good part of the play.