VOGONS


First post, by P8j6

User metadata
Rank Newbie
Rank
Newbie

I installed CnC GOLD on Windows 98 SE and game freeze on intro.

On first run it freezed on intro video (the blowing skyscraper)
On second run, i disabled intro in INI and then it freezed on animated Westwood logo (also video).

It always freezes in first 1-2 seconds of video and then i must restart computer.

Any ideas whats wrong? Maybe im missing some video codecs?

Last edited by P8j6 on 2019-11-11, 16:23. Edited 2 times in total.

Reply 3 of 10, by Revolter

User metadata
Rank Member
Rank
Member

Westwood used their own format with in-built proprietary Windows-independent codec for C&C and other games of the era:

https://wiki.multimedia.cx/index.php/VQA

You're much better off listing your PC specs and the game package details (which version: the original one, the First Decade one or the free one from EA, and whether you patched it after installation) for any chance of troubleshooting.

I'd suggest the following: in the game folder of the original Win95 version, there is a "setup.exe" (or similarly named) video settings configuration file - run it and try switching the options there ("Back buffer in Video memory" and "Allow hardware filled blits").

I've also experienced problems with C&C95's videos under Windows 2000: even with app compatibility mode set to Windows 95 I've had to hit "space" or "enter" key when any video starts playing to skip some error message. The known "official XP patch" from Westwood in the form of the "THIPX32.DLL" file is supposed to fix that, but it didn't work for me.

Still, what is the exact size and date of your thipx32.dll file (located in the game folder)? There are several different versions of it on the web.

One more thing. On the original 1997 version installation CDs there were a couple of "sneak peaks" (trailers) .VQA files with their own player, so that you could watch the trailers outside of the game. Try running them and see if they play without freezing.

>>AMD Duron 850MHz

Good, but which motherboard (or at least which chipset it uses)? And what soundcard do you use?

Any OS quirks we should know about (KernelEX installed and enabled, for example, an unofficial service pack, or if it is a rare language edition such as Japanese 😀)?

Celeron 800, 512MB, GeForce2 MX, ES1938S/DB S2, 128GB SD, Windows ME/DOS 6.22

Reply 4 of 10, by P8j6

User metadata
Rank Newbie
Rank
Newbie

@Revolter - Thx for reply.

MOBO is: ECS K7VTA3, specs here:
https://www.anandtech.com/show/927/8

Also im using sound card: KOB C884E, Windows lists it as: CMI8738/CDX PCI Audio device

Instalation is from original CD, released around 96/97 in big box. Unpatched, straight from the CD.

thipx32.dll, size is 26KB and timestamp 1996-01-30
In attachmend is screen of all installed files.

Windows doesnt have any quirks, as far as i know. Its stadard english version. 4.10.2222 A
No service packs. How can i determine if KernelEX is installed?

EDIT: I tried SneakPeak videos directly from CD. Video freeze, but when i hit spacebar it returns me to desktop.
When videos freeze in game, then i must restart PC.

Attachments

  • cnc.png
    Filename
    cnc.png
    File size
    35.46 KiB
    Views
    274 views
    File license
    Fair use/fair dealing exception

Reply 5 of 10, by Revolter

User metadata
Rank Member
Rank
Member

P8j6, thanks for the extensive info - now we know at least there's no obvious problems, so we must go even deeper 😀 The issue doesn't seem to be a known one, unfortunately.

Right now my guess is: either it's some problem with the sound, or with your mobo chipset. With VIA-made chipsets, all sorts of problems may occur if one doesn't install the VIA 4-in-1 drivers: at all, the right version, or in the right order:

VIA 4-in-1 driver experiences

"For KT333, KT400, KT600, KT880 and newer use 4.56 under Windows 98 - you should manually install all devices (CPU to AGP bridge, CPU to PCI bridge, etc) - sometimes they don't install correctly."

Which 4-in-1 version do you have? Also, did you have any issues in other Win9x games on this system?

To quickly check if it's a problem with sound<=>chipset combination, try temporarily disabling your soundcard in in the device manager and run the game/sneak peek again. If it doesn't freeze - this will at least point us in the right direction, and if it does - my best guess will be the chipset drivers.

P.S. KernelEx is an unofficial compatibility layer for NT programs, enabling you to run them in your Win9x environment. It's known to break certain native Win9x things if enabled for all programs (its default installation option), but it has to be deliberately installed first, so if you don't use it - it is safe to assume it's not the culprit.

Celeron 800, 512MB, GeForce2 MX, ES1938S/DB S2, 128GB SD, Windows ME/DOS 6.22

Reply 6 of 10, by P8j6

User metadata
Rank Newbie
Rank
Newbie

Ok, we are on right track, looks like it's sound-card problem.

I've disabled sound card in hardware profiles (see attachment).
Then when i've started game it spawned warning "Unable to create Direct Sound Object" and game starts and play videos. Everything OK, but without sound, of course.

About chipset, i'm using this driver: VIA Hyperion 4in1 Driver 4.56v WHQL
So it should be ok.

As for other win9x games, i have installed Warzone 2100 and it runs fine.

Attachments

  • soundcard.png
    Filename
    soundcard.png
    File size
    21.31 KiB
    Views
    229 views
    File license
    Fair use/fair dealing exception

Reply 7 of 10, by Revolter

User metadata
Rank Member
Rank
Member

Cool, that was faster than I expected 😀

Try decreasing the hardware acceleration levels until you hit the one without C&C freezing:

dxdiag_sound (1).png
Filename
dxdiag_sound (1).png
File size
152.04 KiB
Views
219 views
File license
Fair use/fair dealing exception

If this doesn't work - try this "PCI latency patch" for VIA chipsets:

http://www.georgebreese.com/net/software/

Celeron 800, 512MB, GeForce2 MX, ES1938S/DB S2, 128GB SD, Windows ME/DOS 6.22

Reply 8 of 10, by P8j6

User metadata
Rank Newbie
Rank
Newbie

Allright! It works!

I decreased acceleration to level 2 "Basic acceleration" and videos stopped freezing. Perfect!

Thank you Revolter! Without your help i would be still hunting for video codecs.
You are PRO!