VOGONS


First post, by gafland

User metadata
Rank Newbie
Rank
Newbie

I've been searching through the posts here for ways to get Quest for Glory I VGA to work with VDMSound. The solutions posted didn't quite work for me.

P4 1.8 GHz
Windows 2000
VDMSound 2.04
Sound Blaster Audigy

First off, extracted QfG into a folder. I try to run install.exe with VDMSound, it does, but I have no keyboard input. So far I've had run install.exe with DOSBox. I set it up for Sound Blaster for music/speech and to use XMS memory.

Then I install the sb16drv.exe in my QfG folder. I try to run hero.bat/scidhuv.exe with VDMSound but no luck. It sits there with a "Unable to initialize your audio hardware" error message. I've tried changing the Sound Blaster to IRQ 5 and just about every other audio option available.

The game does work with DOSBox but there are some graphics/sound timing issues and changing the CPU cycles doesn't seem to help. I've also tried PITSET but again, the same results.

Does anyone know what the problem seems to be or how I should setup Quest for Glory I with VDMSound?

Reply 1 of 10, by Unregistered

User metadata

UPDATE:

I used command prompt to manually run dosdrv.exe. Then run install.exe and it ran. It says I do not have Sound Blaster for either sound options, but I selected what it said I have. I tried to run the game and tells me I need more memory to run the game.

I'll search for this.

Sorry for a possibly obvious solution that I'm not seeing.

Reply 2 of 10, by collector

User metadata
Rank l33t
Rank
l33t

The "Unable to initialize your audio hardware" error message is a common error with the DOS Sierra SCI games on modern fast machines. You can use one of the updated Sierra Sound Blaster drivers from Sierra's FTP or try the GOSiERRA patch. You can find it on Quest Studios utilities page:

http://www.queststudios.com/quest/Utilities.html

Reply 5 of 10, by Nicht Sehr Gut

User metadata
Rank l33t
Rank
l33t

Originally posted by gafland The game does work with DOSBox but there are some graphics/sound timing issues and changing the CPU cycles doesn't seem to help.

DosBox is presently the best way of running it. What version of DosBox are you running? Are you going fullscreen before starting? If you are running it in a window, is it set to double-sized mode (KEEPSMALL=FALSE)?

What timing/graphics issues are you talking about? (details)

Attachments

  • qfg1vga.png
    Filename
    qfg1vga.png
    File size
    58.18 KiB
    Views
    857 views
    File license
    Fair use/fair dealing exception

Reply 6 of 10, by gafland

User metadata
Rank Newbie
Rank
Newbie

Certain parts in the game, like going up to Erasmus' place, the graphics don't match the sound. The sign begins to pop up out of ground while the soundfx is playing. But the graphic is going faster than the sound, so the sound gets cut off when the graphic is done.

I can lower my CPU cycles until it matches up, though the rest of the game goes much too slowly. It's not something that is hindering my progress, it's simply annoying.

But I'm guessing you're going to tell me there's nothing I can do about it but change the cycles on the fly.

(This also happens very noticably if you choose introduction.)

Reply 7 of 10, by Nicht Sehr Gut

User metadata
Rank l33t
Rank
l33t

Originally posted by gafland Certain parts in the game, like going up to Erasmus' place, the graphics don't match the sound. The sign begins to pop up out of ground while the soundfx is playing. But the graphic is going faster than the sound,

Sounds like your cycles are too low. You CPU is faster than mine, so it should work fine.

#1 Thing. Use DosBox 0.58

If you are using a Beta or a CVS release, it may have additional bugs or speed issues. (Anything that uses 386 real-mode or earlier, I use 0.58)

Start up DosBox, mount the drive/directory, change to the game directory, adjust cycles to the maximum amount while still leaving some CPU time for the actual game (on mine, this is about 9300 cycles), DosBox full-screen (Alt+Enter), start the game.

BTW, if you haven't already put back the AUDBLAST.DRV, do so. (Reinstall the game if needed).

Reply 8 of 10, by gafland

User metadata
Rank Newbie
Rank
Newbie

Faster is what I'm trying to avoid. The more I put the cycles up the more the graphics/sound is off cue. I have to lower it beyond playable for them to match up.

I think you're confusing it. My overall sound is excellent, some scenes though are not. Graphics and sound don't match up, they cut each other off. This is only in a few parts though.

Last edited by gafland on 2003-10-03, 03:18. Edited 1 time in total.

Reply 9 of 10, by Nicht Sehr Gut

User metadata
Rank l33t
Rank
l33t

Originally posted by gafland Faster is what I'm trying to avoid. The more I put the cycles up the more the graphics/sound is off cue. I have to lower it beyond playable for them to match up.

You have to understand something, increasing cycles doesn't mean "go faster" and decreasing cycles doesn't mean "go slower".

"Increasing cycles" means "give more CPU power to DosBox and less to my PC". Too many cycles can cause the same kind of slow-down as too few (this is because you need to leave some CPU time for your "real" PC).

I think you're confusing it. My overall sound is excellent, some scenes though are not. Graphics and sound don't match up,

Trust me, "too much speed" is not a problem in DosBox. On my PC, at it's fastest usable setting, DosBox is equivalent to a 25MHz 386. Hardly too fast.