VOGONS


Daggerfall crashing

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by winotron

User metadata

I played Daggerfall fine for about an hour, went through a couple dungeons and a few towns with no crashing. But all of a sudden it started crashing to desktop when I was in a town. When I load my game now it instantly crashes when I try to move. No error message or anything. I'm tried VDMsound 2.0.4 and 2.1.0 beta and it's the same. I should also mention that I've tried starting another game, and the same thing always happens after about an hour of playing, and always in a town. Any ideas?

Using XP btw.

Reply 3 of 12, by winotron

User metadata

I know no one will ever have a solution to this, but one more thing. I've messed around with it some more, and if I use quick travel to go to another town I can go around that town fine, until the same thing starts happening after a few minutes. Another note: it does the same thing running Daggerfall without VDMsound.

Reply 4 of 12, by samtam90

User metadata
Rank Newbie
Rank
Newbie

Daggerfall is not playable without Dosbox for a simple reason: the invisible bug.

In few words, every time you receive a quest where you must kill monsters in a town, you doesn't see the monsters. This bug also appear when you try to do quests for join the Thieves and the Dark Brotherood. And it could also appear in some dungeons.

So, what do you have to do?

Simply, open the dosbox folder and:
- open dosbox.conf
- go to the [autoexec] line
- cancel and write: mount c: c:\(daggerfall folder)
c:
cd (daggerfall folder)
fall.exe z.cfg (this line is important, if you run dagger.exe, you won't be able to play the game)

Now, you should be able to play Daggerfall without crash (only if your version is the latest), bugs (minor bugs are still present) and other fuck** problems 😀

Have fun! 😉

Reply 5 of 12, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Was testing Daggerfall and .ISO support today. Was able to load a Daggerfall .ISO with imgmount and Daggerfall actually recognized the CD! Unfortunately this method doesn't work for Mechwarrior 2/Mercs but at least we know it works for one game.

So some questions are:

1. Can Mount and Imgmount be combined into one command?
2. What differs in Imgmount that allows Daggerfall to recognize the cd whereas using mount it doesn't recognize the cd?

EDIT - Ignore Daggerfall nonsense. Daggerfall works fine with Mount

Last edited by DosFreak on 2005-02-19, 19:47. Edited 1 time in total.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 6 of 12, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

uhm good to know

they could be combined. Would give an even more complex mount...
was thinking of it myself though

Well lowlevel reading is simpler in a file then crossplatform

(and this iso support is coded by somebody else than the cdrom support. Maybe some little differences somewhere)

I assume you used ioctl support on the real cdrom ?

Water flows down the stream
How to ask questions the smart way!

Reply 7 of 12, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Yep, IOCTL and ASPI tried using mount on Daggerfall and Mech2/Mercs CD's.

So far only the Daggerfall CD loaded with IMGMOUNT allows me to bypass the CD error. Mech2/Mercs still are unable to locate the CD.

Need to look through the rest of my CD dos games and see if I can find any more instances of this behavior.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 8 of 12, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

hmm.

I thought the mecs game was due to missing mscdex calls.

darklands obviously isn't... maybe a side to side compare oneday (shouldn't be that hard)

Imgmount will stay seperate.

I fear users will think that images are required if they are integrated into mount.

Water flows down the stream
How to ask questions the smart way!

Reply 9 of 12, by winotron

User metadata

I haven't run into the invisible bug yet using VDMSound. I've even done the quest to join the thieves guild and have done a couple thieves guild quests. Maybe it's because I have it installed on a FAT32 partition? I saw someone say that could be a problem in another thread before, but I dunno. I tried adding MoSlo to my Daggerfall batch file and running it at 20% and that seems to have fixed the crashing in towns I was getting. I'm still unable to move in water and climbing/levitating is still really glitchy, but I can live with that for now.

Reply 10 of 12, by samtam90

User metadata
Rank Newbie
Rank
Newbie
winotron wrote:

I haven't run into the invisible bug yet using VDMSound. I've even done the quest to join the thieves guild and have done a couple thieves guild quests. Maybe it's because I have it installed on a FAT32 partition? I saw someone say that could be a problem in another thread before, but I dunno. I tried adding MoSlo to my Daggerfall batch file and running it at 20% and that seems to have fixed the crashing in towns I was getting. I'm still unable to move in water and climbing/levitating is still really glitchy, but I can live with that for now.

You haven't the invisible bug probably because you're playing Daggerfall without Windows XP.