Speed problems

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by cleekjc

User metadata
Rank Newbie


I have a lap top with a PIII 1000. I am trying to run Darksun and it works as long as set the speed decrease is no greater than -41, any speed decrease greater than that and the program runs really really slow or locks up.

any Ideas or suggestions


Reply 1 of 5, by vladr

User metadata
Rank Oldbie

You are very likely hitting some sort of threshold. Have you also tried other native DOS slowdown programs like MOSLO? SPEEDSET is good for speeding up timer interrupts but not necessarily the best (i.e. smoothest) at lowing things down.

Reply 3 of 5, by fiatgtn

User metadata
Rank Newbie


I use the Abandon loader 0.8b, and vdmsound-2.0.4.
I have Windows Xp, P4 1700mhz, 256mb ddr.
I play many games on this config but:
Alien Breed 2: Tower Assault
Death Rally
Micro Machines 2
Pac in time
Lost Vikings
Runs slowly, in abandon loader, in the options/preferences i have the slowdown tweak at 0, and on the CPU slow down i put 0%. And all these games run slow. I can´t put it at normal speed. 🙁

Helppppppppp .....

Reply 4 of 5, by yomismobis

User metadata
Rank Newbie

hi there, here a man that uses win32 dosbox for x.com: apocalypse, darksun, worms and others without problems 😁 i love your work men/women

i´m now trying to increase the speed of the games in the dosbox s60 v0.73 with the 0.7 virtualkeyboard runnin yet, on my nokia x6 with cfw "universo simbyan extreme x6 v21"
i can run worms and darksun, it taked a little work, but it´s ok, but they´re run very slow:
-i tryed increassing "cycles", from "auto" (default in the cfg i dled first) to 1600, 3200, 10000 but don´t apreciate changes, it´s on 1600 now, better than auto to launch the games, but doesn´t increase speed inside game
-i tryed with more "memsize", for worms with 4 can be runned, i tryed 8, 16, but nothing better
-i tryed changing core=normal from simple and nothing better :\
-in the case of worms, i tryed to change the dos/4gw.exe for the dos32a.exe (is there a "slim" ver for s60 dosbox?) it worked as if didn´t changed nothing

¿anyidea? Thx 😁