First post, by salil

User metadata
Rank Newbie

I setup Dark forces correctly, and got the game working perfeclty in windows 2000, with sound and music. problem is the music is a bit too slow. I tried speedset. First of all, when i use the launcher and go into DOS environment, i put

speedset.exe 5

into the autoexec. no matter what i do it will not run what is in autoexec. it still runs the slow speed as before.

I then made a bat file and put the same values in, and then setup the launcher to use the bat file. I get this:

SPEEDSET is now resident on IRQ 6.

DOS/4GW Protected Mode Run-time Version 1.95
Copyright (c) Rational Systems, Inc. 1990-1993
Dark Forces Version: 1.0 (Build 1)
...DOS/4GW error (2002): transfer stack overflow on interrupt 0Eh at C7:000012AC

TSF32: prev_tsf32 322C
SS 26F DS 26F ES 26F FS 0 GS 317
EAX 333C EBX 26F ECX 0 EDX 21
CS:IP C7:000012AC ID 0E COD 0 FLG 100002
CS= C7, USE16, byte granular, limit 38B0, base 110800, acc FB
SS= 26F, USE16, byte granular, limit 7CFF, base 2ACF180, acc F3
DS= 26F, USE16, byte granular, limit 7CFF, base 2ACF180, acc F3
ES= 26F, USE16, byte granular, limit 7CFF, base 2ACF180, acc F3
FS= 0, USE16, byte granular, limit 0, base 2ACF180, acc 0
GS= 317, USE32, page granular, limit 7FFEFFFF, base 0, acc C7F3
CR0: unavailable

i then decided to mess around with speedset some more and with dark forces itself, i found out that if i ignore the error and run dark.exe again the game will run... so i changed my bat file to show this:

speedset.exe 5

now the game runs, once with that annoying crash tho... unfortunatley there is no sound, only music... at least im closer this time.

i then go back to dos, and i started looking at the error message itself, the only thing that made some sense to me was the word interrup. i then decided to chage the interrupt in dark forces from the default 7 to 5. i also changed the value in vdmsound and tried running. now i get sound effects and music. unfortunatley, the nagging interupt error is still there, but at least the game is playable and hasnt crashed for 2 hours of play... hope this long post at 5 in the morning helps some people... i guess the interrupt error is for you guys instead 😀