VOGONS


Doom 'MBF' for DOS, Maintenance release 2.04

Topic actions

Reply 160 of 193, by 1541

User metadata
Rank Newbie
Rank
Newbie

Will MBF work with Romero's SI6IL MOD/WAD?
https://www.romerogames.ie/si6il

Windows 98 SE inofficial Service Pack & NUSB (German)
Windows 9x device drivers and tools (German)

Reply 162 of 193, by Sakitoshi

User metadata
Rank Newbie
Rank
Newbie

Hi!
Just for the heck of it I ported some changes made to Libretro-PrBoom to MBF to properly support Sigil and it works like a charm (at least on dosbox).

https://github.com/Sakitoshi/mbf_sigil/releases

Last edited by Sakitoshi on 2019-06-08, 06:28. Edited 1 time in total.

Reply 164 of 193, by Sakitoshi

User metadata
Rank Newbie
Rank
Newbie
dr_st wrote:

Thanks! What wasn't working before that is fixed with this patch?

with my release you can use the main sigil.wad and it will appear as a 5th episode, no need to use sigil_compat.wad and replace inferno.
you have to use an ultimate doom iwad for it to work though.

mbf_sigil.png

Reply 165 of 193, by dr_st

User metadata
Rank l33t
Rank
l33t

So looks like same-species infighting (which can be achieved in vanilla DOOM by the simple DeHackEd patch below is broken in MBF (and BOOM as well)? Somehow I only now noticed it.

Does it look like something that can be easily fixed / achieved by other means?

Patch File for DeHackEd v3.0

# Note: Use the pound sign ('#') to start comment lines.

Doom version = 19
Patch format = 6


Misc 0
Monsters Infight = 221

https://cloakedthargoid.wordpress.com/ - Random content on hardware, software, games and toys

Reply 166 of 193, by dr_st

User metadata
Rank l33t
Rank
l33t

Bah.

After verifying that the infighting DeHackEd patch support works in PrBoom+, I partially ported the following PrBoom commit to MBF, complete with the comments crediting original author "e6y" (only the changes related to monsters_infight, not the others):
https://github.com/coelckers/prboom-plus/comm … 78c9a6066711506

Same-species infighting appears to work perfectly now with the patch above.

In the attached ZIP are the 4 changed files and a .DIFF file.

@gerwin
Do you mind picking up this change?
How about bumping the version number? There have been quite a few changes since 2014, and we are still at 2.04.

Attachments

https://cloakedthargoid.wordpress.com/ - Random content on hardware, software, games and toys

Reply 167 of 193, by gerwin

User metadata
Rank l33t
Rank
l33t

I will pick up the change, seems like a fun option to tinker with the infighting. Thanks for the efforts.
Last time I changed the version number from 2.03 to 2.04 there appeared to be checks for demo and save files: They did not work properly since they expected to read 2.03. So I rather just keep that version as it is now, to prevent problems, then use the build date as an actual sub-version of 2.04.

--> ISA Soundcard Overview // Doom MBF 2.04 // SetMul

Reply 168 of 193, by Sakitoshi

User metadata
Rank Newbie
Rank
Newbie

@dr_st Thanks for the heads up, I also integrated that change into my fork.

@gerwin feel free to use my changes to support sigil. I just did it to see if I could make sigil run as a proper 5th episode under dos (as it should be) and as it worked pretty well I decided to publish it.
https://github.com/Sakitoshi/mbf_sigil

Reply 169 of 193, by wa59

User metadata
Rank Newbie
Rank
Newbie
Sakitoshi wrote:

@dr_st Thanks for the heads up, I also integrated that change into my fork.

@gerwin feel free to use my changes to support sigil. I just did it to see if I could make sigil run as a proper 5th episode under dos (as it should be) and as it worked pretty well I decided to publish it.
https://github.com/Sakitoshi/mbf_sigil

I just tried this version on real hardware, and all I get is a black screen after the initial loading. This happens on DOS 6.22 with a k6-2 and with a 486 dx4. This happens on all versions from 2.04-sigil1 through 2.04-sigil4.

Unpatched MBF 2.04 runs fine. 😒

@echo $bio

Reply 170 of 193, by Sakitoshi

User metadata
Rank Newbie
Rank
Newbie
wa59 wrote:

I just tried this version on real hardware, and all I get is a black screen after the initial loading. This happens on DOS 6.22 with a k6-2 and with a 486 dx4. This happens on all versions from 2.04-sigil1 through 2.04-sigil4.

Unpatched MBF 2.04 runs fine. 😒

I tested on dosbox and a real pentium 3 866mhz running windows me and dos 7.1.
it works flawless on all of the tested systems (although I can only make the music work under dos, the sound blaster pci 128 is weird).

the changes I made aren't severe and shouldn't interfere if you play base doom or doom 2.

EDIT: try deleting MBF.CFG to reset the settings.

Reply 171 of 193, by wa59

User metadata
Rank Newbie
Rank
Newbie
Sakitoshi wrote:
I tested on dosbox and a real pentium 3 866mhz running windows me and dos 7.1. it works flawless on all of the tested systems (a […]
Show full quote
wa59 wrote:

I just tried this version on real hardware, and all I get is a black screen after the initial loading. This happens on DOS 6.22 with a k6-2 and with a 486 dx4. This happens on all versions from 2.04-sigil1 through 2.04-sigil4.

Unpatched MBF 2.04 runs fine. 😒

I tested on dosbox and a real pentium 3 866mhz running windows me and dos 7.1.
it works flawless on all of the tested systems (although I can only make the music work under dos, the sound blaster pci 128 is weird).

the changes I made aren't severe and shouldn't interfere if you play base doom or doom 2.

EDIT: try deleting MBF.CFG to reset the settings.

Even after extracting all files into a new folder, deleting MBF.CFG and copying DOOM2.WAD I still get a black screen, this was also tested on Windows 98.

I understand that it's a small patch and that it should work, but the older version loads fine so I don't know what could be causing it.

@echo $bio

Reply 172 of 193, by mOBSCENE

User metadata
Rank Newbie
Rank
Newbie
wa59 wrote:

Even after extracting all files into a new folder, deleting MBF.CFG and copying DOOM2.WAD I still get a black screen, this was also tested on Windows 98.

I understand that it's a small patch and that it should work, but the older version loads fine so I don't know what could be causing it.

Are you sure you are using the correct Doom WAD? (Ultimate Doom WAD which should be named "doomu.wad", according to the batch file included) You mention using "DOOM2.WAD".

@ Sakitoshi: Just tested the SIGIL MBF version and it runs fine on my real hardware (AMD K6). Thanks for the compatibility update! However, I'm just wondering why you have decided to use the old Allegro Sound System setup/config. Did you use an older version of MBF as well?

Also, would it be possible to have the correct demo level shown at startup? Now the demo plays on a map of SIGIL, which of course leads to nothing good 😉 If it's up to me, the SIGIL splash screen also should not show as default, since we're adding extra maps to the original version.

Reply 173 of 193, by Sakitoshi

User metadata
Rank Newbie
Rank
Newbie
mOBSCENE wrote:

@ Sakitoshi: Just tested the SIGIL MBF version and it runs fine on my real hardware (AMD K6). Thanks for the compatibility update! However, I'm just wondering why you have decided to use the old Allegro Sound System setup/config. Did you use an older version of MBF as well?

Also, would it be possible to have the correct demo level shown at startup? Now the demo plays on a map of SIGIL, which of course leads to nothing good 😉 If it's up to me, the SIGIL splash screen also should not show as default, since we're adding extra maps to the original version.

I decided to use allegro setup again because I think that it works better with the version of allegro I have to compile it (for some reason I was getting adlib sound and music no matter how I changed the settings). maybe I was doing something wrong, but what's done is done.

sigil title screen and demos shows up because that's how it's supposed to work, sigil.wad contains title screen and demo lumps, so of course the ultimate doom title and demos are going to be replaced by sigil's. now, I know the demos are desyncing, but so they are in every source port I've seen (and in vanilla doom 1.9 too).
if you want to get the ultimate doom title screen and all that you'll need to open sigil.wad with slade and delete those lumps.

Reply 174 of 193, by gerwin

User metadata
Rank l33t
Rank
l33t
Sakitoshi wrote:

I decided to use allegro setup again because I think that it works better with the version of allegro I have to compile it (for some reason I was getting adlib sound and music no matter how I changed the settings). maybe I was doing something wrong, but what's done is done.

My MBF 2.04 work was about the sound drivers to a large extend. These reside in the Allegro 3 library. So Doom MBF 2.04 is supposed to be compiled with this modified Allegro. The necessary files are included in the packages. Also precompiled ones.
The MBF 2.04 setup program mirrors this work and is matched to this modified Allegro.
Besides that I had best results with a 1997 DJGPP compiler setup. Further details can be found in earlier posts in this very topic.

--> ISA Soundcard Overview // Doom MBF 2.04 // SetMul

Reply 176 of 193, by hail-to-the-ryzen

User metadata
Rank Member
Rank
Member

The D4V gameplay mod (DOOM 4 VANILLA v2.2) exits with error while playing map06 with DIGMID wavetable music driver. Did not yet detect this issue with other midi based songs. One solution is to convert the MIDI lump to a MUS formatted lump file.

Have not yet determined the cause in the code, but the other MIDI drivers work fine so far. One possibility is the tick based timing in the midi file and its compatibility with the DIGMID driver or the ability of the DIGMID driver to send output to MBF.

Reply 177 of 193, by Pablo_Doom_Guy

User metadata
Rank Newbie
Rank
Newbie
Sakitoshi wrote:

so I was doing something wrong.
well, I don't think I'm going to change it back, is good enough for me and I'm too lazy to do it.

hi , i've downloaded your "sigil" MBF version and it runs super fine , the problems i've found so far are :

1- Plutonia Map 07 softlocks after killing the enemies on the first part of the level (after you kill the first monsters the door should automatically open and this is not happening)
2- It's cool to be able to play Eviternity on dosbox, the only problem is that maps 15, 31 and 32 wont load , idclev or -warp will crash the game giving a "segmentation violation" error

i was also able to run mutiny with your latest mbf version =) .

Reply 178 of 193, by Sakitoshi

User metadata
Rank Newbie
Rank
Newbie
Pablo_Doom_Guy wrote:
hi , i've downloaded your "sigil" MBF version and it runs super fine , the problems i've found so far are : […]
Show full quote
Sakitoshi wrote:

so I was doing something wrong.
well, I don't think I'm going to change it back, is good enough for me and I'm too lazy to do it.

hi , i've downloaded your "sigil" MBF version and it runs super fine , the problems i've found so far are :

1- Plutonia Map 07 softlocks after killing the enemies on the first part of the level (after you kill the first monsters the door should automatically open and this is not happening)
2- It's cool to be able to play Eviternity on dosbox, the only problem is that maps 15, 31 and 32 wont load , idclev or -warp will crash the game giving a "segmentation violation" error

i was also able to run mutiny with your latest mbf version =) .

thanks for the heads up. just published the fix for level 7.
I accidentally broke tag 666 and 667 while implementing the master levels behavior.

regarding eviternity, I believe that the seg faults are due to the sheer size of that wad. it's just too much for dos mbf to take. maybe there is a way to fix it, but I lack the knowledge.

Last edited by Sakitoshi on 2019-12-02, 17:42. Edited 2 times in total.

Reply 179 of 193, by Pablo_Doom_Guy

User metadata
Rank Newbie
Rank
Newbie
Sakitoshi wrote:
thanks for the heads up. just published the fix for level 7. I accidentally broke tag 666 and 667 while implementing the master […]
Show full quote
Pablo_Doom_Guy wrote:
hi , i've downloaded your "sigil" MBF version and it runs super fine , the problems i've found so far are : […]
Show full quote
Sakitoshi wrote:

so I was doing something wrong.
well, I don't think I'm going to change it back, is good enough for me and I'm too lazy to do it.

hi , i've downloaded your "sigil" MBF version and it runs super fine , the problems i've found so far are :

1- Plutonia Map 07 softlocks after killing the enemies on the first part of the level (after you kill the first monsters the door should automatically open and this is not happening)
2- It's cool to be able to play Eviternity on dosbox, the only problem is that maps 15, 31 and 32 wont load , idclev or -warp will crash the game giving a "segmentation violation" error

i was also able to run mutiny with your latest mbf version =) .

thanks for the heads up. just published the fix for level 7.
I accidentally broke tag 666 and 667 while implementing the master levels behavior.

regarding eviternity, I believe that the seg faults are due to the sheer size of that wad. it's just too much for dos mbf to take. maybe there is a way to fix it, I lack the knowledge.

Wow that was a fast fix, thank you , now it's working as intended =) .
according to zennode , map 15/31/32 blockmaps are too big (actual error message "Level too big to create valid blockmap") , but i think it's ok , this wad was not meat to be played on an ms-dos port.

I'll do a much intense test tomorrow