VOGONS


"Madness", One retro PC to rule them all :)

Topic actions

First post, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie

Hello all 😀

Challenge :
Build a universal Retro PC for DOS/Win98SE/WinXP/Win7/Win10 [x64].
Native support. No DOSBox/Virtualisation/etc.
Basicly : "The Impossible stuff" 😁

Well, I gave it a shot... and here are the results :

DOS 6.22 :
Sz7d780.jpg

Windows 98 SE :
BWxZpIi.png

Windows 2000 :
XWean4X.png

Windows XP :

3DMark 03 GTX 780 Ti mini.png
Filename
3DMark 03 GTX 780 Ti mini.png
File size
419.61 KiB
Views
4323 views
File license
Fair use/fair dealing exception

Windows 7 x64 SP1 :

3DMark 03 GTX 780 Ti mini.png
Filename
3DMark 03 GTX 780 Ti mini.png
File size
389.23 KiB
Views
4323 views
File license
Fair use/fair dealing exception

Windows Server 2016 (Win 10+) :

3DMark 03 GTX 780 Ti mini.png
Filename
3DMark 03 GTX 780 Ti mini.png
File size
275.71 KiB
Views
4323 views
File license
Fair use/fair dealing exception

DirectX 12 support test : https://www.3dmark.com/spy/2555135
Checked, and Valid 😀

I added Win2000 and Server 2016 to make it even more ridiculus/compatible 😁

Hardware list :
CPU : Core i7 980X (w/BOX cooling)
MB : Rampage II Extreme (BIOS 2101)
RAM : Corsair 3x4GB
GPU1 : GeForce 7800 GTX (Reference)
GPU2 : GeForce GTX 780 Ti (Reference)
SC1 : Aureal Vortex 2
SC2 : Auzen X-Fi Forte
HDD0 : Compact Flash 1GB
HDD1 : WD Raptor 74GB
HDD2 : WD RaptorX 150GB
HDD3 : Samsung SM961 256GB (NVMe)
Clover "Pendrive" (card reader + microSD) : Sandisk 8GB
PSU : OCZ ZS-750W
Floppy : GOTEK USB Floppy Emulator

Pics :
Working : LINK
PCI(e) Devices : LINK

Slot vs. Device :
PCIe x1 = "Empty"
PCIe x16 2.0 "1" = 7800 GTX
PCIe x1 "2" = X-Fi Forte
PCIe x16 2.0 "2" @ x8 = NVMe
PCI = Aureal Vortex 2
PCIe x16 2.0 "3" @ x8 = GTX 780 Ti

Notes :
1) rlowe patch NOT required if you can live with 1GB RAM on Windows 7/10 😁
2) No CD's were used during OS installation (card readers + microSD FTW 😉).
3) Sound works in ALL OS-es (DOS <=> Win2000 = Aureal Vortex 2; WinXP <=> WinServer '16 = X-Fi Forte)
4) GTX 780 Ti will not work with 7900 GTX on Windows 98SE (if moded drivers are used).
Reason : NV driver falls apart if it sees 512MB of VRAM and another card. Unplugging GTX 780 Ti solves this issue.
5) Quadro FX-1300/6800 GT will not work in Win2000 because of AGP to PCI-e bridge conflict with MB's PCIe to PCI brudge.
6) GTX 780 Ti uses PCI-e 2.0 x8 slot (and since it's Dual Slot card, it requires some space below last slot if this setup had to be mounted in actual case).

I made a video how it all works as well : LINK
Enjoy 😀

Conclusion :
I know this can't run really old games because of CPU speed sensitivity [Core i7 980X can go as low as 1,2GHz with 100MHz BCLK], or those that are simply not compatible with GF 7800 GTX in DOS mode.
I wanted to showcase a working PC that can do modern things but that is capable of running retro programs (up to a point).

UPDATE (07.11.2017) : LINK

Current configuration :
CPU : Core i7 980X (w/BOX cooling)
MB : Rampage II Extreme (BIOS 2101)
RAM : Corsair 3x4GB (12GB total)
GPU1 : GeForce 7800 GTX (Reference)
GPU2 : GeForce GTX 780 Ti (Reference)
SC1 : Aureal Vortex 2 + DreamBlaster X2
SC2 : Auzen X-Fi Forte
HDD0 : Transcend Industrial Ultra 1GB (Compact Flash) [DOS 6.22]
HDD1 : WD Raptor 74GB [Win 98 SE]
HDD2 : Kingston SM2280S3G2 (M.2 AHCI/SATA) [Windows 2000 SP4 + Windows XP SP3]
HDD3 : Samsung SM961 256GB (NVMe) [Windows 7 x64 SP1 + Windows Server 2016]
"Pendrive" (card reader + microSD) : Sandisk 8GB [Clover]
PSU : OCZ ZS-750W
Floppy : GOTEK USB Floppy Emulator

Last edited by agent_x007 on 2017-11-07, 13:17. Edited 10 times in total.

108080818886.png

Reply 2 of 69, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie
emosun wrote:
agent_x007 wrote:

Unplugging GTX 780 Ti solves this issue.

one could argue that if you have to remove/add hardware from the machine to make different OS's work then it wasn't a success.

Indeed, that's why I didn't use 7900 GTX, but 7800 GTX instead (which works in Win98SE with GTX 780 Ti plugged in) 😀

108080818886.png

Reply 3 of 69, by cyclone3d

User metadata
Rank l33t
Rank
l33t
emosun wrote:
agent_x007 wrote:

Unplugging GTX 780 Ti solves this issue.

one could argue that if you have to remove/add hardware from the machine to make different OS's work then it wasn't a success.

Probably why a 7800 GTX is being used instead of a 7900 GTX.

Bah, replied to while I was reading/replying.

Yamaha YMF modified setupds and drivers
Yamaha XG resource repository - updated November 27, 2018
Yamaha YMF7x4 Guide
AW744L II - YMF744 - AOpen Cobra Sound Card - Install SB-Link Header
Epstein didn't kill himself

Reply 4 of 69, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie
cyclone3d wrote:

Bah, replied to while I was reading/replying.

😀
There is also another reason for 7800 GTX instead of 7900 GTX :
7900 GTX is Dual Slot, while 7800 GTX is Single Slot.
With 7900 GTX, X-Fi Forte would have to use PCI-e Riser from first PCI-e x1 port (because it's too long to be mounted directly in it).
PS. I didn't opted for 7900 GT 256MB, because of small/cheap cooling solutions on those.

108080818886.png

Reply 5 of 69, by vvbee

User metadata
Rank Oldbie
Rank
Oldbie

Run path_bench in dos on it, PATH_BENCH - DOS path tracing CPU benchmark, and see what you end up with. Probably won't match the xeon in one-core perf, but who knows. No dos on the xeon machine though.

Reply 6 of 69, by Jade Falcon

User metadata
Rank BANNED
Rank
BANNED

well I do know that some sk370 system can do 286 speeds with a 1.4ghz with unsupported bios.
grab a gigabyte board with dual bios, 😈 for me a dual piii 1.4ghz setup is the way to go.

Last edited by Jade Falcon on 2017-10-17, 03:13. Edited 1 time in total.

Reply 7 of 69, by sprcorreia

User metadata
Rank Oldbie
Rank
Oldbie

Nice build. Personally I don't go over 478 P4 to maintain ISA slots.
I have an awesome ISA soundcard that outputs everything through SPDIF in MS-DOS and I like it.

So I'm stuck with the traditional AGP, 875 chipset, P4 3.2GHz with HT and max. 4GB DDR, but with two fully working ISA slots.

Reply 8 of 69, by gdjacobs

User metadata
Rank l33t++
Rank
l33t++
sprcorreia wrote:

I have an awesome ISA soundcard that outputs everything through SPDIF in MS-DOS and I like it.

CMI 8330 based Zoltrix/AudioExcel AV310? I'd like to find one!

All hail the Great Capacitor Brand Finder

Reply 9 of 69, by sprcorreia

User metadata
Rank Oldbie
Rank
Oldbie
gdjacobs wrote:
sprcorreia wrote:

I have an awesome ISA soundcard that outputs everything through SPDIF in MS-DOS and I like it.

CMI 8330 based Zoltrix/AudioExcel AV310? I'd like to find one!

No, it's an ESS based card.

Reply 10 of 69, by gdjacobs

User metadata
Rank l33t++
Rank
l33t++

Ah. I don't believe any of the ESS codecs natively interface with SPDIF, so it will most likely be going through an ADC stage internally. Still very nice, I expect.

All hail the Great Capacitor Brand Finder

Reply 11 of 69, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie
vvbee wrote:

Run path_bench in dos on it, PATH_BENCH - DOS path tracing CPU benchmark, and see what you end up with. Probably won't match the xeon in one-core perf, but who knows. No dos on the xeon machine though.

Best score (out of 5 tries I did) :
tTm08bm.jpg
Others were "about 2 sec." 😀

108080818886.png

Reply 13 of 69, by brostenen

User metadata
Rank l33t++
Rank
l33t++

Qurious...
What games and software have you had running without issues in MS-Dos 6.22 ?
Then, what games and software have you had running on Win9x?

Don't eat stuff off a 15 year old never cleaned cpu cooler.
Those cakes make you sick....

My blog: http://to9xct.blogspot.dk

001100 010010 011110 100001 101101 110011

Jah ich will trynen... Die Leute wie macht scheisse in dem Grünen.

Reply 14 of 69, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie

In Win 98SE, I ran Doom 3 timedemo, and Quake III Arena timedemo (both worked fine).
3DMark 01 SE and 03 also did OK (screen shot of 03 is in 1-st post).
In DOS I run Blood (with sound, since Aureal Vortex 2 does SB emulation).
1600x1200 had graphic glitches, but 1024x768 played super smooth 😀
I also tried MIDI player (DOSMid) also worked fine.
Few programs from Phil's DOS benchmark suite also worked without issues.

I'm not sure what games to run in DOS/Win98SE... any suggestions ?
PS. In DOS I didn't use FastVID or MTRRLFBE yet.

Last edited by agent_x007 on 2017-10-17, 18:43. Edited 1 time in total.

108080818886.png

Reply 15 of 69, by brostenen

User metadata
Rank l33t++
Rank
l33t++
agent_x007 wrote:
In Win 98SE, I ran Doom 3 timedemo, and Quake III Arena timedemo (both worked fine). 3DMark 01 SE and 03 also did OK (screen sho […]
Show full quote

In Win 98SE, I ran Doom 3 timedemo, and Quake III Arena timedemo (both worked fine).
3DMark 01 SE and 03 also did OK (screen shot of 03 is in 1-st post).
In DOS I run Blood (with sound, since Aureal Vortex 2 does SB emulation).
1600x1200 had graphic glitches, but 1024x768 played super smooth 😀

I'm not sure what games to run in DOS/Win98SE... suggestions ?

Win98se:
- Need For Speed Porche 2000
- Unreal Tournament 99
- Need For Speed 3
- Hidden And Dangerous

Dos:
- Dynablaster
- Civilization
- Alley Cat
- Warcraft 1
- The first command and conqour
- Descent
- Monkey Island
- Doom
- Lotus III
- Sam And Max hit the road
- Full Throttle
- Dark Forces
- Sim Earth
- Sim City

Don't eat stuff off a 15 year old never cleaned cpu cooler.
Those cakes make you sick....

My blog: http://to9xct.blogspot.dk

001100 010010 011110 100001 101101 110011

Jah ich will trynen... Die Leute wie macht scheisse in dem Grünen.

Reply 16 of 69, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie
brostenen wrote:
Win98se: - Need For Speed Porche 2000 - Unreal Tournament 99 - Need For Speed 3 - Hidden And Dangerous […]
Show full quote

Win98se:
- Need For Speed Porche 2000
- Unreal Tournament 99
- Need For Speed 3
- Hidden And Dangerous

So :
Porsche 2000 - Game crashes after loading screen (after intro, before menu), have to do more research about this...
Other than that :
UT99 - Runs great. Had to figure out the controls tho (mouse up = move forward [default settings], WTF!?).
After I changed those, everything was fine. I used 1024x768 16-bit with DirectX path (90FPS lock).
NFS3 - No problems here, completed a 2 lap race. Works on both low and high graphics quality settings.
Hidden and Dangerous : Game loaded fine, and it didn't crash after I fired a gun as well 😀
Looks like it may take a while to master tho. I didn't finished any missions yet.

DOS games will have to wait for tommorow 😀
For now I added the video (no timestamps yet, 1h 21min) with switching between OS'es.

108080818886.png

Reply 17 of 69, by brostenen

User metadata
Rank l33t++
Rank
l33t++

Yeah.... Porche need a new patch, as it is an DX7 game, and takes heavy use of that.
Issues are some of these and possible more:

Menu text will be washed out/not sharp when going for anything newer than GF2 and DX7 (can be fixed with AA/AF settings. Smoke from the tires, will get more and more green, when going with something that are faster than G400/GF2/V3. (FX-5xxx are the absolute worst line of cards) When changing camera to dashcam mode, the gearshift arm will fly around like crazy, when shifting gears (both in manual and automatic gear mode).

In UT99... Do you have jaggered and false rendered wall lamps in one of the first levels, and does the computer render vertical lines without issues, when looking at them in the distant? If they are falsly rendered, then you need to patch for the newest version and enable AAx4 and possible AFx2. Another thing that has crossed me, regarding UT99, is that it sometimes makes a kind of lag on it's head. To simplify. It jumps a couple of frames ahead. Feels like the computer just decides to render twice or three times faster, just a splitsecond each time. That was on a Sempron, socket 754 with an Radeon 9600se.

Don't eat stuff off a 15 year old never cleaned cpu cooler.
Those cakes make you sick....

My blog: http://to9xct.blogspot.dk

001100 010010 011110 100001 101101 110011

Jah ich will trynen... Die Leute wie macht scheisse in dem Grünen.

Reply 18 of 69, by agent_x007

User metadata
Rank Oldbie
Rank
Oldbie
brostenen wrote:
Dos: - Dynablaster - Civilization - Alley Cat - Warcraft 1 - The first command and conqour - Descent - Monkey Island - D […]
Show full quote

Dos:
- Dynablaster
- Civilization
- Alley Cat
- Warcraft 1
- The first command and conqour
- Descent
- Monkey Island
- Doom
- Lotus III
- Sam And Max hit the road
- Full Throttle
- Dark Forces
- Sim Earth
- Sim City

Dynablaster = OK (w/sound),
Civilization = OK (w/sound),
Alley cat = OK (no sound),
Warcraft = DOS4GW error 2001,
CnC = DOS4GW error 2001,
Descent = DOS4GW error 2001,
Monkey Island = Math error (Integer Divide error [dividing by 0] ?),
Doom = OK (w/sound),
Lotus III = Hard crash,
Sam And Max hit the road = OK (w/sound), sometimes cursor gets stuck, but using Left/right or up/down on edge gets it unstuck 😀
Full Throttle = OK-ish (w/sound). It sometimes crashes (on action).
Dark Forces = OK (w/sound),
Sim City = OK-ish (w/sound), [game speed problems on Normal speed]
Sim Earth = OK (w/sound, no music).

^Oh, all tests were done with 4,3GHz OC on CPU and no additional stuff in Autoexec.bat (only what Aureal Vortex 2 required to make SB16 emu working).

PS. Here are pics of my Autoexec/config.sys files (and "mem" command) :

AUTOEXEC.jpg
Filename
AUTOEXEC.jpg
File size
152.18 KiB
Views
4018 views
File license
Fair use/fair dealing exception
CONFIGSYS.jpg
Filename
CONFIGSYS.jpg
File size
141.24 KiB
Views
4018 views
File license
Fair use/fair dealing exception
MEM.jpg
Filename
MEM.jpg
File size
171.7 KiB
Views
4018 views
File license
Fair use/fair dealing exception

As you can see, there really isn't much inside 😁

108080818886.png

Reply 19 of 69, by Kamerat

User metadata
Rank Oldbie
Rank
Oldbie
agent_x007 wrote:

Warcraft = DOS4GW error 2001,
CnC = DOS4GW error 2001,
Descent = DOS4GW error 2001,

Try using EMM386 or JEMMEX. Using another DOS extender (like DOS/32A) might also help.

agent_x007 wrote:

Monkey Island = Math error (Integer Divide error [dividing by 0] ?),

I think this is a speed related issue, have you patched the game?

DOS Sound Blaster compatibility: PCI sound cards vs. PCI chipsets
YouTube channel