First post, by Scythifuge

User metadata
Rank Oldbie


This doesn't have to do with emulation, but with an issue with a real MT-32. Whenever I try to run either Savage Empire or Martian Dreams, they hang. They will run if set up to use a Sound Blaster. Does anyone have any clue as to why this is happening? Thanks!


Reply 1 of 9, by Dominus

User metadata
Rank DOSBox Moderator
DOSBox Moderator

is this with Dosbox? If yes, try to set mpu401= under the [midi] section to none, uart or intelligent and also try the different cores.

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for macOS (10.4-11.x ppc/intel 32/64bit) notarized for gatekeeper

Reply 4 of 9, by mvmiller12

User metadata
Rank Newbie

Actually I am having the exact same problem as the OP above. Martian Dreams, Wing Commander 1 (and Secret Missions) and Wing Commander 2 (and Special Ops) all lock up my 486 PC when using my real MT-32. It is only these 3 Origin games that do it and only when trying to use the MT-32 (SoundBlaster support works fine). Other Wing Commander games (Academy, Privateer, Armada, etc.) are fine, Ultima's 6 & 7 work great, all Sierra games work great (TIM, KQ4 and up, SQ1, 3 & up, LSL1, 3 & up, Willie Beamish, etc.). I even tried Buck Rogers 2 - Matrix Cubed and it worked fine as well. I tried these games because they are the oldest ones supporting the MT-32 I have (I initially thought it could be the problem games were using Intelligent Mode on the MPU-401 causing the lockup, but if KQ4 and Matrix Cubed, both designed to run on an 8088, work OK that is unlikely) Again, it is only these 3 Origin games that cause the lockup - All the other MT-32 games, and Windows all work fine. None of my newer MIDI games that use the SoundCanvas have any of these issues either.

Lock up details:
Game loads Origin Sound System! and the OriginFX intro starts. Shortly into the fireworks display at the end of the OriginFX intro, the PC hard locks and the MT-32 starts looping the last sound it was playing. This requires turning the MT-32 and PC off entirely and turning them back on to fix. This same problem happened initially with Wing Commander Academy as well, but that game uses the Miles AIL 2 libraries, so I copied the MT32MPU.ADV file from a working game and that resolved it.

I can get the MT-32 to work in all games except Ultima 7 if I replace the PC MIDI Card with a Gravis Ultrasound running MegaEm 3 to emulate an MPU-401 and output all MIDI through the GUS MIDI port instead. I really should be able to just use the MIDI card and run everything though.

PC I am working with:
IBM PS ValuePoint 6381-F50 - 486SX-25 CPU, 16M RAM, integrated CL-5628 video w/1M RAM. IRQ 9 is enabled by jumper (disables video IRQ - have tried with this both on and off, makes no difference), LPT and COM ports are all disabled in the BIOS as they are unused - PC has 3 ISA slots for expansion containing:
(Slot 1) - MusicQuest PC MIDI Card 8-Bit ISA (100% MPU-401 compatible, when you read MPU-401 in my notes THIS is the card I mean) - set at Port 330, IRQ 2/9
(Slot 2) - 3Com EtherLink III 16-Bit ISA set at Address 3A0
(Slot 3) - Creative SoundBlaster AWE64 Gold 16-Bit ISA set at A220 I7 D1 H5 P300 E620
Roland MT-32 (connected to PC via MIDI IN and MIDI OUT)
Roland SoundCanvas SC-55mkII (connected to MT-32 via MIDI THRU)
15G IDE HDD (Master)
52x IDE CDROM (Slave)
3.5" Floppy Drive
PS/2 Mouse and KB
PC-DOS 2000
Windows 3.11 for Workgroups (all DOS games run in pure DOS)
QEMM '97 (tried under both QEMM and regular DOS HIMEM.SYS and EMM386.EXE)

Troubleshooting tried:
Removing all ISA cards other than the MPU-401
Memtest x86 (24 hrs stable)
Trying different port on MPU-401
Trying different IRQ on the MPU-401
Clean booting into DOS (No Drivers at all)
Connected MIDI IN & OUT to the SoundCanvas, leaving MT-32 disconnected.

If anyone has any other suggestions, please let me know. Someone somewhere has to have run into and resolved this before. . .

Michael Miller

* edit * corrected PC Model # and clarified test game choices - BTW, if anyone still has the update patches for QEMM '97, I'd REALLY like to get up with you as they're about impossible to find on the 'net. . . 😀

Reply 6 of 9, by Hardrock

User metadata
Rank Newbie

I downloaded Savage Empire from Abandonia. It did not have any documentation with it. It seems to run fine in Dosbox, but I cannot get past the copy protection question.
Does anyone know where I can download the manual (I have found maps) or at least get the copy protection questions and answers. Thanks

Reply 7 of 9, by Dominus

User metadata
Rank DOSBox Moderator
DOSBox Moderator

We don't help here people with pirated software. Go somewhere else for help.
And it is also bad netiquette to hijack a thread in this manner.

Last edited by Dominus on 2008-12-08, 17:06. Edited 1 time in total.

Reply 9 of 9, by Dominus

User metadata
Rank DOSBox Moderator
DOSBox Moderator

No chance to integrate this into Exult. Exult is only aimed at the Ultima 7 engine. But for the other Ultima games you have the following projects:
Nuvie http://nuvie.sf.net aimed at the Ultima 6 engine which does include Martian Dreams and Savage Empire (but spport for these two is not yet as good as for U6)
Pentagram http://pentagram.sf.net aimed at the Ultima 8 engine, which includes Crusader: No Remorse/Regret (same as with Nuvie, support for the Crusader games is no as advanced)
Xu4 http://xu4.sf.net aimed at Ultima 4