First post, by SquallStrife

User metadata
Rank l33t

Hi, this is my first post here, and I thought I'd share a solution I cobbled together in the face of hours of frustration.

I was having trouble with Space Quest 4. The music was working fine until the first digital sound effect played. After that, the music plays but it's all crazy, but digital sound effects (incl speech) continue to function as normal. I was not having the same problem with SQ3, SQ5 or any other MT-32 enabled game.

My system is a 486 DX2/66, with an ISA SB16 PnP (CT2940) and an MT-32 connected to the SB's gameport with the appropriate cable.

I tried all the fixes, turning off turbo, MoSlo, pre-loading the patches to the MT-32, the various Sierra driver solutions on offer at Quest Studios, and even a replacement sound card, but to no avail.

Surprisingly, I found my solution in a patch that specifically says it is NOT for SQ4. The package at this address is intended to fix "error 29" for SQ1 VGA among others.

This driver will work for the following games: […]
Show full quote

This driver will work for the following games:

Police Quest III
Space Quest I Enhanced VGA
Leisure Suit Larry I Enhanced VGA
Leisure Suit Larry V
Hoyles III

This file will not work with any other Sierra or Dynamix titles.
For King's Quest V choose the AdLib option and the game will sound
perfect. For Space Quest IV, try slowing the system down when you
start the game by turning off the Turbo button. You can speed it
back up once in the game. If you do not have a Turbo button, you
will need to choose the AdLib option.

Against its advice, I placed the MTBLAST.DRV into my SQ4 folder, added some lines to INSTALL.HLP:

MT-32 / Soundblaster MIDI

Ran the setup utility, picked the new driver, and held my breath.

It runs perfectly. I still have sound effects, speech, and fully functioning MT-32 support (all the custom patches are there!).

So, just thought I'd share this, for any other Quester out there who has tried it all, but still gets nowhere.


Last edited by SquallStrife on 2010-02-07, 07:18. Edited 1 time in total.

Reply 1 of 4, by Dominus

User metadata
Rank DOSBox Moderator
DOSBox Moderator

Thanks for the heads up. It's a nice gesture to register and all just for posting something helpful!

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox
DOSBox SVN snapshot for macOS (10.4-11.x ppc/intel 32/64bit) notarized for gatekeeper

Reply 3 of 4, by Kynrek

User metadata
Rank Newbie

I know that this is a very old post but I wanted to add some tips for posterity. I was going crazy with the same problem and was very happy to find this thread! I have the Space Quest Collection version on CD and There was an additional step that I had to take to make this work as I kept getting an error saying the game couldn't find the driver file. Apparently it was looking for the new driver file on the CD! I downloaded the updated soundblaster driver for SQ4 from the same site linked in the original post and found additional instructions in the readme.txt that helped.

If you are playing the game from the CD, use a text editor (like the MS-DOS
Edit program) to modify the RESOURCE.CFG file in the game directory on your
hard drive. The line that refers to the SoundBlaster driver looks like this:


If you put AUDBLAST.DRV on your C: drive, edit the audioDrv line
to look like this:


after I used the install program to pick the new driver (every time you save changes with the install program actually) you have to modify resource.cfg to add C: in from of MTBLAST.DRV like this C:MTBLAST.DRV and then it worked! I also put C: in from of the new soundblaster driver I got too (I'm not sure it actually did anything but I installed it for good measure).