VOGONS


First post, by Lazar81

User metadata
Rank Member
Rank
Member

Hello,
Until now I used a midi emulator (falcosoft) with soundcards that have a gameport (windows xp machines). Connected the um-one (to the soundcard in the retro machine and to a sidekick that runs the falcosoft midiplayer) and everything runs nice.
I now wanted to do similar on my main machine with Windows 10. I googled a lot but found no tutorial or anything alike... So how can I use the midi emulator in DOSBox with Windows 10? No gameport there... 🤷
Do I need an USB to Gameport Adapter?
I imagine to connect things like that:
1. USB to Gameport Adapter to PC
2. MIDI cable to Adapter
3. MIDI cable to um-one
4. um-one to emulator machine
5. emulator machine sound to line in of PC

486-VIP-IO | CYRIX 5x86 | 16MB | MACH32 VLB | CT1740 | 4GB CF
-
6VIA5T | PIII-S 1400 | 512MB | GF4Ti4600 | TT GOLD 16/96 | 120GB SSD
-
GA-EP45 DS4 | X5470 | 4GB | RADEON HD 5870 | SB0220 | 1TB SSD
-
ROLAND MT-32 | ROLAND CM-32L | YAMAHA S-YXG50

Reply 1 of 3, by Lazar81

User metadata
Rank Member
Rank
Member

Ah... I found something else... Will try that and hope... 😬
-----

Get it working with loopmidi... Amazing... 😍

486-VIP-IO | CYRIX 5x86 | 16MB | MACH32 VLB | CT1740 | 4GB CF
-
6VIA5T | PIII-S 1400 | 512MB | GF4Ti4600 | TT GOLD 16/96 | 120GB SSD
-
GA-EP45 DS4 | X5470 | 4GB | RADEON HD 5870 | SB0220 | 1TB SSD
-
ROLAND MT-32 | ROLAND CM-32L | YAMAHA S-YXG50

Reply 2 of 3, by Nilwill

User metadata
Rank Newbie
Rank
Newbie

Unsure if you got this to work, but I was messing around with the Sound Canvas VA VST and used LoopMidi to create a virtual midi device that I could route sound through.

I currently am using Ableton to send the MIDI to, but any VST host works for my solution.

All this so I can play an emulated version of EverQuest (TAKP) that has the old MIDi music.

Reply 3 of 3, by Lazar81

User metadata
Rank Member
Rank
Member
Nilwill wrote on 2021-08-02, 05:02:

Unsure if you got this to work, but I was messing around with the Sound Canvas VA VST and used LoopMidi to create a virtual midi device that I could route sound through.

I currently am using Ableton to send the MIDI to, but any VST host works for my solution.

All this so I can play an emulated version of EverQuest (TAKP) that has the old MIDi music.

Got everything working with loopmidi and falcosoft midiplayer... It runs without any problem...

486-VIP-IO | CYRIX 5x86 | 16MB | MACH32 VLB | CT1740 | 4GB CF
-
6VIA5T | PIII-S 1400 | 512MB | GF4Ti4600 | TT GOLD 16/96 | 120GB SSD
-
GA-EP45 DS4 | X5470 | 4GB | RADEON HD 5870 | SB0220 | 1TB SSD
-
ROLAND MT-32 | ROLAND CM-32L | YAMAHA S-YXG50