VOGONS

Common searches


First post, by Bubby_the_Tour_G

User metadata
Rank Newbie
Rank
Newbie

Just installed DOSBox 0.70. Things get really slow when typing things in the DOSBox DOS prompt, it loads the game ever so slowly, for example, when trying to run Stunts, the intro screen takes 1 hour to get through, and the audio is chopped into farts. Lowering CPU Cycles to 1 and raising Frameskip to 10 does nothing at all. Checked in Windows Task Manager, and the CPU was still using 100% of itself for this program.

AMD Athlon 64-Bit Processor, 2.0 Ghz+
Asus K8N-E Mobo
Radeon 9800 Pro Video Card
Realtek AC'97 Audio card or drivers or whatever

Last edited by Bubby_the_Tour_G on 2007-07-16, 21:59. Edited 1 time in total.

Reply 3 of 18, by MiniMax

User metadata
Rank Moderator
Rank
Moderator

Cycles to 1?????
Better make that 10000, 20000 or even 30000.

DOSBox 60 seconds guide | How to ask questions
_________________
Lenovo M58p | Core 2 Quad Q8400 @ 2.66 GHz | Radeon R7 240 | LG HL-DT-ST DVDRAM GH40N | Fedora 32

Reply 5 of 18, by IIGS_User

User metadata
Rank Oldbie
Rank
Oldbie
Bubby_the_Tour_G wrote:

Set it to 30000, seems to be even slower

If it get slower at higher cycles, the cycles are too high. Now you must lower the cycles, because your real CPU tries to manage more cycles as it can really do.

Klimawandel.

Reply 6 of 18, by Bubby_the_Tour_G

User metadata
Rank Newbie
Rank
Newbie

It actually doesn't matter how many cycles I allow, whether it's set to 1 or 30000, it's still extremely slow. And I have a good computer, I'm not running a Commodore 64 or a 386 here.

Reply 7 of 18, by red_avatar

User metadata
Rank Oldbie
Rank
Oldbie

I had a very similar system like yours and it sounds to me rather that your Windows is f**ked up - if Dosbox always uses 100% it's probably windows that is doing something it shouldn't. You could mess with priority and see what it gives though.

Reply 10 of 18, by Bubby_the_Tour_G

User metadata
Rank Newbie
Rank
Newbie

Crap. Dosbox doesn't run in Safe Mode. Restarted m'puter and disabled most of the unneccessary .exe's that were running in my system memory. Ran Dosbox again... still lagged down and eating 100% of CPU.

Reply 12 of 18, by DosFreak

User metadata
Rank l33t++
Rank
l33t++

Check your ddraw/d3d acceleration in dxdiag.
Make sure hardware acceleration for video is all the way to the right.

DOSBox Compilation Guides
DosBox Feature Request Thread
PC Game Compatibility List
How To Ask Questions The Smart Way
Running DRM games offline

Reply 14 of 18, by ADDiCT

User metadata
Rank Oldbie
Rank
Oldbie

DOSBox shouldn't use 100% CPU after starting it. There's something wrong with your machine, OS, or setup. Let's try to identify the source of the problem.

- Unplug _all_ USB devices, and disable programs running in the background, like virus scanners, etc.
- Re-Install DOSBox, or copy the default dosbox.conf file into the directory you've installed DOSBox
- Change the "priority=higher,normal" line to "priority=normal,normal"

Start DOSBox (not the game). If it's still using 100% CPU (and i mean 100%, not 85% or 90%), change the "output=" setting in dosbox.conf, and watch the CPU utilization after every "output=" change (just start DOSBox, not the game).

Some general questions:
- Do you have any FPS or other modern 3D games on your machine? If you have, do they run OK?
- Did you install the latest drivers for your graphics card and sound-chip? Is your DirectX up to date?

Reply 17 of 18, by Xelasarg

User metadata
Rank Member
Rank
Member
red_avatar wrote:

it sounds to me rather that your Windows is f**ked up - if Dosbox always uses 100% it's probably windows that is doing something it shouldn't.

Have you tried reinstalling or repairing windows?

"What's a paladin?!"

Reply 18 of 18, by franpa

User metadata
Rank Oldbie
Rank
Oldbie

i attempted repairing windows once and all it did was cause the computer to reset while starting windows ;\

but that was after recovering from a virus. the virus was gone, but the damage it caused remained...

AMD Ryzen 3700X | ASUS Crosshair Hero VIII (WiFi) | 16GB DDR4 3600MHz RAM | MSI Geforce 1070Ti 8GB | Windows 10 Pro x64.

my website