VOGONS

Common searches


First post, by Solymr

User metadata
Rank Newbie
Rank
Newbie

Hello,

Am having issues with running DOSbox windowed, set output to ddraw and using resolution of 1024x768 but when running a game the game runs at its original resolution so that there's this small box in the corner of the game and lots of big black empty space in the rest of the window.

How can I get the game itself to stretch or change to the size of dosbox?

Reply 2 of 8, by TeaRex

User metadata
Rank Member
Rank
Member

ddraw is known to have issues with Windows 7. Look at DOSBox's console window to find out if ddraw even got used at all, and if what you're seeing isn't DOSBox falling back to surface output.

tearex

Reply 3 of 8, by robertmo

User metadata
Rank l33t++
Rank
l33t++

what is your dosbox version and where have you got it from?
what is your Operating System?
what are your PC specifications?

post content of "DOSBox Status Window" (in Windows: right click on its title bar -> edit)
enclose your dosbox's config file

Reply 4 of 8, by Solymr

User metadata
Rank Newbie
Rank
Newbie

Using windows 7, Dosbox 0.74, Specs: Intel i7 960 @3.72ghz, 12 gig of DDR3 RAM, GTX 295.

Content of console window:
DOSBox version 0.74
Copyright 2002-2010 DOSBox Team, published under GNU GPL.
---
CONFIG:Loading primary settings from config file C:\Users\kerleyj\AppData\Local\
DOSBox\dosbox-0.74.conf
MIDI:Opened device:win32

Config file contents:

[sdl]
fullscreen=false
fulldouble=false
fullresolution=original
windowresolution=1024x768
output=ddraw
autolock=true
sensitivity=100
waitonerror=true
priority=higher,normal
mapperfile=mapper-0.74.map
usescancodes=true

[dosbox]
language=
machine=svga_s3
captures=capture
memsize=16

[render]
frameskip=0
aspect=true
scaler=normal2x

[cpu]
core=auto
cputype=auto
cycles=fixed 4000
cycleup=100
cycledown=100

[mixer]
nosound=false
rate=44100
blocksize=1024
prebuffer=20

[midi]
mpu401=intelligent
mididevice=default
midiconfig=

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
sbmixer=true
oplmode=auto
oplemu=default
oplrate=44100

[gus]
gus=false
gusrate=44100
gusbase=240
gusirq=5
gusdma=3
ultradir=C:\ULTRASND

[speaker]
pcspeaker=true
pcrate=44100
tandy=auto
tandyrate=44100
disney=true

[joystick]
joysticktype=auto
timed=true
autofire=false
swap34=false
buttonwrap=false

[serial]
serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[dos]
xms=true
ems=true
umb=true
keyboardlayout=auto

[ipx]
ipx=false

[autoexec]
mount c d:\games\dos
mount d k:\ -t cdrom

Reply 6 of 8, by dosdog

User metadata
Rank Newbie
Rank
Newbie

I'm having the same problem with ddraw output in DosBox 0.74, and my specs and config are almost identical to Solymr's, right down to the GTX 295, Intel i7 (975) and Windows 7 x64.

While the opengl outputs do stretch to fill the window, ddraw does not. Also worth noting that switching to a 1920x1200 fullscreen with ddraw *does* fill the screen, indicating the problem is peculiar to windowed mode.

[sdl]
fullresolution=1920x1200
windowresolution=1280x1024
output=ddraw

Installing the latest nVidia drivers (both public and beta releases) was worth a shot but it made no difference.

Attachments

  • Filename
    opengl.jpg
    File size
    241.67 KiB
    Downloads
    251 downloads
    File license
    Fair use/fair dealing exception
  • Filename
    ddraw.jpg
    File size
    132.45 KiB
    Downloads
    251 downloads
    File license
    Fair use/fair dealing exception

Reply 7 of 8, by Solymr

User metadata
Rank Newbie
Rank
Newbie

Opengl does fix the issue, but it will not work under any circumstances with ddraw. Using latest beta or public drivers makes no difference, pretty sure I've had this issue since I switched to Windows 7, so might be an issue there.