VOGONS

Common searches


DOSbox Gravis Ultrasound Support?

Topic actions

  • This topic is locked. You cannot reply or edit posts.

First post, by Terrapin

User metadata
Rank Newbie
Rank
Newbie

Okay, so I've read the GUS post here on how to install, set up the ULTRASND directory, and how to point DOSbox to that directory within the .conf file. I've been able to successfully enable Gravis Ultrasound in a few games, but with some games I keep getting laggy sound that snaps, crackles, and pops. Most games that this is happening with are slightly graphic intensive (considering they're age-old DOS games) and/or they don't have proper .conf files available from D-Fend Reloaded's configuration database found while using the Add a Game Wizard.

I've tampered a bit with the mixer settings and increased/decreased the block size and prebuffer with varied results. Changing the block size definitely has an impact, but never quite makes the sound to a point where it's stable. I'm not sure if prebuffer has any sort of impact. I've increased it to 80 on certain games, but have received the same result.

Here is my GUS entry in my .conf:

#      gus: Enable the Gravis Ultrasound emulation.
# gusrate: Sample rate of Ultrasound emulation.
# Possible values: 44100, 48000, 32000, 22050, 16000, 11025, 8000, 49716.
# gusbase: The IO base address of the Gravis Ultrasound.
# Possible values: 240, 220, 260, 280, 2a0, 2c0, 2e0, 300.
# gusirq: The IRQ number of the Gravis Ultrasound.
# Possible values: 5, 3, 7, 9, 10, 11, 12.
# gusdma: The DMA channel of the Gravis Ultrasound.
# Possible values: 3, 0, 1, 5, 6, 7.
# ultradir: Path to Ultrasound directory. In this directory
# there should be a MIDI directory that contains
# the patch files for GUS playback. Patch sets used
# with Timidity should work fine.

gus=false
gusrate=22050
gusbase=240
irq1=5
irq2=5
dma1=3
dma2=3
ultradir=.\ULTRASND

EDIT:
Now, I have noticed that with Hocus Pocus, it has it's own .bat script that calls for GUS, but also has it's own executable that may enable it.

The batch file is as follows:

@ultramid -q  
@__hpgrvs
@ultramid -q -f

I'm pretty sure HPGRVS.exe configures GUS irq and dma, but then calls Hocus.exe making this file obsolete for use with any other games.

Are there any options I don't know about that would make Gravis Ultrasound more stable in the games I'm experiencing possible compatibility issues?

Reply 1 of 4, by olddos25

User metadata
Rank Member
Rank
Member

First of all, why do you have two IRQ and DMA entries? Normally there is only one IRQ and DMA entry. What build are you using?

Currently mod on several Discord servs and a forum, so you can trust me if you want a DOSBox mod here!
Other places to find me:
DraStic: http://drastic-ds.com (as dsattorney)
EPForums: http://www.epforums.org (as emulationfan)

Reply 2 of 4, by Terrapin

User metadata
Rank Newbie
Rank
Newbie
olddos25 wrote:

First of all, why do you have two IRQ and DMA entries? Normally there is only one IRQ and DMA entry. What build are you using?

I saw someone on the web using that config. They used dual irq and dma, I'm guessing one was for midi. I was having trouble getting DOSbox to recognize midi in some games and it was a workaround.

I believe I'm just using v0.74.