VOGONS

Common searches


First post, by missling

User metadata
Rank Newbie
Rank
Newbie

Running the 0.74-3 DOSBox.app on Mojave (10.14.5) returns a "package is damaged" error.

If I go into the package content and run the actual binary, it works. Still though this should be fixed.

Reply 3 of 6, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

very odd, I cannot reproduce this. it might be due to some certificate problem and/or the security settings on your mac to only allow App Store apps.

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 4 of 6, by Dominus

User metadata
Rank DOSBox Moderator
Rank
DOSBox Moderator

Actually seems my buildbot was not having the updated certificates anymore and all my VMs, main machine and buildbot just accepted it without throwing that error.

I was now able to reproduce the problem in another vm and also to verify that a new build is working correctly. Expect a new version shortly.

Thanks for reporting this!!!

Windows 3.1x guide for DOSBox
60 seconds guide to DOSBox

Reply 5 of 6, by Qbix

User metadata
Rank DOSBox Author
Rank
DOSBox Author

the new build (with same name) is up.
new sha1: 30bba3fadd50e98a67c9c8bb9fee076173226350

Water flows down the stream
How to ask questions the smart way!