Common searches

First post, by Innovative Machining

User metadata
Rank Newbie

i'm having trouble with my serial port communication on an rs-232 connection in DOSBOX communicating with a FANUC CNC controller. I had the same software setup with an older machine on windows 7 and It wasn’t having issues with communicating. I am wondering if this problem could be due to software incompatibility between windows 7 and 10. DOSBOX is emulating a CNC communications program called POWERSTATIONS. This program is communicating with HARDINGE VMCII 600 CNC machine.

I have a SUNIX DEL2S00PL 2-port RS-232 PCI Express Powered Serial Board that i’m using for the RS-232 communication. (ATTN): The power supply is not connected to the 6pin on the serial board. This was the same with my previous setup in the windows 7 machine and the serial communications worked just fine. I have attached the DATA SHEET for the serial card.

Troubleshooting: Here are the first few things that I've tried.

Feedback loop (shorting out the pins) with rs-232 connection failed. Program communication went into a looping error
Checked all the cabling connection which where all working correctly
Tried switching the com ports that I was communicating on, which resulted in the same errors

Here what the terminal in DOSBOX is outputting:

Run 1:
Serial1: Errors: Framing 0, Parity 0, Overrun RX:210 (IF0:57), Break 0


Serial1: Errors: Framing 0, Parity 0, Overrun RX:200 (IF0:41),TX:0, Break 0
Serial1: Errors: Framing 0, Parity 0, Overrun RX:200 (IF0:1),TX:0, Break 0
Serial1: Errors: Framing 0, Parity 0, Overrun RX:200 (IF0:0),TX:0, Break 0

Here is the code i’m running to start up the virtual serial ports and the program POWERSTATIONS.

My Serial port is configured as follows:
serial1=directserial realport:com1
serial3=directserial realport:com3
serial4=directserial realport:com4

Here is the code that runs the program:
mount c c:\dos

serial3=directserial realport:com3
serial4=directserial realport:com4
serial1=directserial realport:com1

cd ps

My CPU is configured as follows:

Here is how my com ports are configured in windows:

Bits per second: 9600
Data bits: 7
Parity: Even
Stop bits: 1
Flow Control: None
Under advanced -- I have 128 bit FIFO buffers enabled

I was wondering if anyone would know the cause behind the COM communication errors problems and know a possible solution?

Thank you


Reply 1 of 2, by Jo22

User metadata
Rank l33t++

I don't know how to help getting this to work in DOSBox, sorry.
However, you can try these:
- Try booting real DOS in DOSBox
- DOSBox-X
- MS-DOS Player
- Virtual PC 2007 with 2004 VM additions for DOS (+dosidle program)
- Qemu running MS-DOS 5/6
- Bochs running MS-DOS 5/6
- VirtualBox with DOS and limited CPU speed
- 86Box with serial pass-through (if available) and DOS
- Run Ecomstation or Blue Lion OS, both which are modern OS/2 Warp descendants

"Time, it seems, doesn't flow. For some it's fast, for some it's slow.
In what to one race is no time at all, another race can rise and fall..." - The Minstrel

//My video channel//

Reply 2 of 2, by junglemontana

User metadata
Rank Newbie

I understood that you used DOSBox with that CNC control software on Windows 7, and the same PCIe -> RS-232 card. And everything was working well. Is that correct?

Which DOSBox version are you using? I think someone said that serial issues were fixed in the newest (or SVN) release.

Are there configuration options for the COM ports in the CNC software? Have you set all parameters to the same values as in Windows port settings?

Have you tried any other serial equipment and software to see if the serial ports really work?

(I'm not sure, but if you don't have any other serial devices, I think it should be possible to run two local terminal programs such as PuTTY and make them communicate with each other using a nullmodem cable. For example, plug the nullmodem cable to COM ports 1 and 2, then open one terminal on COM1 and other on COM2. If you have a serial terminal for DOS, you can try this in DOSbox as well, for example, PuTTY on COM1 on Windows and the other terminal on COM2 on DOSBox. Don't reserve COM1 for DOSbox in this case.)